Jump to content

-fsopen error: cannot open file

Recommended Posts

Someone here was doing an overnight rendering of a model (VW9.5.3) on his machine (MacOSX.2.4) although the file itself was on a networked drive (MacOS9.1).

The scheduled overnight backup (Retrospect) tried to read the file for copying, but found that it was busy/locked, so it didn't copy the file. Not quite, anyway; a new copy was made, 0 kB (stupid Retrospect).

This morning, the operator tried to access his file, but with no response, had to do a force-quit. The current copy of the file is still 4.4MB, but both the OS9 host and OSX client indicate that the file is in use, since VectorWorks never closed the file stream.

Why oh WHY does VW keeps its grubby hands on the ACTUAL file? Good practice is to work on a temp file stream, eh?

Anyway, I can't open the file by any means I know, so does anybody have any ideas?

Link to comment

Okay; I fixed the problem. The busy/locked status of the file when checked by Retrospect essentially tied Finder's shoelaces. I logged everybody out, shut down network apps, but when I tried to shut down the server, I get a Finder error -11 bomb. A simple soft boot restart solved the file open/closed status.

All is well and good now, AFAIK.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...