Jump to content
Sign in to follow this  
J Lucas

2016 Random Crashing

Recommended Posts

Compared to 2015, 2016 has been crashing a lot. The crashes appear to be random. I have not been able to identify a pattern. Anyone else experiencing this? For me 2016 is not stable compared to 2015.

Share this post


Link to post

The same crashing still occurs for you on Windows after installing SP1?

Share this post


Link to post

Sorry, yes it just came out end of yesterday, I am not sure if the app itself is alerting users yet.

Share this post


Link to post

Is it replicable, meaning the same steps cause the same crash after relaunching? or cant replicate it?

Share this post


Link to post

I have been experiencing this from day one with 2016. I waited a while to post to see if I could detect a pattern. The only thing that I know will usually make it crash is if I get going to fast and execute a command before the last one has completed. Once I noticed that I tried to slow down a bit. But now I still am getting "random" crashes at a much higher rate than 2015.

Share this post


Link to post

i´m architect and urban planner i live in Brazil. I teach vectoworks in cadtechnology.

i´m user vectorworks since 2006, and love software.

I new in community, and my vectorworks 2016 crash random to.

My version is 2016 sp1, my currently OS version is:

sorry about my english.

64 bits windows 7

16 ram

i7 4790

64bits

Edited by Henrique Lauer

Share this post


Link to post

Hi, Look at this post, Its easy to crash the program in a few minutes by following my post. Just move the mouse back and forth over the attributes pallet fast and you see the GDI numbers rise quickly and then crash.

https://techboard.vectorworks.net/ubbthreads.php?ubb=showflat&Main=43487&Number=218339#Post218339

I am told the fix is coming soon.

Hopefully very soon.

Share this post


Link to post

I've experienced the same kind of issues J Lucas. I find I'm "going to fast" and Vectorworks is trying to keep up so I to try to slow it down a bit. I find this unacceptable though. I don't like that I have to think about doing various functions in a manner that will keep the program from failing or locking up. Rather than just doing them with out consequence and getting the job done in a timely fashion. Response time is way to slow.

Share this post


Link to post

After updating to SP2 two days ago, I'm experiencing a crash about every 10-15 minutes. Editing a workspace is a guaranteed crash. I just crashed using the attribute tool to scale a texture. Sometimes clicking on a toolset icon doesn't refresh the list of tools pertaining to the newly selected toolset. Clicking onto another toolset and back again to the desired selection causes a crash.

What should have taken me 1/2 a day to finish the drawing I'm currently working on is now proceeding into day 2.

Share this post


Link to post

If crashing seems to have changed dramatically after a service pack, do the following to back up your preferences:

http://kbase.vectorworks.net/questions/885/Backing+Up+Vectorworks+Preferences

Then set that aside in a folder on your desktop or somewhere for safe keeping. Afterwards, reset the preferences back to stock:

http://kbase.vectorworks.net/questions/1099/Resetting+Vectorworks+Preferences

DO NOT restore your preferences or workspaces before testing, then try to replicate a crash, try outrunning Vectorworks or try hammering the workspace editor and see if it seems more stable or less so. Let me know the results. If you are getting regular and severe crashing though, make sure to contact Tech Support directly as well, their response time may be faster than mine:

tech@vectorworks.net

Share this post


Link to post

Just crashed again just now. Seems to happen when changing views in a fairly complicated 3d model.

I've found 2016 pretty snappy speed wise, in fact it saves to disk much more quickly than did 2015 for some reason.

Share this post


Link to post

I am also getting random crashes, Simple zoom out and spinning ball shows up and does not go away. Also when pasting object randomly crashes.

Also crash during rotate page.

MacBook Pro (Retina, 15-inch, Late 2013)

2.6 GHz Intel Core i7

16 GB 1600 MHz DDR3

Macintosh HD

Intel Iris Pro 1536 MB

OSX 10.11.2

VW2016SP2

Edited by Joe 4449

Share this post


Link to post
I am also getting random crashes, Simple zoom out and spinning ball shows up and does not go away. Also when pasting object randomly crashes.

Also crash during rotate page.

MacBook Pro (Retina, 15-inch, Late 2013)

2.6 GHz Intel Core i7

16 GB 1600 MHz DDR3

Macintosh HD

Intel Iris Pro 1536 MB

OSX 10.11.2

VW2016SP2

Just crashed again just now. Seems to happen when changing views in a fairly complicated 3d model.

I've found 2016 pretty snappy speed wise, in fact it saves to disk much more quickly than did 2015 for some reason.

What behavior occurred after the preference reset/backup described above?

Share this post


Link to post

Since I updated to SP2 its been very stable, can get through the whole day without a crash.

Been working on a busy interior with a few 3D warehouse mesh object in like bath refrigerator etc and I can get a black screen when rotating but I think that is the graphics card catching up, I click screen and it turns white and a few seconds later the file is running ok again.

The only crashes so far is when I have tried to extract a face off a subtracted solid surface (recess in a curved wall face) and changing and making textures.

Other wise its 1000% better.

Share this post


Link to post

Crash 2016SP2 consistently crashes.

This will do it everytime.........Rotate Plan ( I am doing 18 degrees. Add simple object to drawing. Zoom out and then drag drawing. Then program hangs, spinning ball.

This is on new clean install with preferences striped out as suggested by JimW in thread above.

Very frustrating. Moving back to 2015 until this is resolved. ;-(

Just back converted t0 2015. 2015 works just fine.

MacBook Pro (Retina, 15-inch, Late 2013)

2.6 GHz Intel Core i7

16 GB 1600 MHz DDR3

Macintosh HD

Intel Iris Pro 1536 MB

OSX 10.11.2

VW2016SP2

Edited by Joe 4449

Share this post


Link to post

Updated to SP2. As mentioned, editing workspace slows it down, then crashes. Also, simple tasks like "Use Default Attributes" on an object when assigning to a class crashes it every time, pre and post SP1 and SP2.

Not sure why such a basic task would crash it?

Share this post


Link to post

Seem to crash when I use "Use Default Settings" in the attribute palette. Any explanations would be appreciated, since I often draw stuff, change it to the class I want. Changing to a class and using defaults shuts it down every time.

Share this post


Link to post

We've also experienced frequent crashes while using 2016 with both SP1 and SP2. Below are some of the commands that have caused repeated crashes that we have noted so far:

- Save and commit project sharing file. The program will save the working file and then crash while committing to the project file.

- Editing multiple classes through the organization dialogue box in a project sharing working file.

- Deleting multiple classes through the organization dialogue box in a project sharing working file.

- Too many successive undo attempts in a short period of time causes the program to hang and crash.

- Changing Viewport graphic overrides on sheets not previously checked out will occasionally result in a crash.

These crash instances are marginally reproducible, and happen across several projects that we have in the office.

Share this post


Link to post

#4 & #5 as well as a new one we've found today:

- With two drawings open. One imports a symbol through the Resource Browser often the Programme gets confused as to what File is the Active File & what file is the Source File and either crashes or just fails to import the symbol until the Programme is restarted - A Crash in all but name IMHO.

(It may not help that these are VW 2014 files that have been batch converted.)

Share this post


Link to post

BTW, heard from a colleague, that his former firm has decided to stick with VW2015 until further notice as Crashes were too frequent. I've not spoken to the folks at this firm to get their take, but will do so in the new year.

Share this post


Link to post

Same here, I have random crashes when doing more or less complex layer or class operations. Or sometimes it's just simply opening/closing a group or symbol. Sometimes it's just taking time, which means it takes several minutes to change from one layer to another. It seems that something triggers endles arithmetitc operations in the background.

One thing defintely works:

After closing and opening Vectorworks the problems dissappear for some time...haven't checked yet how long.

Share this post


Link to post

Hello;

I get crashes with Vectorworks 2016 right after saving the file (to an existing file) and then trying to use the flyover tool 3D.

This is not random as it happens every time.

My work-around is to use another tool first, then all is well. It feels like a system glitch.

Vectorworks 2016 Architect/Renderworks

MacBookPro Retina 15 Mid 2015 / 16G / 550G flashdrive / 2.5 GHz Intel Core i7

El Capitan 10.11.2

Toronto, Canada

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×