Jump to content

worksheet doesn't update change in record field

Recommended Posts

I have a worksheet that lists all the objects on a layer with a record attached. When I update a field for an instance of a symbol the change doesn't appear in the worksheet when I re-calculate the worksheet. I tried deleting the record attachment and recreating it , but that didn't make any difference.

I'm using VW 9.5.2 and MacOS 8.6

Link to comment


Are you changing the data for the symbol in the Resource Palette, or are you changing the record data when the object in the drawing is selected, or are you editing that object in the drawing and making changes to the data?

Rules for symbols and records:

When making a universal record data change for a SYMBOL DEFINITION, edit the symbol in the Resource Palette -2d edit.

Do NOT select the symbol - the objects need to be deselected.

Make changes under the Data Pane in the OIP.

This change will affect all symbols in the drawing and any new symbols created.

To change the Record Data for a specific SYMBOL INSTANCE in the drawing, select the symbol and make changes in the Data Pane of the OIP wihtout editing the symbol.

If you have a symbol in the drawing and edit the symbol, the changes made in the data pane will apply globally if the objects are not selected in the Edit Symbol mode. This is applying the change to the symbol definition.

If the objects are selected, the change of data will only apply to the symbol instance, not the definition.

Link to comment

Jim, Katie, thanks for your replies. I'm still having problems. My symbol has a 3D locus embedded which has the record attached. This represents the centre of gravity (CoG) of the symbol, which is not at the geometric centre. Updating this record, either from the symbol in the drawing or from the resource pallette doesn't track through in the worksheet.. The worksheet is used to calculate the centre of gravity of the complete installation. I tried making the CoG a symbol, but this didn't seem to help. The workaround seems to be to take the CoG locus out of the symbol, and place it seperately, but this is counter-productive.

regards, Steve

Link to comment

Jim, you were right, it is to do with the nested symbols. I searched the messsage board for nested symbols and found the answer.

Adding "INSYMBOL" to the criteria does the worksheet update OK

=DATABASE(INSYMBOL AND (L='Layer Name') AND (R IN ['Record Name']))

The INSYMBOL is an option in the Create Report dialog, but not when a worksheet is created in the resources palette.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...