Jump to content
Sign in to follow this  
fabrica

El Capitan

Recommended Posts

I would love to see comments from any canaries that have taken the plunge into El Capitan.

Probably a question that Jim can't answer, but Jim, is there any sense of how long it might take to crank out the first service pack for 2016 to get some nominal El Cap compatibility?

Hello - it's that time of year again!

Any more news on whether either 2014 or 2015 will work in El Capitan? If not, will there be service patches or are we forced to upgrade to 2016?

More word on this from management:

The reason that our compatibility with OS X 10.11 is delayed is because the final beta seeds that we get from Apple are not always (often not) the same as the release builds that go to the public on launch day.

We are only able to perform the final compatibility checks once the final OS release versions come out, and the service packs for 2016 and 2015 are delayed partly to make these versions both compatible with Windows 10 as well as OS X 10.11.

We have not seen any issues preventing Vectorworks from launching, users are of course in charge of whether they take the plunge early and update to the latest Mac OS right now. But we have seen enough issues that we do not recommend upgrading to 10.11 unless you have a strong and pressing reason for doing so.

Share this post


Link to post

Thanks Jim, i am an update junky but still need to get my work done, do they have a list of the conflicts/issues that exist?

Share this post


Link to post

Unfortunately not. That will only become public in a list once the respective SPs are released, the fixed items will be in the release notes.

Share this post


Link to post

This is not a VectorWorks issue - but it will affect anyone trying to print using VWX and Gutenprint.

Gutenprint is broken - so if you're using an older HP DesignJet, you won't be able to print. None of their drivers install (fail - no software found to install), and for some reason OSX can't find the old ones, either.

(I only installed 10.11 on my secondary computer, so no panic - yet)

Share this post


Link to post

I have started having LOTS of users report older DesignJets losing OS compatibility over the last few OS versions, and HP has not released new drivers for many older models. I would fully expect that issue to get worse as OS versions advance.

Share this post


Link to post
This is not a VectorWorks issue - but it will affect anyone trying to print using VWX and Gutenprint.

Gutenprint is broken - so if you're using an older HP DesignJet, you won't be able to print. None of their drivers install (fail - no software found to install), and for some reason OSX can't find the old ones, either.

(I only installed 10.11 on my secondary computer, so no panic - yet)

In OS X 10.10 Yosemite, Apple tightened the security access to the printing subsystem (also known as 'Sandboxing') so there is a chance that your failed printer drivers might be related to that change.

Additionally you might have luck using OS X's built-in CUPS printing, but it may also restricted by Sandboxing.

You might be able to find a printer driver for your legacy printer on this website: OpenPrinting : Printer List

The web interface for CUPS is turned off by default in 10.8 and beyond. To enable it enter the following in terminal:

cupsctl WebInterface=yes

Then to access CUPS, direct your browser to http://localhost:631/

If you have or can find a printer driver for 10.9 on HP's website, the driver is not signed for Yosemite so it may get blocked by the Gatekeeper. The 'secret password' to get past the Gatekeeper is to hold down the Control key and click on the installer. A pop-up menu will appear and select 'Open', and you'll be allowed to install the driver.

HTH.

Share this post


Link to post

Thanks. Gutenprint uses CUPS drivers, and it worked fine under Yosemite. This might be a rootless problem. In any case, Gutenprint (GIMP-print) is supposed to be working on a fix (I can still print from my main, non-updated computer running Yosemite).

Share this post


Link to post

Mike - yeah I also read over at the gutenprint mail-list that they were working on a fix which should be available soon.

Share this post


Link to post

I haven't upgraded yet to El Capitan because of issues mentioned here. But, I am wondering, when one refers to older HP plotters, just how far back one has to go to be concerned. I have an HP Designjet 510. Will that model be affected by upgrade to El Capitan? No issues with it on VW 2015/2016/Yosemite. Thanks.

Edited by skfurn

Share this post


Link to post

It seems that El Cap is not a compelling upgrade. At least not enough to risk the stability of our fledgling VW2016. I'm looking forward to some of the features and performance promises however I'm listening out for the canaries rather than being one this time.

Share this post


Link to post
I haven't upgraded yet to El Capitan because of issues mentioned here. But, I am wondering, when one refers to older HP plotters, just how far back one has to go to be concerned. I have an HP Designjet 510. Will that model be affected by upgrade to El Capitan? No issues with it on VW 2015/2016/Yosemite. Thanks.

From HP's Support website via Google search for "hp designjet 510 El Capitan":

HP Designjet Printers Supported in OS X v10.11 El Capitan ... through OS X v10.7 Lion

It looks like it your HP DesignJet 510 is supported in OS X 10.11 El Capitan, but as bcd said, I would still wait.

HTH.

Share this post


Link to post

Thanks for the link...and advice. Yes, I think I'll hold tight for awhile before El Capitan update. Just not worth dealing with VW issues.

Share this post


Link to post

I ran VW 2013 with 10.11 today and it worked fine until I tried to quit the VW software. I got a message that VW 2013 crashed on closing. Is it possible that this is an issue with preferences that need too be erased and rebuilt? I only use VW 2013 for one client who refuses to upgrade.

I have also ran VW2016 today with out issue but I suspect I was just lucky.

Share this post


Link to post

Do you have an older machine with an older OS to run 2013 on? Or why not batch convert the file to 2016 then export it as a 2013 file when finished?

(One of the reasons I keep my old MacMini is for a similar client with 2012)

;-)

Edited by Jim Smith

Share this post


Link to post

Thanks. Removing the VW-2013 preferences and resetting the auto save location worked for me. VW-2013 has been working all morning. I must not be using the tools yet that will break it. It has not crashed on closing today.

I do have an older Mac a G5 with MiniCad and FormZ just so I can go back and reference old jobs from the dark ages. I have not had to use it for over a year. Still looks cool. :-)

Bob Tiedemann

Share this post


Link to post

@Chris Busch.. good to know.

Could you briefly describe the conditions.. like what size files and generally what sort of paces you're putting 2016 through..

Thanks in advance for your reply.

Share this post


Link to post

Good to know.

I upgraded may Mac Book and Mac Mini to EC,

no time to try VW 2016 on Mac Book so far.

But EC in general :

- do not see or notice any differences to 10.10 so far

- some said it will be faster, I do not notice anything

- Installation took much more time than any other upgrade before.

This time "will take 45 minutes" - will take 45 minutes :)

- I had to delete and redo all Time Machine Backups on my Mac Mini from scratch.

Including Kernel Panics on the Mac Pro because Time Machine disk was broken

on Mac Mini.

Share this post


Link to post

Hi dtheory,

Generally files that are about 80-100MB with 1-2 referenced files making up 10-15 design layers plus maybe 20-30 sheet layers. I do museum exhibition design work so other than basic floors and walls most of my textures are applied to small objects but there are some moderately complex geometries too.

I am noticing a somewhat drastic drop in quality when using "fast" renderworks, but "final quality" renderworks seems good and the render times don't seem to be any faster. I'm actually not sure if that's due to VW or OSX though. I hadn't done much rendering in the space in between upgrades.

Also, walkthroughs are a little choppy now that I try it some more, but again, not sure if it's VW 2016 or El Capitan.

I'll post again if I notice any glitches.

Share this post


Link to post

Hmmh,

I also would risk to upgrade to EC for VW 2016 before SP1.

But VW 2015 has run without any Issues though.

Someone had any bad EC experiences with EC + VW 2015 ?

Edited by zoomer

Share this post


Link to post

Thanks Chris,

I went ahead and took the plunge and installed El Cap.

So far the only glitch seems to be an increase in the incidence of docked palettes

becoming "un-docked" between restarts of the computer.

I'm doing residential design, file sizes 50-200 MB, 12-14 to maybe 40 sheets probably an equal number of design layers. a small number of referenced files. I'm on an older machine, somewhat more recent video card, performance seems more or less similar to VW 2015.. I am on a fast SSD as my boot drive, that certainly helps with opening larger files.. and loading assets, obviously not with rendering or other processor bound actions. I can post more details if anything of interest pops up..

Share this post


Link to post

I also did it :)

Couldn't resist ...

Well see ....

But said Installation Time is no more in SATA I HDD minutes,

it's now measured in real PCI SSD minutes

Share this post


Link to post

I took the plunge also - works fine on the office retina iMac......no issues.

... but is not working on the home 2013 iMac - crashes on start-up (normally takes 3 attempts to load) - crashes when I open a file and I get black palettes if I try to move them , then crashes .. have tried to uninstall and reinstall but to no avail.

Also gives me the 2015 icon for drawing files rather than the new red 2016 one.

Graphics card issue? (older iMac has a NVIDIA GeForce GT 755M 1024 MB)

Share this post


Link to post
I took the plunge also - works fine on the office retina iMac......no issues.

... but is not working on the home 2013 iMac - crashes on start-up (normally takes 3 attempts to load) - crashes when I open a file and I get black palettes if I try to move them , then crashes .. have tried to uninstall and reinstall but to no avail.

Also gives me the 2015 icon for drawing files rather than the new red 2016 one.

Graphics card issue? (older iMac has a NVIDIA GeForce GT 755M 1024 MB)

Create a new user account on that machine:

http://kbase.vectorworks.net/questions/805/Creating+a+New+User+Account+%28Mac+OS+X%29

Reboot, then login to the new account and tell me if it behaves the same way.

Share this post


Link to post

So far VW works with El Capitan for me.

The only thing that lets me regret upgrade to 10.11 is that I can't use my MadCatz Mouse

anymore. So I had only 2 days of fun with it.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×