Jump to content
Sign in to follow this  
GeoffreyP

Calling on Mac gurus for help

Recommended Posts

I'm not getting proper performance on VW 9.5.2 -- crashes, painfully slow rendering for the size files I've drawn, etc. I'm running OS 9.1 on a G4 with dual 500MHz processors and over a Gig of RAM (I provision a minimum of 200Mb for VW)

I'm hoping that there is a recommended set of extensions and possibly other settings that will optimize performance.

Also, I routinely 'print to file' for turning into PDFs. On some larger files (only around 10MB or so, not huge) I have had the process fail, and an 'insufficient memory' message. Does anybody know where additional memory should be provisioned? I understand that Renderworks works outside of VW (using the memory that isn't taken up by VW) so is there a way to devote more memory to the rendering/printing process?

Thanks in advance for any suggestions!

Share this post


Link to post

Thanks for the swift response Katie ? although I'm still a bit in the dark. I'm already using OS 9.1, and I have a hard time accepting the notion that over 800MB of RAM wouldn't be enough for rendering and printing operations even if VW was using the other 200MB that I've got. (I'll reduce it to 125MB as you suggest, though) I have reloaded the system software, reloaded Vectorworks from 9.0 through 9.5.2, run Norton Disk Doctor and done everything I can think of short of pouring Drano through the CPU.

When using Custom Renderworks, I set detail on high, and select ray tracing, recursion levels to 4, textures, transparency, and NURBS if they are used in the drawing. (Are these settings in error?)

Regarding extensions, please ask around and see if the folks in the white lab coats down in the bunker can recommend any settings. (I do know that the more extensions are enabled the harder the system has to work, and there can be conflicts with certain extensions when running some applications. Maybe creating a custom configuration for VW would help?

Thanks again

Share this post


Link to post
Guest

Generally speaking, the Base OS extensions set is what the minimum the system needs to run, along with what VW needs to run.

So whatever you do over that can lead to bogging up the computers memory.

Everyone has something different installed on their computers outside of the system information. Setting a custom extension set for an individual computer is not something we can guarantee.

So I'm not sure what exactly you are looking for.

Rendering speed is based on the ammount of RAM you have and CPU speed power.

Reducing the allocated memory setting for VW should free the computer up to do some other background things and assist with the printing issue.

I don't know what type of speed "improvements" you are looking for .. but depending on what's in the drawing, the type of objects that are in the drawing, the complexity of textures and the image size of the textures can all contribute to the time needed to render.

If you have a complex drawing, the rendering time is up there.

Adding memory doesn't really help speed up the rendering process significantly at any rate.

It might shave a moment or so off the final rendering time, but nothing too impressive.

Share this post


Link to post

Hi, Geoffrey. I have a similar but less powerful setup (VW9.5.2, OS 9.1, G4 with 2 processors, 450MHz, 512 MB built-in memory). I also set my preferred memory to 200MB when rendering. I turn on virtual memory (only for large files) in the 800 MB range when. I've had good luck with this. Have you tried messing around with your virtual memory settings?

Share this post


Link to post

I can't comment on the PDF issue, but as far as your rendering speed there are a few things that wlll siginifigantly increase your rendering time.

Multiple light sources

reflective materials

transparent materials

complex geometry.

Also, what do you consider a long rendering time. When it comes to ray trace rendering in VW/RW, some of my more complex scenes can take up to 45 mins to render on screen, and several hours to export an image file (G4 733, 384 Mb ram, OS 10.2.4). Its just the nature of the beast for ray trace renderers, they are processor intensive, and memory hogs. Also dont forget that your dual processor machine is acting like a single 500 Mhz machine when using VW/RW, VW is not a multithread app.

I would suggest moving to OS X if possible, it seems a bit quicker, and OS X is optimized to use your dual processors more effeciently.

Good Luck

Share this post


Link to post
Guest

The first thing I suggest is updating to OS 9.1.

Running with the base system extension will turn off all unnecessary applications and maximize sysmte performance.

You can also use disk utlitliy to clean up the hard drive in the even that the hard drive is where the problem lies.

If you have too much memory allocated to an application, that limits the amount of free memory able to be allocated to other things running and for the system to take advantage of.

I think having 200megs of memory allocation to VW is too much. You shouldn't need more than 125 and that's pushing it. I've seen a few RARE cases, where this setting has needed to be set more than that .. but like I said, it's not very often.

When creating a plot file, the plot file is being written outside of VW. If you are getting out of memory errors when writing the print file, this could be one of the side affects from having too much mem. allocated to VW.

You say rendering is slow.

What rendering mode are you using?

If you are using Open GL or Custom RenderWorks, what are the settings for the rendering mode?

[ 03-12-2003, 12:26 PM: Message edited by: Katie ]

Share this post


Link to post

Thanks, Katie, Kristen, and Mike B! It looks like OSX running on the base extensions is the way to go. I had been putting off switching because my font management software won't work with OSX, but I'll just have get some that does. It seems clear it will be worth it.

Share this post


Link to post

Hello, Geoffrey. I?ve read your questions and the answers you got, and I think Kristen and Mike are, in my experience, absolutely right (I use a G4 533, 896 Mb ram). But if your copy of VW uses a dongle key, I would suggest you to think your switching over. You might like to first read "problems w dongle" @ "Tech Note and How To Suggestions", where I posted my own unsolved switching problems.

Good luck

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...