Jump to content
Sign in to follow this  
Henry Finch

inability to snap at times

Recommended Posts

VW10.1 seems pretty good and stable except the snaps are unpredictable, Snap to object often doesn't work in 2D on 2D objects when zoomed out a bit. The ALIGN to object edge seems to overpower the object snap which didn't happen in VW9.5.3. It is usually hard to drag one object to another objects corner. This has reallly slowed down production for me.

In the past my troubles with new VW releases were occasionally not learning changes in how the new VW worked. If anyone has insight on how the snaps work differently in VW10.1 I'd like to know.

When VW 9 came out it had great features but had such significant slowness in standard operations that I felt it was cost ineffective to use until VW9.5 came out. VW9.5.3 is great and I just might stay with it until more of the bugs are worked out in VW10.

MAC 1.25Ghz dual, 768MB ram, OS10.2.4

Share this post


Link to post
Guest

In order for snaps to work, the correct constraints need to be turned on.

As far as one snap overriding another snap - it depends on how the objects are drawn and the stacking order.

The snap you want may not be executing because of the order the objects were drawn where an edge may be overtop an edge of another object.

If you draw to rectangles where one edge of the rectangle overlaps the other rectangle, and want to snap to the corner of the first rectangle -- you won't. You'll snap to the rectangle drawn last - on top of the stack.

Essentially, in this case, it doesn't matter since the corner or the rectangles are in the exact same spot .. I was just trying to give a basic example.

Is this what is happening with you?

If not, please include the steps and types of objects being used so we can attempt to duplicate it in house. If it's acting as it should, we can comment on that. If it's a bug, then we can add it to the bug list and have it addressed for a future version.

Share this post


Link to post

quote:

Originally posted by Henry Finch:

... It is usually hard to drag one object to another objects corner. ...

Oddly enough, I found this problem with version 10.0.0, but found that it's gone in 10.1.0 (on a Windows machine).

The problem, as I finally figured out, was that I would get the screen hint and cursor type for grabbing a corner at times when I wasn't really poised to grab a corner. So when I grabbed that non-corner point and dragged it to another object's corner, the result was the corners not coinciding. But as I said, it's cleared up in version 10.1.0

Share this post


Link to post

I have several users (on VW10.0 Mac) that have complained about their inability to snap to objects. They try to snap to the end of a line or the corner of a rectangle or polygon (with all the proper snaps turned on), and they either cannot get the cursor to snap to the point or they think it snapped but the line is obviously not at the preferred snap location.

We first tried LOWERING the snap radius below 5 pixels, but we found it's actually better to RAISE it above 10 pixels. We're still experimenting, though. I will let you know if VW10.1 fixes the problem for them.

Sarah

Share this post


Link to post

I'm also having problems with "snap to object", even when it is the only constraint turned on. I've tried raising and lowering the snap radius, to no avail. I often can only get the "align" cues, I can't catch a "point". Especially if there are other objects nearby (although not overlapping). Zooming in doesn't help, either. Also, it seems impossible to snap to symbols and groups. Is this the case? This is becoming handicap. Possibly snapping works differently than in VW8 and 9? If so, in what way?

VWA10.1, OS9.1

[ 03-19-2003, 09:50 AM: Message edited by: Kristen ]

Share this post


Link to post
Guest

Snapping in Vw 10 is essentially the same as previous versions in VW.

You cannot snap to objects on other layers other than the active one if they are different scales or in different views.

Also, you cannot snap to objects on other layers with the same view and scale if you do not have Show Snap others for layers (and classes if need be).

If you only have Snap To Object constraint turned on and are not getting snaps, make sure you are snapping to an object on a layer with the same view and scale.

Also make sure you have the correct layer and/or class options enabled.

Also make sure you have "Smart Cursor Cues" checked in the Edit tab of VW preferences (File>Prefs>VW Prefs).

You can also make the snap radius higher, such as 7 or 10 or 12 to get a quicker or easier snap.

going higher than 12 or so might not allow you to get certain snaps that may be desired from time to time.

Share this post


Link to post
Guest

If there's a file where you are having troble snapping, please send it to me along iwth the objects you are trying to snap to. I can try it out here and see if it is difficult and see if there is a way to work around it.

Include the snaps you have turned on in the Constraints palette and the setting for the snap radius in VW prefs.

Share this post


Link to post

I've noticed that sometimes if you are editing inside a group and you try to snap to an object that is outside the group AND is outside the original rectangle encompassing the group, you cannot snap to it. (This is with "view objects outside group" preference turned on.)

Share this post


Link to post

What I find (all VW versions on Windows machines) is that while inside a Group I can't snap to any objects on other layers, but can snap to all objects on the current layer, regardless of location.

Share this post


Link to post

my finding :

when in a group,

in the beginning the snaps work fine,

but then when I pan the screen while in a command

- I then loose the snaps

my work around :

I exit group and then go back in

Share this post


Link to post
Guest

If you go to File>PReferneces - Display tab - there is an option called "Show Other Objects While in Groups".

If this is checked, you will only be shown the other objects in the edit group method. You can snap to other objects in another group or something in the Edit Group mode IF the snap points are within the boundary of the original group used when going to Organize>Edit Group.

If this is NOT checked, you'll be able to snap to anything while in Edit Group mode if class and layer options allow you to.

This is different behaviour from VW 9. I am looking into the problem to see if it's as intended or a bug.

[ 04-04-2003, 04:26 PM: Message edited by: Katie ]

Share this post


Link to post

Katie,

That's completely different from my experience with all versions of VectorWorks on Windows.

If "Show Other Objects While in Groups" is NOT checked, then I can't see anything but the group while editing it. It's similar to editing a symbol. And that happens regardless of "Layer Options" setting.

If it's checked, then I can see everything else while editing the group, just as before editing the group, and can snap to other objects on the same layer but not on other layers, again regardless of the "Layer Options" setting.

And none of that is affected by where the objects are located or by how long I'm editing the group or whether I've done a transparent Pan in the group.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...