Jump to content

Textures moving in Renderworks


Recommended Posts

This is my first posting on the forums so I apologise in advance if I break any etiquettes. I have been using Vectorworks for 10 years now and never come across this problem before.

I am running on a 2014MBP with the latest up to date version of VW2015 architect with renderworks (2015 SP4 Build 267630 - 64 bit).

I have built a simple exterior model with basic extrudes, walls and doors. I have applied a range of custom textures to the objects by creating tile-able images in PS ensuring the jpgs are small to minimise render times and memory usage. I have applied the textures to the extrusions and positioned them using the "Attribute mapping tool", specifically for the pillar tiling and branding. This all works fine under test renders with OpenGL (see attached files)

However, once trying to render using any of the renderworks modes the textures shift by some unknown arbitrary value. (see attached files)

If I group the objects and run the same renders inside the group the textures render correctly (see attached files).

I have tried everything I can think of to remedy the problem with no success, I have tried rebuilding the textures, rebuilding the objects ensuring no overlapping geometry, reformatting the images to 1:1 (squares) all have been unsuccessful. I have even tried moving the model piece by piece to a new file to see if it was one object causing the problems.

I am completely at a loss for how to solve this, any help would be appreciated before I try manually bumping the textures until they sit right...

Thank you for your assistance.

Link to comment

Hi Jim,

No, when any of the pieces are in isolation in a new document they render fine in openGL and Renderworks mode, there is no offset.

As I mentioned I tried bringing the objects to a new file piece by piece to identify what might be causing the rendering problem but it seems to randomly occur and I can't pin it to one texture or object.

Link to comment

I have finally sussed it out, but it is only a temporary work around until I have time to investigate further.

The culprit was the Curtain walls used to create the glass store fronts. I ended up converting them to groups then generic solids and now the textures all work perfectly. (attached test render using renderworks)

If I figure out what is causing the problem using curtain wall I will post my solution. Don't know if anyone can replicate the problem on their machines or if it is a one off on mine, but would be good to know if anyone else has the problem.

Edited by nplache
Link to comment
  • 2 weeks later...

I've had that problem in the past and just last week. Sometimes I've had images fine in Open GL that then flip in Custom RW, in fact, i am updating last weeks file and the texture map moves up and flips. I just adjust it to be correct in Custom RW, don't have the time to track down why and I don't care about the Open GL rendering. A lot of my work is too complex for Open GL so I work in wireframe most of the time (plus I'm old school) and render in Custom.

Link to comment
  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...