Jump to content
Sign in to follow this  
Benson Shaw

Publish is rasterizing text

Recommended Posts

Just noticed that my Published to pdf sheets always have rasterized text. The option for rasterize text is disabled in dialog for each sheet.

To test, I enabled the option, published (= rasterized text), then disabled the option and published again. Same result. Text is rasterized.

Export or Print to pdf produces unrasterized text, as expected.

Did I miss a Publish setting or pref?

Thanks!

-B

Share this post


Link to post

I am unable to replicate this on Windows or Mac.

If you create a new blank file and add a single text object, then viewport it to a sheet layer and publish or save a view of it and publish with Rasterize Text off, does it still do it?

Share this post


Link to post

Yes. Still happens. - Attached is vwx created after system restart, and pdf created via Publish.

Publish options for pdf of this sheet layer have disabled the Rasterize Text.

Some other setting or pref?

-B

Share this post


Link to post

Hi,

On the export panel I Have un-ticked the rasterize text box and I get this. Appears to be un-rasterized.

Share this post


Link to post

Thanks for looking , Alan! Are you using Publish or Export?

Export works as expected.

In Publish, I have the box unticked, and still get the rasterized output.

-B

Share this post


Link to post

Export and publish from your file and got the same results.

Both appeared to be NOT rasterized like my previous post.

Edited by Alan Woodwell

Share this post


Link to post

Same meaning as your previous? or same as my results?

PDF text is rasterized from Publish?

Anyway, thanks.

My pdf text is always rasterized from Publish. Whether I check or uncheck the Rasterize Text option makes no difference. Export and Print to PDF the text is not rasterized.

???

-B

Share this post


Link to post

Sorry the forgot to include the files.

Both export and publish from your file produced the un-rasterized result.

Edited by Alan Woodwell

Share this post


Link to post

I have this same problem on my iMac.

Publish rasterizes the PDF. Print to PDF works correctly.

I'm switching to VW 2015 from VW 2013 and

mac mini 2009 to iMac late 2013

henry

Share this post


Link to post

Henry - a theory:

It's the font! I'm using Avant Garde. If I switch to Geneva, or Century Gothic, or several others, the text is not rasterized.

But this is new to v2015 and mac OS10.9.5. Avant Garde was not rasterized by Publish in v2014 w/10.6.8

Font Book indicates a name table error. I'll see if I can find a new Avant Garde and try that.

-B

Share this post


Link to post

A font-specific issue would make sense since myself and others testing that same file didn't get the same result. Especially if FontBook is popping an error up.

If the font was installed on an earlier OS and migrated over to the newer 10.9, it could have become corrupted during that as well, I see that fairly regularly especially if it was upgraded multiple times.

Sometimes just a reinstall of the font cures it.

Share this post


Link to post

Also, the problem font is in my user>library >fonts folder, not the system>library>fonts folder. Does the publish command access user and system fonts? or only the system ones?

-B

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...