Jump to content

creating a line with arrow/ marker


Recommended Posts

I'm doing some basic annotation on sheet layers of a 2D drawing.

I would like to put an arrowhead type object on the end of lines.

I have a class called 'notes - sheet", which is showing 'markers' as arrows, but I can't see where there is an option to use or not use these markers.

In the attributes pallette I have Line Endpoint Style set to Class Style but no arrows appear when drawing a line.

If I manually change Line Endpoint Style to a particular arrowhead it still doesn't appear when drawing a line.

Its a simple 2D drawing, but I'm precious about graphics so don't really want to use an annotation tool, I want to create a number of notes within a single text block then arrow the relevant bits of drawing.

Got a feeling I'm missing something simple, but... any help appreciated.


Link to comment

Thanks Jim, I don't think its the scale - if I draw a line at 1:1 on the sheet layer there is still nothing visible. The marker is default settings of 3.17x3.17mm (circle actually, rather than an arrow) and I have my units in mm so a line of 3mm should have a circle of similar proportions attached, I guess?

I've also tried drawing a line of 3mm on a design layer & still no marker visible!


Link to comment
  • Vectorworks, Inc Employee

The marker was selected but not turned on.

(Also, in this example the marker will be much larger than the line drawn so that may look odd once you enable it)

Make sure to click on the marker to turn it on, not just have the type selected:

Your current setting:


Turning the right/end marker on:


Link to comment

There is an old (ancient even) tool called "leader line" (actually there are two of them, which reside in "all tool" in the Workspace Editor). These, or one of these, might be of interest to you for the task at hand. You can add them to your Workspace via the Editor. To use just select the tool, then first click is the outbound end of the shoulder, second click is the elbow (shoulder to leader) and third click is the arrow end.

Link to comment

Thanks Peter, it looks just the job but I can't see how to install it!

Under Workspace Editor I go "Edit the Current Workspace", find the 2 leader lines under Tools, then once highlighted the only options seem to be "OK" or Export Workspace to Text File. If I click on OK i get the window shown as attached. Clicking OK doesn't seem to add Leader Lines to my tool palette - how do I access the 'modified workspace'? (and I thought the point was to modify the current workspace, not create a new one)?!

Thanks again,


Link to comment

The workspace editor has never been very intuitive (at least for me). In order to use it you need to understand that the left hand column is what is available and the right hand column is your workspace. Unfortunately it doesn't look like your workspace and also it is "collapsed" or "nested". Clicking on the workspace name (in the right hand column) will reveal (nested) lists which represent your workspace. To add a tool (or a menu item) to your workspace, find it on the left and then grab it and drag it to the right, into the appropriate tool palette in your workspace (my workspace has the leader line in the Basic Palette (eg). It is probably a good idea not to alter the original shipped versions of the workspaces. Rather you should choose Edit a Copy of the Current Workspace. Then you can rename it "mike's workspace" or whatever. Hope that helps.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...