Jump to content

Trouble switching active layer, user in Viewport edit mode


LarryO

Recommended Posts

Anyone know why Layer() doesn't completely switch to the active layer when in the user is in Viewport Annotation mode?

Or is there another function I'm not aware of in lieu of PickObject that accepts coordinates and a layer handle?

I use:

VSave('TempView');

GetPt(SelectPtX,SelectPtY);

ObjPtX:=SelectPtX-(VPOriginX*VPScale);

ObjPtY:=SelectPtY-(VPOriginY*VPScale);

Layer(Lname);

PIOObjh:=PickObject(ObjPtX,ObjPtY);

VRestore('TempView');

VDelete('TempView');

in that order but PickObject() doesn't detect the object at the specified location. If I don't restore the saved view I am left seeing the specified layer on screen but only the now invisible objects that were in the annotation area of the viewport remain selectable. The exit viewport annotation button also is active in the top right corner. So vectorworks still thinks I am editing annotation but now shows the specified active layer objects which do not appear to be selectable.

As per my previous message I am attempting to get a handle to an object that I see while in viewport annotation mode in order to extract data from said object. I will capture the visible layers of the viewport and I attempt to use the calculated point with PickObject() to get the object's handle before returning the user to viewport annotation mode.

Thanks

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...