Jump to content
Sign in to follow this  
I will I

VW 2015 CPU Usage

Recommended Posts

I am attempting to transition our office to 2015 but am experiencing erratic cpu usage at times nearing 100% while sitting idle with a blank file, once this behavior begins the software become completely unusable, quitting and restarting VW does not usually seem to resolve the issue either. We always seem to have issues such as this with new versions of VW and assumed waiting till SP2 would eliminate a lot of headaches but yet Nemetshek software team never ceases to amaze.

Has anyone else experienced this issue, or know where I could dig to find the root of this problem?

Thanks

Share this post


Link to post

Ive seen CPU usage spike randomly in a complex file on occasion, whenever redraws are triggered or sometimes during backup, but not on a blank file.

If its doing this across multiple files though, a backup and reset of your preferences is almost always advisable:

http://kbase.vectorworks.net/questions/1099/Resetting+Vectorworks+Preferences

Then, reboot and relaunch to see if you get the same odd spikes.

Share this post


Link to post

Yes, we usually wait for maintenance updates to happen before attempting to upgrade as it seems to resolve most if not all software issues I find when testing out an initial release.

Share this post


Link to post
Yes, we usually wait for maintenance updates to happen before attempting to upgrade as it seems to resolve most if not all software issues I find when testing out an initial release.

A wise practice.

Share this post


Link to post

Thank you for this it seems to have resolved the CPU issue, rebuilt all our workspaces and such from scratch, wondering if it was something I was trying to carry over from 2014 that was creating this behavior.

I am however experiencing some strange behavior when clicking in palettes and menus outside of the drafting window. While manipulating these menus the view in the drafting window continues to jump around as if these clicks and scrolls are still registering in the drafting window. This is quite irritating as the view will jump away from line work that you are trying to complete operations on.

Share this post


Link to post

It also seems that while trying to insert symbols from the resource browser is maxing out my cpu and making vectorworks unresponsive.

Share this post


Link to post

I just did a complete wipe and reinstall of 2015 sp2, and am using all default settings and workspaces. I have attached a file which contains line work copied from our title block symbol, this just the line work and text not the actual symbol itself. If I start manipulating the objects for a few minutes VW becomes unresponsive and does not recover, cpu remains maxed out. This is completely unacceptable and we are at our wit's end.

Sorry for the frustration, but after years of dealing with constant issues like this with Vectorworks it looks like searching for other software solutions would be the smart choice.

Share this post


Link to post

I just tried playing with that file. It ran super fast. Activity monitor didn't stir.

The only weird thing I noticed:

I tried downloading it, testing it, closing it, deleting it, and downloading it again … rinse and repeat.

Sometimes - but not always - it replaced the font when opening. Could you have a corrupt font?

mk

Share this post


Link to post

This is the same font we have for all our assets and there is no issue with any of them in their 2014 versions.

This always seems to be the problem, tech support is never able to reproduce the issues we have on multiple work stations. I honestly think it has more to do with VW not running properly on our machines as opposed to file issues.

Thanks for taking a look.

Share this post


Link to post

I don't know nothin' 'bout computers. But this sounds a little familiar to me.

I hate to ask this - and I only do because I had some similar problems with VW 2012 - but have you tried running VW with all the system extensions turned off?

I had a huge problem w/ stability in VW 2012 (CPU maxing out at random times, etc.) that turned out to be an Adobe extension (for a version of CS that I no longer had). It was banging on the processor every 5 seconds asking for resources that were no longer there. Deleting that extension made a huge improvement.

I ended up nuking and paving the computer, reinstalling software. After that, VW2012 was as stable as… VW 2012 could be :)

I'm hammering on VW 2015 all day, and I see crashes so rarely that it surprises me when it happens. I couldn't have said that about any previous version. We're both running the same OS, and I have waaaaay less RAM than you do. Like you, I have multiple customized workspaces that I switch between (plus Sam Jones' crazy workspace :)

Take this for what it's worth, but all this makes me wonder if you have a rogue extension or something else that is incompatible w/ VW…

good luck!

mk

Share this post


Link to post

Michael is referring to this:

http://kbase.vectorworks.net/questions/624/Safe+Mode+%7B47%7D+Boot+Without+Extensions

It may also be worth attempting the same procedure in a new document in a completely new user account, sometimes the issues that cause it to behave that way are account specific on Macs:

http://kbase.vectorworks.net/questions/805/Creating+a+New+User+Account+%28Mac+OS+X%29

Edited by JimW

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...