Jump to content
Sign in to follow this  
Trillian

Viewport woes in sheet file (again)

Recommended Posts

I have a simple problem with Viewports turning off randomly and have posted on this before. If anyone can walk me through it step by step it would be greatly appreciated.

I have a Master file - 'A' and a Schedules file 'B'. To stop any messing with the master file, I have referenced A into design layers in B. I add some extra info to B and create a view on a new sheet layer in B. (This is as there are 2 of us working on the project and that way File A doesn't need to be opened by either of us).

So far, so good, I can work away in file B creating all the sheets needed. Lo and behold I open up B this morning to find empty viewports in the sheet file, although the model file is fine with the reference and my additions. I can click on the viewport crop in sheet file but can't see anything behind it. I tried creating new viewports from the design layer onto the sheet file as well, and they're empty too. I am the only person who has opened file B, my partner is working on file C where luckily he hasn't started any viewports yet.

I draw everything in Screen Plane. I have turned on all the classes in the viewport, the sheet layer and the design layer. I have tried turning the machine on and off and clicking everything I can possibly think of in the object info palette to see if helps. I have also tried shouting at the computer, but that hasn't helped the situation much, though it made me feel better briefly.

This may be something obvious, but it is causing ridiculous delays trying to sort it out. Please, please, please help.

Share this post


Link to post

An update, several hours in. I created a new viewport from the design layer (B) into the sheet file (B). By messing around with all the settings, I managed to get it visible by changing from Top/Plan to Custom View and then to Top view. This only works on the new viewport -none of the rest are working. This is affecting 50+ viewports so having to redo them all would be a pain.

13zctmo.png

Can anyone advise what settings I should have in the obj info palette?

Share this post


Link to post

Viewports are objects themselves and they have a class. I notice that your viewport is in the "Detail" class; when you view your sheet layer, is that class on?

Share this post


Link to post

Thanks Mitch, yes it is. I've tried changing the class of the viewport a few times which is why it's currently in the detail class. I literally have every class turned on in viewport, sheet layer, model layer and original file A model layer, so it's not a class issue.

Share this post


Link to post

Is there anyone from Nemetschek who is on these forums who can help?

I've also tried opening the file on a colleague's computer - no luck there either.

Share this post


Link to post

The plot thickens. The reference file has moved in relation to the viewport. Pretty much an identical situation to this post https://techboard.vectorworks.net/ubbthreads.php?ubb=showflat&Number=198905#Post198905

So now my viewport crops are wrong, and I still have the issue with items missing in the viewports themselves when I re-crop them. They are visible for a second as in this previous thread I posted https://techboard.vectorworks.net/ubbthreads.php?ubb=showflat&Main=39196&Number=194606#Post194606

Vectorworks must be used for complex enough buildings all the time, but what I can't understand is that this problem has only happened on my 2 larger projects and has wasted enough time that I'm seriously considering switching programmes. The additional cost in new software probably is similar to the money lost in wasted time. It is actually a simple enough small project.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...