Jump to content
Sign in to follow this  
PVA - Jim

Problematic Sketchup (SKP) and 3DS Files

Recommended Posts

Ladies and Gentlemen!

We are currently testing a LOT of aspects of Sketchup and 3DS file import functionality to find the weak spots. If you have ANY 3DS or SKP files that you have imported into Vectorworks an encountered difficulty with, please either post the file, or a link to the file here so that I may use it for testing.

If the file is confidential in nature but you would still like us to give it a thorough going over, feel free to email the file or a link to it, directly to the address in my signature. (Rest assured the file will only be used for testing purposes and will not be re-purposed for any other reason.)

Specific issues we are working on at the moment:

Missing geometry

Incorrect location of geometry

Missing colors, textures or materials

Crashing outright during import

Please send them my way, the more the merrier.

Share this post


Link to post

Hi Jim,

all of the students here use .3DS > VW and we have never once encountered an issue and we do a lot (huge amount) of transfers. Not sure if that helps at all.

The only time there are missing materials is when the faces are reversed in SU. The conversion process only looks at the front faces for materials so it might look fine in SU with the material on the back face but it will be missing in VW. This is a user error.

Edited by barkest

Share this post


Link to post

That's what we are trying to avoid in the future. If you happen to still have a copy of that SKP file, please send it our way for testing.

Share this post


Link to post

I had to import a SKP file.

Although there were a lot of materials and layers in Sketchup,

none of these were recognized in the VW import option window.

Tried latest Sketchup Make format and older formats.

Therefor the model comes in on one Layer only and Class none.

Share this post


Link to post

Hi Jim,

Importing

I have stopped importing our in house Sketchup files as the results were so bad. A guide to achieving good results would be great.

Exporting

We have reverted to exporting out FBX files, which only seem to need tweaking to textures. Whenever we export out 3DS files, our 3rd party visualisation artists end up redrawing the whole model.

Thanks.

Share this post


Link to post

Please post or send my any example files where you specifically saw the results were bad and I can submit them for testing.

Share this post


Link to post

Hi Jim,

I believe the 3D artist have an issue editing the 3D model that is produced. Creating too much triangulation, even on the least settings in Vw. Also possibly the issue is that the textures are a challenge to apply the geometry created in VW? Thirdly, the issue could also be the issue I commonly have with issuing DWG files, where the third party is inexperienced, or lazy, to properly work through the files issued to them. In fact, in my experience, this is the more likely scenario. Unfortunately I know little of 3DS Max to be able to work through any challenges.

I have sent you an email with the 3DS file we sent to them (For this project we ended up sending them the DWG files as well so they could recreate the model).

PS Could it be that the FBX file seems to keep all of the texture data contained within the file, where as 3DS keeps the textures externally?

Thanks.

Edited by Diamond

Share this post


Link to post

Hi Jim,

Just sent you a PM with my file. It's a 3ds file exported from c4d. Practically useless to work with in VW. Hang times are typ to 2014, crashing, etc.

Share this post


Link to post

Same results here. This is way larger and more complex than any file I had tested before from 3DS, submitting it now.

Share this post


Link to post

Could you please send in the supporting files as well? its missing a few jpg image texture sources.

Share this post


Link to post

Could you please send in the supporting files as well? its missing a few jpg and psd image texture sources.

Share this post


Link to post
Hi Jim,

Just sent you a PM with my file. It's a 3ds file exported from c4d. Practically useless to work with in VW. Hang times are typ to 2014, crashing, etc.

Thank you for the other files.

If you are able, could you please send in the C4D file as well? I am getting odd results even when I open the 3DS in 3DS Max and MeshLab. There is still a slowness problem in Vectorworks with this model, but I think there may be more than one issue occurring.

Share this post


Link to post

deleted the imacs in the corner. There were 4 of them, and thousands of polygons each. Now the model works. But there IS a limit to geometry, even with the new version.

Share this post


Link to post

I've actually had a hard time in 15. I bring in warehouse stuff all the time. But now I frequently have to enter into a mesh object for it to regenerate.

Share this post


Link to post

There are a couple of minor issues that we regularly see. If you import .skp and you are in a top plan view then you have to go to a 3D view and back to top plan before the object becomes selectable. Another is that if you bring in the .skp as a mesh then you will not see it in top plan. The best way to work this is to create a component in su which equals a symbol in vw. You can see it fine then.

Edited by barkest

Share this post


Link to post

Hi

Does possible to import mesh 2-sided materials from sketch-up?

I mean plane with 2 materials on it

upd.

Sorry i missed in manual

The SketchUp format supports materials on the front and back of each face of an object. When importing as 3D polygons, only the front material is assigned to the imported objects, as Vectorworks only supports one material for 3D polygons.

When importing as architectural objects, both materials are imported and assigned to the imported objects, as Vectorworks supports several materials in this case.

Edited by Ilay

Share this post


Link to post

Not really. Both materials will import, but each side of your plane will have the same material (the one that was on the front face in sketchup).

What are you trying to do?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...