Jump to content
Sign in to follow this  
gejsen

2014 Walkthrough strangeness or malfunction?

Recommended Posts

I've been using VW since MiniCad so I am no dummy, but my current version 2014 has me stumped. When using the walkthrough tool while rendering in Open GL, the view that I have walked to, reverts back to the starting view whenever I release the mouse button. It doesn't do this in other render modes which are not fast enough to be useful in active walkthrough. It doesn't do this in wireframe, but then it is hard to tell where you are at times. Is there something I am missing? Or is this a bug?

Share this post


Link to post

Ok, now I am feeling ignorant. Today, the walkthrough tool is working as I think it should: that when I move about and let go the mouse, the view should hold. If anybody has knowledge of why it should work sometimes and not others, that there is some control for the revert, I'd love to hear about it. I did some experimentation with the editing of the saved view settings which did not seem to affect the behavior.

Share this post


Link to post

The behavior has cropped up again and I don't know why. Any help would be appreciated.

Share this post


Link to post

I tested a simple 3d scene. Walkthrough behaved as expected. In OGL the view froze in place when the mouse button was released. Walkthrough consistently resumed or held in place as mouse was toggled.

I don't know that any of this would cause or affect the problem you are seeing but maybe worth a check?

Scene includes referenced objects or DLVPs needing update?

File is ported up from older version?

Corrupt objects are affecting performance?

Faulty mouse?

Need a system reboot?

Replace plist?

Other open software is conflicting?

Corrupt file?

Test walkthrough in a new blank file containing only a few new 3d objects. If problem shows up could be hardware or Vectorworks. Reinstall?

If all OK in the new file, might be corrupt object. Paste in half the objects from problem file & test again. If OK, paste in the other half and test. If OK, the orig file is likely corrupt. If not OK in any step, there is probably a corrupt object(s), or resource.

-B

Share this post


Link to post

Hey, thanks for your thoughts. The file is ported up from 2013. It is big 65MB or so. I went back to an earlier version of the file which was small but also ported up from 2013 and had the same behavior. I tried creating a new file and simple floor plan and the walk through worked fine, stopping and not returning to the initial view.

Later today working on the original job, it moved as it should. I might well have some corrupt objects as this file has been in progress for a long time, through many variations of design. It was, in fact, begun in VW 12.5!

Share this post


Link to post

If you move around in walkthrough mode and get the issue to happen again, where it snaps back, if you change to a separate rendering mode, like Fast Renderworks, does it show you in the expected position or still snapped back to the original?

If you do the walkthrough in OpenGL, it snaps back, then you switch to wireframe then back to OpenGL, does it still show the wrong location?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×