Jump to content

Avoid Creating VWTMP File


Recommended Posts

Thanks Jim, the problem I have is with this VWTMP existing, whenever I tried to save my file, I get a message "The file save operation failed. Please try again, or save to a different location". I have to save as and replace the original file or manually have to delete this VWTMP file.


VW 2014 Architect

Imac Intel 10.8.5

Link to comment

I get the same problem. Every time I render a sheet layer viewport using Open GL the out of memory error occurs. I'm working on an extension to an individual house - nothing complicated. There are three SLVs in the file which are rendered in this way, but it only takes rendering the first one of them to trigger the problem.


I'm using VW 2014 SP2 on a 17" MacBookPro, 2009 vintage.


Link to comment
  • Vectorworks, Inc Employee

If its hitting Out Of Memory, that can definitely happen.

Once an OOM error occurs, (and in a few other circumstances) Vectorworks creates this type of file to avoid losing geometry within the file itself. It is annoying, but better than losing work. This can then be resolved by saving to a new location or with a new filename.

To be clear, this isn't that you are hitting your machine's maximum memory, but the amount of memory that Vectorworks itself can use. Renderworks modes likely aren't seeing the problem as it can use a huge amount of RAM, but Vectorworks itself, which runs OpenGL, is still limited to effectively ~3.5 GB.

This is currently how it works, but will not be for very long as a number of large changes are incoming to address limitations like this.

Link to comment
  • 2 months later...
  • 5 years later...
  • 1 year later...

I have this issue and it is causing major disruption. 


I have tried saving copies to new locations; rmeoving as many veiwports as possible; rmeoving as much other data hungry items too and still the files in question become almost unusable and crash regularly. 


This appears to have been an issue for well over 10 years (if going by the dates in other threads that cover the same issue.  Has there been any useful feedback from Vectorworks on how to resolve this?





Edited by EParks
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...