Jump to content

Viewport Visibility control


George K

Recommended Posts

Hi,

Trying to control visibility in the viewports but seems that none of the steps i take affect anything.

So.. I have three boxes (simplifying the drawing here, in reality some will be doors, wall etc)

All boxes are on the same layer but each on a different classes.

In Viewport 1 I want all of them to show up

In Viewport 2 I want one of them to be dotted red line

In Viewport 3 I want the red one to disappear.

I seem to be able to achieve my goal for VP 1& 3 but all the steps i take in order to make the box dotted red in VP2 seem to have no effect.

Steps taken:

Click on Viewport, then on the Obj.Info box go down to the classes button and click it.

Viewport Class properties pops open showing classes.

Click on the Class i want to appear dotted red.

Edit class properties to the desired effect (colour and line type) click ok

Back to VP class properties dialogue box, little landscape icon appears next to modified class...(things look promising!)

Press preview...nothing changes, tick every combination possible on class overrides and class visibilities and press preview...nothing happens.

Still hopeful, press ok and return to sheet but there is no difference between VP1 & VP2

What step am I missing?

Any help would be appreciated.

Thanks GK

VW14

Mac.

Link to comment
  • Vectorworks, Inc Employee

Hi George,

Since walls typically have multiple components, you'll need to create a Wall Style and set everything to "Use Class Attributes." You'll then be able to make any/all components behave the way you want.

Check out the Saved Views in the attached file and check out the Wall Style... The thick line/thin line thing is just me experimenting - it only works in plan view as those two components will mess up your rendering(s)

Wes

Link to comment

I have a question concerning this string.

I have a master file with a A-WALL-FIRE class. It is referenced into a design layer in my floor plan file. Then i have an enlarged plan viewported from the design layer. I need the A-WALL-FIRE class off in the enlarged plan. I have tried everything i can't get it to turn off in the viewported enlarged plan. I can turn it off in floor plan however i need the floor plan to have the class shown. I have turned the class to make all attributes by class.

Can anyone help?

Barbie

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...