Jump to content

Hidden Line render bug?


Recommended Posts

Just about to submit a bug report, but wanted some confirmation.

I cannot render Hidden Line for an extrude of a polyline containing circular segments. A 3D viewport of it on a sheet layer won't update, and when a bit more complex with many other viewports, there's a huge lag in viewport updating. Perhaps related to the other discussion:


See attached file.

What am I doing wrong?

Link to comment

There's definitely a bug. If you go into your VW preferences, on the 3D tab, what's your 3D conversion resolution set to?

If mine is set to low/med/high it renders as expected. If its set to very high it doesn't render at all. Even with only that one object in the file. I'd be curious if you have the same results.

I would file it or wait for Jim to follow up in the forums after New Years....


Link to comment


The file you posted back still shows the same problem on my machine. The background render completes but the hidden line doesn't unless I reduce my conversion resolution as above. What's your conversion resolution set to? I notice you're on a PC so it might be a Mac bug. An object this simple shouldn't be choking VW even when the conversions resolution is set to very high.....


Link to comment

Hi Kevin,

Computer specs in signature wrong ? have to change them

On my Toshiba lappy at the mo

It has a Nvidia GT 750M 2gb and with 3D conversion resolution set to Very High Hidden Line does not work

Works in Lower resolutions

Tried it on my drawing puter also ? it has Nvidia GTX 770 4gb



Link to comment

Kevin, you?ve nailed the precise issue again ? 3D conversion resolution.

When I set it back to High (from Very High), it renders okay. In fact, Update All Viewports (I have 47 viewports) now take only 35 seconds instead of over 2 minutes. Most are Hidden Line render.

I went further and tried the Medium setting. While Update All Viewports is even quicker (20 seconds), there are some jagged octagon-looking shapes where I have extruded circles and circular solids. So it seems the High setting is the good balance for me.

I probably had ambitiously set all my 3D prefs to their max thinking my hotrod 3.5GHz i7 iMac can handle anything. And in this document that lags, I have a good number of circular-infused polyline extrudes and curvilinear geometry.

It?s a bit disappointing that geometry with many circular forms can affect a fast desktop computer.

But what a relief. Thank you both for looking into it.

Link to comment

Glad to help. I still think you should bug submit it. That geometry isn't particularly complex so the rendering shouldn't be failing.

Historically I've kept my 3D conversion resolution on Very High. There was a recent post by someone from NV (possibly Jim but more likely Dave) about setting it lower for best results. The problem I've found is that this setting is universal, so something 3" in diameter and something 30' in diameter seems to have the same number of facets. I've been working on a project that has walls with a 15' radius so the facets became very obvious in most render modes. The facets also tend to show for small objects destined for 3D printing. Its fine to suggest using a lower quality level but in practice its not that easy.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...