Jump to content
Sign in to follow this  
alain

10.9 Maverick Upgrade and Vectorworks 2011 not working anymore

Recommended Posts

This is really a ty service from you guys. Your developper team should be able to see that coming and fix it!!!

I upgraded and PAID a good amount only 2 YEARS ago!!! For that version and you were not able to see that coming and help your customer with that.

You see, i am currently using about 50 software on my machine, some costed me a lot, some a couple of bucks. Some were installed about 8 years ago and ALL my software are working great after that upgrade except? Guess which one?

Vectorworks!!!

Hey guys! When your customer pay around 600$ for a "basic" upgrade, you could make a little effort to make your program work for at least a couple of years!

I am really really angry about that situation and i hate to feel like i've been take in hostage from a company to upgrade a software and pay more!

I've been using Vectorworks since the "minicad" version!!! I had always talked good to my partners about it, but now i feel that you really missed that one. And i am considering seriously other options!

Ciao

Alain Boisclair

Edited by alain

Share this post


Link to post

It is only viable to support the current and previous versions of Vectorworks, unfortunately.

Apple regularly makes massive changes between OS updates and sometimes the fix is as simple as waiting until the next service pack. For example, Vectorworks 2013 will most likely be patched to be compatible with OS X Mavericks, while Vectorworks 2014 was repeatedly tested with the developer builds of 10.9 as they came out and fixed along the way, since it was also still in beta at the time and changes were possible.

We do not build end-of-life into our software directly, its all about the OS. Windows XP for example, can run every version of Vectorworks released since at least MiniCAD 6 all the way up to the current Vectorworks 2014.

I do understand it is frustrating and you may feel as if you've been intentionally trapped, but we do not hide compatibility issues and entrapment was never our motive. I make sure any OS compatibility problems are posted to the knowledge base as soon as we are aware of them.

This article was updated less than 3 hours after OS X 10.9 Mavericks was released:

http://kbase.vectorworks.net/questions/1163/Vectorworks+Operating+System+Compatibility+List+2013-10-22

Even if it were possible to keep the older versions up to date, we certainly wouldn't be able to patch 10+ versions of a massively complex software package within a day of a new OS being released.

I truly sympathize with you, but it simply isn't feasible to keep so many versions of such a complex program compatible with OSes that change so dramatically so often.

Share this post


Link to post

So what is a small business owner to do?

Ditch their computer's operating system, or ditch the one piece of software who's creator decides it's not "viable" to support their two year old software on a new OS release?

Ever since NM went to this single year software version release, I've seen more and more people complain about bugs and compatibility issues. By the time they are resolved, "POW" a new version comes out, and the whole thing starts again.

As an employee in a large residential remodeling company, we don't even have the infrastructure to handle annual upgrades, even though we pay for them through our annual subscription. We simply "choose" to upgrade every two years. Back when NM would spend several years updating and refining the current release, support for evolving operating systems was obligatory.

I think you owe it to the single license owners (and Mac users) that you reconsider this position.

There will be a tipping point where more people will choose another competing software, not because VW is bad, but because they cant depend on the customer/technical support being there in a year or two.

my 2 cents...

Matt

(p.s. Just because other software companies are doing this annual upgrade thing does it mean that it is a good idea for the user.)

Share this post


Link to post

Matt, in your Signature you show a Win 7 machine (?). Also, I think its pretty unreasonable for you to think that VW 2011 (now 4 years old) should (or could) be made to work with OS X Mavericks...

Suggestion: Stick with Mt Lion until such a time as you can afford to buy a new copy of VW's. It works fine, so what's the issue?

Share this post


Link to post
So what is a small business owner to do?

Ditch their computer's operating system, or ditch the one piece of software who's creator decides it's not "viable" to support their two year old software on a new OS release?

That would have to be a personal decision, whether to keep everything up to date or keep the OS/Software combo at the versions that work with each other. Unless the user had a major reason to switch to the latest OS.

If their reasoning is that they always want the latest and greatest software, then they would most likely already be on Service Select, get our new versions as soon as they release and then the compatibility problems would not be an issue.

As for the yearly release cycle, this is something that is happening across the entire industry. Whether we like it or not, all OSes and major software packages are moving to similar models and the pace at which hardware and software is being updated/replaced is increasing dramatically, but that is completely separate from any decisions we make or actions we take.

Edited by JimW

Share this post


Link to post
Also, I think its pretty unreasonable for you to think that VW 2011 (now 4 years old) should (or could) be made to work with OS X Mavericks...

I certainly wouldn't advocate anyone upgrading their OS on it's first day of release, but if VW is the only software not working, what gives?

Fwiw: Just looking in my old service pack release folder. I downloaded the final service pack release of VW2011 on 7/18/2011.

In my mind, 27 months of using a "refined" piece of software is not a long time. Our warranty to our clients is longer that that.

Again, just because "THE INDUSTRY" is moving to an annual release cycle doesn't mean it's ultimately a good thing for a user. If I were to buy a car, and it took half a year for it to finally work as advertised, I'm sure I would have traded it in before then. Fortunately, cars, "in general", work as advertised, so producing them annually is somewhat a given. Sadly, people so used to new versions of "half baked" software and OS upgrades, that it ultimately leaves the customer with the short end of the stick.

(Last month was the first month all our users were running VW2013, upgrading from VW2011). Some of their ongoing projects are still running on VW2011. It is NOT WORTH converting the files up to 2013, with all the bugs we have encountered.

Again, this is what our office has chosen to afford to do.

Matt

Share this post


Link to post

I have inDesign 5.5, which I have to run on Lion because it is not supported on mountain lion. It is a similar problem to your issue, but I have decided to keep that computer on lion so that I can continue to run it.

Share this post


Link to post
Again, just because "THE INDUSTRY" is moving to an annual release cycle doesn't mean it's ultimately a good thing for a user.

I completely agree, unfortunately the speed at which Apple chooses to drop support for software components that we need to rely on is out of our hands.

By picking an OS we have to adhere to whatever practices it introduces. Historically with Windows it has not been a major problem, only users with versions upwards of 8 years or older had problems in Windows releases after XP, but on the Mac side it is a completely different story.

As for software only being supported for 2-3 years, this is directly due to OS updates. If there weren't major changes made by Microsoft or Apple in their OSes, then we would have no trouble supporting our software decades back.

Share this post


Link to post

It would be nice to at least see a poll created to see how much interest there is in fixing older versions. I for one would pay a few hundred bucks to get 2009 working in 10.9, and I'm sure many others would pay for 2010/2011/2012 etc.

Share this post


Link to post

There is a definite interest, that isn't in question, but the cost would be comparable to what a user would have to pay in order to upgrade to the latest version anyway, so it just comes full circle.

Share this post


Link to post

If you have a computer that can run OS Maverick then it is non sensical to to be using an older version of Vw. I use Vw 2009 when I collaborate with an associate who refuses to upgrade and Vw 2014 for everything else. The latter is more productive and a much better experience.

Share this post


Link to post

Macs from 2007 run Mavericks, so that point is sort of invalid.

Not to mention that for what our company does, 2009 was perfect, our go-to tool for speedy 2D drafting. For BIM/renders we use other software. So in our case, 2014 is not more productive nor a better experience... especially seeing that 2009 is snappier even in a VM than 2014 is natively.

Share this post


Link to post
So in our case, 2014 is not more productive nor a better experience... especially seeing that 2009 is snappier even in a VM than 2014 is natively.

Reply back with this and we can have a closer look to troubleshoot that:

http://kbase.vectorworks.net/questions/627/DirectX+Diagnostics+and+System+Profiler

Vectorworks 2014 should be faster and more responsive than 2009 if everything is configured properly on adequate hardware.

(However VM performance isn't useful as a comparison, since there is such a drastic difference between VMware/Parallels/VirtualBox etc and Vectorworks doesn't support running any version on VMs anyway.)

Edited by JimW

Share this post


Link to post

Matt, in your Signature you show a Win 7 machine (?). Also, I think its pretty unreasonable for you to think that VW 2011 (now 4 years old) should (or could) be made to work with OS X Mavericks...

2013-2011= ?? 4 years old? One thing is for sure: We did not went to the same school....

There are lots of reason for people to upgrade the current OS. Each time Apple release a new version they also release a developper version exactly for company like you to test there software on it and make some adjustment.

I've been working with apple computer since 1997 and let me tell you one thing: In all those years of OS upgrades i can count on my fingers the software that i had problems with. And i can tell you that i rarely had to buy a new version of it because company publish a fix.

Now i believe you when you tell me that you don't want to catch customer with that. BUT THATS HOW I FEEL right now whatever you say!

Now, what i see is that i have a major FAIL with Vectorworks on my computer only two years after i bought a 2011 copy. ALL MY OTHERS SOFTWARE (adobe, maxon, etc.. ) are working great but Vectoworks NOT ANYMORE! :mad:

So stop excusing yourself at Nemetcheck and start working for a solution for user like me instead.

Share this post


Link to post

And i should add that usualy you have to install the OS first to see if everything is ok.

Edited by alain

Share this post


Link to post

The fact that you have had so few problems means you are exceedingly lucky. Every time I have had to update Mac OS X I have had issues with various versions of Adobe CS and Office, often making them unusable. The transition from PowerPC to Intel for instance was a nightmare for nearly every software package I used.

The two solutions for you would either be to keep the system that works, leaving the OS that is working fine in the version that it is. Or if you must upgrade to the latest version of the OS for whatever reason, keeping your Vectorworks updated to match.

Edited by JimW

Share this post


Link to post
as OSX 10.9 was supplied free, an upgrade to VW2014 will also be free?

Unless Apple wants to foot the bill, unfortunately no. :cool:

They now profit primarily from hardware, so they have most likely moved to the free OS release as a stab at Microsoft, which is completely software reliant.

Edited by JimW

Share this post


Link to post

So stop excusing yourself at Nemetcheck and start working for a solution for user like me instead.

Alain, this is probably not the answer you wanted to hear, but I have to agree with JimW and say the solution for you is Vectorworks Service Select. It costs quite a bit less than yearly upgrades and you're always up to date and current, as much as you want to be. Not to mention the additional content and training resources.

Share this post


Link to post

learn of what happened to whatsapp

you are about to broke the company

A possible acceptable solution is to realese a free version of vectorworks 2014 only with the escencial tools

Edited by lcda

Share this post


Link to post
Macs from 2007 run Mavericks, so that point is sort of invalid.

Only if it's a quad core

My 2007 dual core iMac can only run Lion. Mountain Lion and above requires a quad core processor.

Edited by Kizza

Share this post


Link to post

Alain, as frustrating as it is (I've been there) you really should have checked compatibility with NV before upgrading your operating system. It's madness to assume 3rd party software should work on future operating systems. If you're happy to upgrade your OS then you should be doing the same with your 3rd party software.

I'd recommend VSS too. Not only does your software stay current but the support is first rate.

The other short term solution might be to virtualise OS X 10.8 in VMWare Fusion or Parallels and run v2011 inside that. But this depends on having a powerful enough computer with a good amount of RAM.

Share this post


Link to post

JIm you are right about the transition from PowerPC to Intel. That caused problem. This was a rare time that i had problem upgrading in fact. But people were advise long before to be careful and company making software were also involved.

By the way, that was a major upgrade that have nothing to do with the others that came after because the entire architecture of the microprocessor was changed. It was 8 years ago.

Share this post


Link to post
A possible acceptable solution is to realese a free version of vectorworks 2014 only with the escencial tools

This would unfairly force our users that upgrade regularly to bear the financial burden of a small portion of users that are in a very specific, and completely avoidable circumstance.

Edited by JimW

Share this post


Link to post

people are upgrading their os because it costs peanuts to null, before they even think of applications that could not be working anymore.

i've upgraded my both mbpros from leo and snow leo to have them in unison on mountain lion, but i could easily let them rest on older os versions, especially as safari with many open tabs devours now my disk space down to null.

there's always a compromise...

rob

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×