Jump to content
Garden_Guy

Cant delete an auto generated class?

Recommended Posts

Hey Guys

Well.. I believe that vectorworks created an auto-class for a tree object, which I didnt want it to do.. but thats not the problem at the moment.

When I try to delete the "Plants - Components - Tags" class I get a pop up saying:

"Unable to Delete Object - One or more of the objects you are trying to delete is an automatically generated component of a plug-in object and cannot be deleted"

Anyone know how I can get rid of this? Also would be cool to know how to turn off the "automatically generated component" from that plug-in object too as I find it a pain.

Thanks

Share this post


Link to post

The Plant symbols automatically place the tag (label) for the plant in the Plant-Components-Tags class. This is actually a really good, desirable thing. It means that you can choose to display the tags or not, when you come to create viewports of your plans for printing/exporting. Classes give you great flexibility.

So, my advice is, don't delete the class - it will mess up all your plants. Instead, live with the class and make use of it!

All the best

Share this post


Link to post

I always thought that this is an issue only when you have "Enable Auto-classing" turned on under the Standard Naming feature. (File/Document Settings/Standard Naming).

If not, you can also check in the "VectorScript Plug-in Editor" (Tools/Scripts/VectorScript Plug-in Editor..)for the specific plug-in object you are using, and see if a default class is assigned under the "Properties" button. I would suspect that you "should" be able to change this here.

While I personally appreciate VW's attempt toward helping me organize my classes and layers in the way that IT sees fit, I appreciate even more the ability for me to control the classes & layers to serve my own needs, depending on the scale or scope of the project I am working on.

hope this helps.

Matt

Share this post


Link to post

My issue is that while learning the software, these automatic classes got in the way and so I reassigned them to a new class called 'reassigned.'  Now I do not know what they are anymore, but I cannot delete the class 'reassigned.'  And something seems to be disabling my ability to use normal toolset objects (like the property line) which I want to use.  Probably because I already tried unsuccessfully to use the toolset and auto-generated component of a plug-in which I cannot see and therefore is not serving me, cannot be deleted.  How can I remove the unknown objects generated by plug-ins and start from scratch without removing all of the lines already in my drawing?  

Share this post


Link to post

Well I moved the none class to reassigned also.  I made my own none class afterwards.  

 

Share this post


Link to post

That might be part of the issue. Never delete the None class, as many tools and internal components of Vectorworks rely on it. I'm surprised it even let you delete it; when I try it says "Cannot delete class 'None'."

 

Generally I'd consider the None and Dimension classes as untouchable. They are the default classes that exist in every file, and even if you don't actively use them they should exist anyways.

Share this post


Link to post

Good to know.  But do you know how do I resurrect them from the ether of my reassignment?  I moved them to my own "Reassigned" class at some point while organizing my drawing.  

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×