Jump to content
Sign in to follow this  
yasin2ray

3D Plant problems

Recommended Posts

I have a few problems with 3D plant symbols.

First, I just realized that none of my plant symbols have 3D information. The plant symbols came from the Plant Object database, so I don't know why no 3D info is there. Don't the standard VW plant objects already come with 3D info?

Next, I found a few tree symbols in the Plant Objects 2 database that say they are specifically 3D symbols (not the usual 2D/3D). I brought three of them into my drawing and placed them on the site model. When I updated my viewports of the 3D model, they all go BLANK. When I turn off the Tree Symbol layer and update again, the model is fine, in a sense; it shows the terrain and paths. But of course, I have no plants.

Weirdly, on one out of six of these viewports, with the Tree Symbol layer turned on, the viewport did NOT go blank and also one of the 3D plant symbols showed up!

What is going on???

Anna

Share this post


Link to post

I don't think most of the plant objects come prefigured with 3D info, that's something you add yourself as desired. For one thing, they're pretty generic, only specifying tall shrub, tree, perennial, etc. I think the idea is they are a good starting point for you to take further and customize into a specific plant. Although a few do come with 3D info, I'm guessing as a learning aid. This is in VW 2011.

As far as the disappearing plants and blank viewports, all I can guess is either classes are turned off (the usual culprit) or maybe a 3D tree or other element is blocking the camera, if you used RW cameras. Although I usually run into this more with walls than plants. Or maybe your camera is below the surface of the DTM. Anyway, check your cameras, and maybe recreate your viewport using a camera if you haven't already. Much more control of things.

Share this post


Link to post
I don't think most of the plant objects come prefigured with 3D info, that's something you add yourself as desired. For one thing, they're pretty generic, only specifying tall shrub, tree, perennial, etc. I think the idea is they are a good starting point for you to take further and customize into a specific plant. Although a few do come with 3D info, I'm guessing as a learning aid.

Correct, a large chunk of the default plant objects are 2D only. Most of the 3D plant symbol content is separated into the Renderworks Xfrog library and a few other libraries.

However, what rendering modes are these viewports in? Are the design layers you are working with all at the same scale?

Share this post


Link to post

Jim,

The layers are all at the same scale. All the classes and layers are correctly turned on or off.

Here's what I've learned since the first post:

I had the viewports rendering with OpenGL.

When I switched them to Shaded Polygon, the viewports would not go blank and the trees would show up.

But I can't use Shaded Polygon as a final output to show the public. It needs to look more like OpenGL... but with plants.

I guess I don't mind making some of my own trees if I can duplicate them like I do with the 2D symbols. But those probably won't show up either...

i still don't understand why the plants don't show up. And now I'm wondering why I purchased Vectorworks for 3D models when SketchUp is free and far more capable.

Share this post


Link to post

Maybe a video driver issue? Have you updated your driver lately? On windows you need to do that fairly often.

Share this post


Link to post
i still don't understand why the plants don't show up.

If the plants do not have a 3D component, that will occur. Is that the case?

Share this post


Link to post

Jim,

Thanks for trying to help.

This is explained in greater detail in the original post - but basically, the plants are 3D objects I got from the Plant Objects 2 library.

Anna

Share this post


Link to post

Hi Anna,

i think i figure out your question.

firstly, you need to create a new document and choose use document template. i choose landmark (metric-mm).sta.Then you can open plant and edit plant tool preferences. i suppose you can see 3d plants in 3d openGl preview.

did i figure out your question?

jeffrey

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...