Jump to content
Sign in to follow this  
NealP

Walls - Making Components non printing

Recommended Posts

When drawings walls in Vectorworks, all the components that make up the wall, gyp. board, plywood, stucco, show. How do I get it so that when I print, all I see are two lines with the center poche? similar to old school drafting?

Share this post


Link to post

I don't know if you can do that without changing the wall style prior to printing.

- If this CAN be done, I'd Love to know how-

TOP VIEW as opposed to TOP/PLAN VIEW will give you an open view of the wall without a hatch, but you will still see the assembly of the wall, just not hatched.

When I've wanted to do what you suggest I use this work-a-round:

-Duplicate all wall types in the Resource Browser

-Remove all Components from duplicates except for one with the Hatch I want and the same overall thickness

-Custom Select Wall Types

-Replace the Walls with the Duplicates

This is a pain so I avoid it, I would love to know if there is another way to do this.

As a footnote, while it may seem that the Eye Dropper tool might be helpful in this case, it will not replace a wall's components if the wall is a saved Wall Style. The wall must be first altered to an Unstyled Wall for the Eye Dropper to work. So one must do a custom selection first anyway.

Share this post


Link to post

You don't have to recreate anything new or change anything about the wall(s).

There is an option when you pick the "Advanced Properties" button (Toward the bottom of the properties window when you select a viewport) called "Show Wall Components".

Just deselect that and your walls will all take on the solid fill of the class their on.

Furthermore, you can override the properties of each and every class through the viewport if you want to (in case you are going for some special poche' color for all walls which is different from your normal colors.)

I would typically have some viewports already "pimped up" with snazzy wall colors in our template to do this to happen right out of the gate. Its a great way to speed things up, and still encourage some uniformity among multiple users.

hope this helps,

Matt

Share this post


Link to post

The Sheet Layer Viewports have and Advanced Properties dialog in the Info Palette. Go to that, and you can uncheck "Show Wall Components". And then it will only show double line walls.

I suspect you'll need to do some overlay 2D graphical poche for the walls in the viewport annotation, for the second part.

Share this post


Link to post

Matt,

As I've said I have avoided doing this work-a-round unless necessary but I've never been able to get a fill or a hatch in a wall (styled or unstyled) using the technique you describe. So what have I been missing?

Share this post


Link to post

Hi Jim,

This should work all the time, assuming you haven't changed the wall's attributes in the attributes palette.

Make sure all the attributes of the wall are set to "by class" before proceeding.

Here's a step by step after this is confirmed.

1) Go to the Sheet layer viewport where the viewport of your walls is. The view should be set to "Top/Plan" view for this to work.

2) Select the viewport, and look at the OIP (object info palette)

3) At the bottom of the OIP is the "Advanced Properties" button. Select it

4) In this box is the option to "Show Wall Components"

5) deselect the "Show Wall Components" button, and hit "preview". You should see your walls take on the default color/fill/hatch of whatever class the walls reside on.

6) Then you select the "Classes" button in the OIP, select a class you want to override, and hit the "edit" button.

7) You can now change the wall's class to be whatever you want it to be (solid, hatch, gradient, tile, etc... This will not affect the default appearance of the wall.

I hope I am explaining this well enough, friend. Let me know if something doesn't make any sense. Again, when I have seen this fail, it is due to an attribute overriding the wall style in the design layer. I always make sure my walls are all set to "by class" before proceeding.

good luck!

Matt

Share this post


Link to post

Thanks Matt, as I've said when I've attempted this in the past and sadly

- ne marche pas!

The thing I note from what you've described (very well I must add) that this technique ONLY works with Unstyled Walls, to allow for the Class Attribute to apply.

One may start with a Wall Style but then all the walls must be converted to Unstyled in the OIP for the process you've described to work.

Even if we have to create one from scratch, we only ever draw a Wall that has a Wall Style in our Resource palette.

Share this post


Link to post

Hi Jim,

Ok, think I am now realizing the issue. I can make it happen with my styled walls, too. They don't have to be unstyled.

Therefore, I "believe" the reason why it works for me and not for you is due to the possibility that the "Fill" settings of your wallstyle components are not set to "use class attributes". (I am certain that we have changed our wall components at our office to be controlled by the class.)

Infact, I now realize that many of the Vectorworks default wall styles don't use set attributes for their components. Therefore, they will likely not change in this way.

I would suggest duplicating a wall style you typically use, and try setting the components fill attributes to be controlled by the class. Then this override should work for you. What's nice about this method is you can always keep control over those particular attributes for any wall style, so you can change the wall's internal appearance (and scale of a hatch) depending on the scale of the viewport (show insulation in the wall, for example.)

hope this helps.

Matt

Share this post


Link to post

Mess around with the attached file. It will do what you want it to. The Wall Style uses the "Use Class Attributes" method which I highly recommend. With this methodology, you can easily use class overrides to dimension to face of stud or whatever as well as have your walls appear as just two parallel lines. The fat line/ thin line thing ONLY works in PLAN VIEW. If you try to render with these classes on, you'll get unexpected results. Email me anytime with questions - wgardner@vectorworks.net

Wes

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×