Jump to content

Force Object to Class Attributes

Recommended Posts

Hi does anyone know how to force objects to class attributes? I have tried turning on and off the 'use at creation' command but this does not work.

I have imported a complex DWG from a consultant and want to control the graphics, but the objects are not set to class attributes. It would take forever for me to go through the thousands of symbols andchange everything manually.

Cheers for the help!


Link to comment

I think you should try "Tools/Utilities/Change Symbol Attrs..."

I just played around with a symbol and modified it's colors, and this tool seemed to accomplish what you are trying to achieve (I think.)I made sure to select the "Use the document's current default attributes".

You could knock all the acad symbols to their own folder, to better control the outcome.

good luck!

Link to comment

The Edit Class should do it. If it did not pick up the objects inside symbols and other containers, you may have to edit the class two more times. First time, uncheck the Use at Creation, and click OK to dismiss the dialog. Then edit the class again and check the Use at Creation. When you click OK, you should get a dialog with option to set all objects in the class - choose Yes, or Yes to All.

In my sample the gold circle is in my Test class and is contained in a symbol with the green circle. It took the class attributes and turned blue after checking the Yes, or the Yes to All option.



Edited by Benson Shaw
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...