Jump to content

Elliptical Eccentricities

Recommended Posts

Part 2. Create a 1/4 elliptical arc 22.5' wide x 16' high starting at x=0, y=5'. Sweep it. Convert to NURBS. Make sure it has a fill and a texture. It takes a looooooong time to process the render command--in the Geometry phase with no obvious progress--and then beeps and draws nothing.

What am I doing wrong? I'd think that sweeping an elliptical arc would fairly easily create a half ellipsoid.

Link to comment

My goal is to have an oblate ellipsoid on a stem wall--the top half of a squashed sphere elevated 5' on a circular base. So if you take the quarter arc and set it 5' above the x-axis, and then extend a vertical line from its outside edge to the x-axis.....that's my sweep section. But when I sweep that and convert to Nurbs, I end up with the nurbs object being defined by LOTS of concentric circles (the number depends on the 2D Res setting). This causes the renderings to look more facetted than I'd prefer. Most of the nurbs objects I've created, such as with loft, show very few lines on the actual nurbs object, and render smoother. I can't figure out why this one is being so recalcitrant. It seems like it's not understanding the geometry of the underlying structure and so it's just straight-line connecting the points on the polygon sweep object.

Link to comment

Seems I have to draw an ellipse (oval), cut it in half along the sweep axis, sweep a complete ellipsoid, and then cut away the bottom portion to get an ellipsoid-shaped nurbs surface.

If I create a quarter ellipse with the quarter arc tool and sweep that polyline and "Create Nurbs", the resulting object won't render.

If I turn the quarter arc into a polygon and sweep that and "Create Nurbs", what results is a group whose components look like trapezoids from the side (I guess technically they are segments of a cone) and unusable for Solids operations.

This is all so strange. What am I missing? (I know there's an ellipsoid object, and I'll mess with that next, but the quarter arc sweep should seemingly work, too. No?)

Link to comment

I'm having a hard time following what your asking for, but maybe this will work,

Create an ellipsoid with the correct dimensions for the object you want to create. Then create a sphere, snapping to the center of the ellipsoid and using the widest dimension of the ellipsoid as the diameter of the sphere. convert the sphere to a nurb, then use the 2-D selection tool to snap the sides of the sphere to the shape of the ellipsoid (does that make sense?). Then switch to a side view, snap the center of the now oblong sphere nurbs object to the center of the 2-d ellipsoid and then reshape the sphere again. At this point you can spit it anyway you like and it will still render.

Here's what I got, Is this close to what you want?


By the way, I got my VWA/RW 10 over the weekend. Solid operations and nurbs are much faster and more reliable.

Good Luck

Link to comment

That led to another experiment. If I sweep the elliptical arc and then do a solids subtraction of any sort from it, I get a Nurbs surface (or a solid subtraction object...don't really know the difference). And that I can use.

But if I sweep the elliptical arc, and convert to Nurbs, I can't do much of anything I need with the result.

What's the reasoning behind this? I guess really, why doesn't convert to nurbs on the sweep create the object in the way that the solids operations do? [Does that make sense?]

Link to comment

Mike, thanks for the reply. My prior note was just more of my talking to myself. I hadn't yet seen your note.

Yours makes sense. I learned something, too, because I never considered squashing a nurbs-ed sphere into an elliptical boundary. Pretty clever approach.

I guess the summary of the way I tried it is to start with the arc and wonder why I couldn't end up at the same place. Why start with the arc? Well, because the shape is an ellipsoid (such as you've rendered) but on a stem wall--your shapes, but on a 5' vertical footer, if you will. When I start with the arc, I don't get good results under one of the sequences that at the time seemed logical to me. Try this:

Create a quarter arc. Sweep it 360 at whatever resolution. "Convert to Nurbs".

What would you expect to result? Is that what does result?

And thanks for the response and suggestion.

Link to comment

Well, you know, there's always more than one way to skin a cat. If I was going to put that on a wall, I'd extract the curve form the bottom of the ellips, duplicate it 5' below the first one, loft them together, then add it all together. I've found that with VW, sometimes you have to come up with some fairly creative solutions to get your geometry.

In this image the full ellipsoid dome was an arc swept, then converted to a nurb and squished into an ellips. It seemed to work fine.


There must be something fundamental your doing different.

[ 10-07-2002, 04:35 PM: Message edited by: MikeB ]

Link to comment

Well, I tried again last night and had a problem, The acr swept fine, but when I tried to convert to a nurb it took forever, when it finished there was a line for the bottom of the sweep, and then one line extending from the bottom of the sweep to the apex of the arc, it wouldn't render and then it crashed befor I could save. So something funny is going on. [Confused]

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...