Jump to content
Sign in to follow this  
Guest

Shift+Click .. How many people ..

Recommended Posts

This also happening to me but not on a regular basis. It often happens when I first open the program. It seems to have some relationship with Num Lock.

450 G4

Share this post


Link to post

I've recently changed from a G4 @ 400 under OS 10.1 & VW 9.5.3 to G4 @ dual 1.25 under OS 10.2.2 And the problem has stopped.

A fine point is that if I pick an item and then click and drag a marque (box), while holding shift key, to select another item the original item deselects. If I do the same and only point and click (No click and drag a marque/box) the original and all new objects stay selected. I believe this is how this is to work, someone let me know if I'm wrong.

Share this post


Link to post

The More I work in V10 and the larger the files get the more this seems to occur. If I start VW after working in other programs it is more likely to occur.

Stuart

Virtual Habitat Inc.

Share this post


Link to post
Guest

This is not just a VW problem Stuart. We've seen other applications have this same behaviour under OS 10.2 as well. The result on those ends is also to restart the computer.

Share this post


Link to post

I have a problem here.

Please add me to list, Thanks

Mac OSX 10.2.4

PowerBook G4

VectorWorks Architect Renderworks 10.1.0

CarbonLib 1.6

Share this post


Link to post
Guest

I have posted a fis to this in a more recent topic of this problem.

If you use the combo updater and update to OS 10.2.4, the shift click problem in all applications is resolved.

If you just used the single updater for OS 10.2.3 to OS 10.2.4, that will NOT fix the problem.

At Apple.com, you can download the combo updater to fix the problem. (you can run this updater even if you have already updated to OS 10.2.4).

The combo updater will also fix the time issue with the OS. Some people have problems with the date and time setting to dec 31, 1969 at midnight when the computer is started. This problem started occuring under the OS 10.2.3 update I believe.

By using the combo update, it seems to have cleared the problem.

There are several other issues with the OS that seem to be cleared up with the combo updater in which the reg. standard version to version updater does not.

You can find more inforamtion about this at macfixit.com.

***PLEASE NOTE **** This is NOT a VW issue. This is an OPERATING SYSTEM issue.

Please contact Apple for additional information.

[ 04-08-2003, 05:26 PM: Message edited by: Katie ]

Share this post


Link to post

Happens all the time on both computers.

G4 500, G4 933. Both running OS 10.2.4, VW 10.1.0. CarbonLib in the OS9 sytem folder is 1.6

Share this post


Link to post
Guest

Bruce,

You should re-update to OS 10.2.4 but update using the combo updater.

Share this post


Link to post

I have followed your advice and I still have the very aggravating non functioning shift click problem. The update to 10.2 has also taken out the option click marquee method of selecting any object that came partly into the marquee area. I love progress.

g3/400 powerbook 0S10.2.4 VW ARCHITECT 9.5.3 and carbonlib 1.6

Also I have noticed in 9.5.2 prior to 10.2 upgrade inconsistencies with the measuring tool - is there a fix for this. Can't see any discussion about it

Share this post


Link to post
Guest

The shift select and other function keys such as shift, option and control having difficultes can be fixed temporarily by restarting the computer.

The combo updater should fix the problem, however if it doesnt, you may want to contact apple to see if they have any additional suggestions to fix it. I know Adobe also has a fix on their website as a workaround they've found to work.

It's an OS problem, not a VW problem.

Applications across the board are having this problem. The strange thing is, when one application has the problem, usually no other one has it at that specific time.

Share this post


Link to post

Thanks Katie but I have done it all. And it still doesn't work. Restarting ad infin. etc. The shift key works in other programmes - for defaulting lines to horizontal/ vertical - but maybe this is just a selective affliction as you suggested earlier.

The only other info I can provide is that the new 12 inch g4 powerbook we have in the office which we updated to 10.2.4 from 10.2.1 and updated to VWorks Architect 9.5.3 does not have this problem.

Share this post


Link to post
Guest

Are you having problems iwth the shift key giving you horizontal and vertical?

If so, that's a totally different problem than the shift+click in which this thread is referring to.

If your shift function isn't working for vertical horizontal, you may not have a VW pref enabled.

Go to File>Preferences, VW Preferences.

Under the Edit tab is something called "Smart Cursor Cues". Make sure there is a check mark next to this.

If there isn't, that would explain why you aren't getting the smart cursor cues such as horizontal and vertical when holding the shift key down.

Share this post


Link to post

Katie,

I mean that the shift key does not constrain the line if I'm drawing with unconstrained line. The cues do appear though.

I use keys to swap tool modes a lot. The alt key not working to duplicate and toggle the eye dropper tool as well as this shift problem is playing havoc with my drawing technique. Though I am getting very good drawing round complicated groups of objects with the lasso tool.

Share this post


Link to post
Guest

Jonathan,

when you say you are holding down the shift key and you are seeing the word horizontal/vertical but the line is not constrained - are you clicking while the shift key is still held down?

When you get the cues on the screen, is the line appearing horizontal or vertical?

With the eye dropper tool - are you holding down the option/alt key while clicking to either pick up or put down (which ever is being toggled) ?

[ 04-14-2003, 05:07 PM: Message edited by: Katie ]

Share this post


Link to post

Bryan Leather says "The select handles (little black boxes on the item) sometimes reverse in that they are visible when the item is not selected and invisible when item is selected. "

--------------------

I get this problem sometimes too. Restarting vectorworks cures it.

Steve

Share this post


Link to post
Guest

Steve,

What version of Carbon Lib do you have?

Do you have 8 selection handles enabled?

[ 04-15-2003, 09:32 AM: Message edited by: Katie ]

Share this post


Link to post
Guest

Steve,

Update to 1.6 and see if that fixes the problem.

Share this post


Link to post

I had this problem today for the first time. Nothing really happended which could have triggered this... except the change from AirPort 11b to 11g and consequent reconfiguration of network (hardly connected to the problem, I believe).

Powerbook G4 1 GHz

OS 10.2.8

VW 10.1.2 but just upgraded to 10.5 and keeps deselecting

Share this post


Link to post

We have the problem on several machines.

All running 10.3.4 or 10.3.5, G4 PowerMac and a G5 iMac.

After a restart, problem can return within the hour.

VectorWorks used within a managed account.

Repaired permissions instead of a restart, and that seems to hold on one machine.

Share this post


Link to post

We've also experienced the extremely odd multiple selection problem (shift + click) with OS Mac 10.3.7 running on 1.8 GHz PowerPC G5s.

One of our VW 11.0.1 Architect+Renderworks programmes now works OK after we updated the OS to 10.3.7; another similar system has never even had the problem. Oddly enough, now one of our machines working with the basic VW 11 has stopped doing multiple selections with shift+click. It worked OK before; the only thing we can recall to have taken place within the last few days is that we added one new user to the computer.

-anni

arkvv.fi | arkkitehtitoimisto vartola & viljamaa

Share this post


Link to post
Guest

EIther restart the computer or run disk utility to alleviate the problem.

Share this post


Link to post

Katie,

I use Windows XP on a Toshiba Laptop, 2.66 GHZ Pentium 4, 512 RAM.

VW11 Landmark.

No problems...and very happy changing from AutoCAD to VW11. Love the product apart from the image import and print problem I have that I still have not got around to emailing you yet.

Cheers,

Brian

Share this post


Link to post

i do have this problem but had thought that it was due to a large file size, or because of my speedy mouse work.

actually i've seen it happen on two machines in our office, not checked the others but again thought it was due to file size and older machines

My machine

G4 800

1.5 Gig Ram

OS 10.2.8

VW 11.0.1

Other machine

G4 400

1 Gig Ram

OS 10.2.8

VW 11.0.1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...