Jump to content
Mattheng

Align Selected Mappings not working

Recommended Posts

I can't get the textures on the sides and tops of brick walls to match up.

As a result it looks like what it is, i.e. a 3d shape with textures on the sides and the top, and not a wall made of bricks. Which defeats the whole object of the exercise.

I'm guessing "Align Selected Mappings" on the OIP is the answer but it is, seemingly permanently, greyed out and doesn't even come up when you type it into the help system.

What does it do and why is it greyed out?

Alternatively how do I get the mappings to align so that my brick walls look like they are actually made of bricks. The textures do say that they are "auto aligned" but to what exactly I'm not sure

Matt

Share this post


Link to post

Select the correct part of the wall (top, right (or left depending on how you drew the wall) and end (start depending again). For each of those parts just play around with the offset H and offset V values until they match. See attached.

Alternatively you could use the attribute mapping tool but the solution above is pretty simple.

Share this post


Link to post

Ok, thanks.

But that doesn't really work. Your picture is of the part that you have lined up the textures on. If you look at the corners then it will be out and I can't see how you fix it. See below.

Also the Attribute mapping tool doesn't like auto aligned plane textures and just seems to smear the texture when it moves it. See below again.

So, as I still can't get them all to align properly, why is "Align Selected Mappings" greyed out? What should it do? Why isn't it in the help file?

Anyone?

Matt

Share this post


Link to post

The texture on the start/end of the wall needs to be a different texture from the one on the top and right as that texture is a full brick and you need an end brick. Then I use the same offset H and V process which is pretty quick.

That is how I manage this not sure if others do something different and if so then it would be interesting to know.

Share this post


Link to post

Looks great but I don't understand.

On a wall you have left, right and overall textures.

The overall texture goes along the top and down the "start/end" as you put it.

You seem to have a different texture on top and down the start/end which is impossible?

How?

Matt

ps Anyone know why "Align Selected Mappings" is greyed out? Why is it there if you can't use it...?

Share this post


Link to post

Think of a wall as a cube with six sides.

top, bottom, left, right, start, end. You can texture each one differently just like I have in the previous reply. Target each part and texture as required and do not use overall.

Holes are also part of a wall and are used when you have a window, door or features etc. which leave part of the wall exposed (not the start or end).

Align selected is when you have multiple objects selected and you want the texture to appear seamless.

Edited by barkest

Share this post


Link to post

Ok I am getting there...

The wall idea works but try as I might I still can't get the "align selected mappings" to work even though I have now found it in the help file. Hooray.

How did you set up your textures in the alignSelected picture above (e.g. were they set to "plane") and was it two walls or two other types of object?

Thanks,

Matt

Edited by Mattheng

Share this post


Link to post

barkest,

I really appreciate you posting this but I just opened it up and this is what happened.....?

Align Selected Mappings is still greyed out and the mappings are smeared down the sides.

Looks like you used VW 2012 and I am on 2013. I have some older versions, I will dig 2012 out and try on that but I would not have thought changing from 2012 to 2013 would cause this sort of trouble...?

Thanks again,

Matt

Share this post


Link to post

barkest,

One final point. I noticed that the mapping type was perimeter and that the "align selected mappings" doesn't work unless it is a plane, sphere or cylinder mapping.

So I changed the type and...

nothing happened. Still greyed out and still smeared down one side.

@sigh@

Matt

Share this post


Link to post

Almost four years later and this is still an issue.  I can't for the life of me figure out how to get "Align Selected Mappings" to NOT be grayed out.  I'm trying to get board & batten hatch to align on a series of walls on multiple layers and can't get it to work.  I select "Use World Z For Origin" and that doesn't do it.  It seems like this should be such a pain.  I just want to be able to draw walls, assign a texture to those walls, and have those textures globally aligned.

 

Can anyone out there help me?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...