Jump to content
Sign in to follow this  
Mattheng

plant database bug?

Recommended Posts

I am trying to get the plant database to show all the dimensions as Metric and not Imperial.

Worked in 2012 but doesn't seem to work in 2013.

Anyone had the same problem and know how to fix it?

Share this post


Link to post

Hi Matt

Have you run Edit > Options > Use Metric Value Lists?

You need to first select all the plants before you run this - Click Search and enter a * in the latin name field then click Perform Find to select all).

Then, run File > Create Category Plant Lists to refresh the data available to Vectorworks in the Plant Lists.

However... I've just done this myself... and it appears to be broken. I will file a bug.

Share this post


Link to post

Told you...

Thanks

a) for giving me the right command to select all plants, hadn't worked that one out

b) for admitting it doesn't work.

I was half expecting to be told it was a "feature"...

Matt

Share this post


Link to post

I just checked. The convert to metric command is working, most of the time. Look closer at your plant lists. Many of the records will convert correctly.

The problem with this commands is: there was no really good way to do this conversion. The database simply checks the value and has a mapped list of corresponding ones. If the match is not exact, no conversion takes place.

You best bet for records that did not convert to your satisfaction is to do a find operation on them and change those yourself. You can do this with the Records | Replace Field Contents command.

I will look into possibilities of refining the search and match for the next version, but no promises.

Share this post


Link to post

Thanks Judah - I did see that some had converted. Kind of you to look at refined searches too, but I understand "No promises!"

Have a good day.

Edited by Tamsin Slatter

Share this post


Link to post

Ok now I'm confused.

The problem with this commands is: there was no really good way to do this conversion. The database simply checks the value and has a mapped list of corresponding ones. If the match is not exact, no conversion takes place.

In VW 2012 this was working perfectly. You could select the entire database and it would convert them all in one go. I just checked.

So, if it wasn't broken before you must have done something in 2013 to break it.

So rather than try to bodge something that has stopped working after you have changed it just roll it back to the 2012 version.

Simple?

Matt

Edited by Mattheng

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×