Jump to content
Sign in to follow this  
jda

"Accept incoming connection" Bug?

Recommended Posts

Just upgraded to VW 2012 from 2008 on OS X and I keep getting a dialog box that says "Do you want the application "Vectorworks 2012.app" to accept incoming network connections?"

The console entry for the dialog is this...

Vectorworks[1174]: Reachability Flag Status: -R -----l networkStatusForFlags

The dialog comes up every 9 minutes on the dot - it goes away after a few seconds on its own, but it's annoying nonetheless. Clicking deny or allow does nothing to keep it from coming up again.

The thing is, I get the dialog regardless of whether I've set my firewall to automatically accept incoming connections for VW or not. Turning off the firewall gets rid of them, but I don't really want to do that.

Does anyone else have this problem? Is there a setting within VW that might prevent this? I've already turned off 'check for updates' and that doesn't have any affect. I'm guessing that this is an anti-piracy check for other copies on the local network.

Ideas?

Share this post


Link to post

I solved this on may machine (Mountain Lion) as follows:

Remove Vectorworks from the list of software allowed to accept connections, restart your machine, and then add Vectorworks again manually from within System Preferences.

The first time you start Vectorworks after this, the pop-up may appear one last time (I can't remember), but after that it's gone for good.

It still carries out the check (visible in the console) but the annoying pop up every 9 minutes is now gone.

Share this post


Link to post

Is anyone else having this problem with the pop-up asking if you want to accept incoming network connections? Every time I start VW, I get the pop-up. I have tried manually removing VW from the list of 'allowed applications', rebooting, adding it back to the list, answering yes, answering no, ignoring it... Nothing I've done makes any difference.

I don't see anyone else complaining, so maybe I'm the only one with this prob? I'm using VW Designer/RW 2014 SP1, latest OS 10.9 updates.

Share this post


Link to post

I have had a number of users report this, but I have never been able to replicate the issue here.

If I disable, then enable the firewall and relaunch Vectorworks I only see the first notification, once it is added to the allowed list I never got it to pop up again.

For many users, removing it from the list manually then re-adding it corrected the issue, but I have not been able to confirm any other method of correcting it.

Share this post


Link to post

I have had this problem for the last few versions. VW2014 seems to be the first version to behave after saying no the first time the dialog box appears.

Interestingly VW 2014 doesn't actually appear in the firewall blocked list. I wonder if it is now "signed" software....

Kevin

Edited by Kevin McAllister

Share this post


Link to post

The problem still persists here. At least mine only pops up once, each time I start VW. I submitted a support request form at Vectorworks Service Select.

Share this post


Link to post

Yep. A continuous PITA for me every time I start VW2015 - i don't think 2014 is any different but rarely touch that anymore.

May be of help, but since I deleted VW2015 from OS X Firewall allowed apps, the entry was not reapplied automatically. SO I manually added it (alone with CineRender) but this annoyance persists.

Share this post


Link to post

I have this constantly with both VW2014 and VW2015. I've tried a lot of different things to fix it and in the end just gave up. Its very annoying.....

Kevin

Share this post


Link to post

Same here with Yosemite, 2014+2015.

Don't had any problems with 10.7.5 before.

Share this post


Link to post

I normally have the Firewall Options set to Block All Incoming Connections. (no need to share in my personal sandbox!)

I temporarily changed firewall options to allow file sharing and started getting the prompt.

Changed it back to Block All, and the prompt never appears.

-B

Share this post


Link to post

I think it is well known at NNA that there is a problem with the firewall in

Yosemite. At least here in Germany.

I don't think it is VW problem as this happens for Cinema and Modo too.

Doesn't mean that VW has no strange things under Yosemite but I think

Yosemite is not VW 2015 readdy either.

At least my new Mac Pro feels like a 468.

Share this post


Link to post

Why is is that you guys on Macs have these problems?

I know I am in big trouble but ...

C'mon

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...