Jump to content

Label Legend only allowing one Bold Channel


Recommended Posts


I have 6 or 7 different Label Legends and if i click 'Edit Layout' and go into one of them and make the Channel attribute BOLD and then go back to the document it has made this legend Bold, but then after a 'Refresh Symbol' if any of the channel attributes in any of the other legends were bold, they then lose this within the document. Is this a bug? Or meant to be like this, if so is there a way of disabling?



Link to comment

I have been having the same issue with 2013 on a Windows 7 machine. I have multiple bold attributes in my label legends and when they were imported from 2012, they failed to maintain their bold status.

Some items had their label parts in different locations on the fixture, like feet away from the fixture.

Anyway, I ended up opening each fixture (tedious. very, very tedious.) And turning each item bold again. (which was an *incredible* waste of time thanks to the new vectorworks being even slower than 2012 on certain features, like editing the label legend layout).

Anyway, I would select the items, click bold, click an empty space to de-select everything and then exit the editor. That seemed to work.

Link to comment


Nope, I lied, it is mostly all back to plain text. Not everything, it seems random. It lasted about 10 refreshes. Again, what an amazing waste of time. And now, it appears that I'll have to go back into all of those layouts and set them all to be plain text so at least everything matches.

Great. Any other suggestions beyond mine which don't work?

Link to comment
  • Vectorworks, Inc Employee

Only other thought would be a font mapping issue. Try looking at your font mapping in 2013 and 2012 and see if they match.

Also try switching the font to something generic. I've seen random problems with custom fonts.

I wasn't able to reproduce the problem on my machine between 2012 and 2013.

You can contact tech support if your problems continue. If you can make a simple reproduce-able example of the problem submit a bug via bug submit.

Link to comment
  • 2 weeks later...

Hi Rob [and others]:

I had this same problem on an old document with ancient label legends working in vw2012 and then "exploding" in vw2013. i would change the channel number in vw2013, and when i pressed the tab key to enter the change into the data cell, the label legend would explode, sometimes text feet away from origin, font attributes that were bold turn into non-bold, etc. yowsah!

with kevin's help, i think i solved it in three steps.

1. first, i opened my "label legend birth chamber" document [originally created in vw2011] in vw2013, and then imported matching label legends from the birth document into the old document, replacing the ancient label legends. that seemed to solve the exploding part.

2. then kevin directed me to "clear the font mappings". when i made the scooby sound "<*aroo?*>", he told me to go to preferences > display > edit font mappings > " and then select ALL of them and DELETE them. this only deletes the mappings, not the fonts.

3. then he instructed me to edit a problem Label Legend. while there, click on a piece of text that was demonstrating the bold/not bold thing. check the OIP for text name. then select **ONLY the first letter of the text**. it will probably not be the same bold/not bold. sometimes somehow a piece of text in LL may be half and half. drag select **all** of the text, and re-select the font and font attributes. edit symbol, refresh symbols in drawing, and [hopefully with fingers crossed] viola! it will all work.

at least it worked on my old drawing.

good luck,


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...