Jump to content
Sign in to follow this  

Copy and Paste Problem - No texts pasted (2012 vectorworks)

Recommended Posts

Just after I have upgraded to 2012 version from 2011 vw, when I copy and paste it onto other software ( eg. Filemaker Pro, Pages, Google Search etc.,) all texts including dimensions (numbers & texts) on the drawing were not copy and pasted. Only line and circles etc. appeared on the other database.

Anyone who has similar problems and how to fix it ?

Mac OS X, version 10.6.8, iMac,

Processor 2.16 GHz Intel Core 2 Duo

Memory 4GB 667 MHz DDR2 SDRAM

Share this post

Link to post

Here are some comments. I think they address your question, but post back for more discussion.

To acquire text in a Vectorworks container (eg a text box):

Enter the container (and nested containers as necessary) until the text can be highlighted. Then select what's needed and copy. Paste to other software should be successful


Dbl click a Vectorworks text box as if to edit the text, highlight some or all of the text, then Copy/Paste to other software.


A Vectorworks container (eg a text box) is an object (similar to circle or line), and will generally paste to other software as a graphic object.

Containers are things like text boxes, viewport annotation layers, groups, symbols, etc.

An interesting effect of all this - Select some items in Vectorworks, eg a text box and a circle. Paste those into body of an email. They become a pdf attachment. Open the attachment in a pdf reader - you will see the text and the circle. Select/Copy the text. Paste to Excel, Word, or TextEdit and get real text. Paste back into Vectorworks and get a text box.

Sorry, might be too much info


Share this post

Link to post

I tried this with Word and Filemaker Pro. All was fine in both instances. I assume the sketch was something like the attached. I did not that in Word that the picture did not show properly unless you were in Print Layout View.

Share this post

Link to post

Right Alan, the selected Vectorworks objects copy to Mac OS clipboard and paste from Clipboard into Word as a single image. With this method, the text (dimension values in your example) is not editable as text in Word. Or did you experience something else?

As far as I know, the Vectorworks text objects can only be "opened" one at a time. So text from multiple text boxes or dimensions will have to be transferred one at a time to the other software.


Transfer to pdf, then to other software to get editable text from many text boxes:

1. In Vectorworks, Select/Copy text objects to clipboard- as many as desired in one selection.

2. Paste the clipboard into a blank Preview file or other pdf reader.

3. Select/Copy desired text in the new pdf.

4. Paste from clipboard into the other software (eg Word or Excel).

Original post by MCP is seeks process to paste editable text from Vectorworks to various other software.

I do not use FMP. so no comment on FMP.


Share this post

Link to post

Thanks for trying to resolve my problem, please check the following link for screen shots so that you will realize my problem since I could not copy and paste one by one, in stead, I have to ( used to) copy entire drawing ( which includes mixture of all lines, circles, texts etc.) and paste in in to filemakerPro database, once pasted, no intention of modification ( just like pdf)


Please advise!


Share this post

Link to post

Oh, I thought you were trying to separate the text from the image and make it editable. Could it be that there is a fill in the text box in VWX? Try a new VWX file, create a dim and a text box, remove fill in the objects and paste into a new FMP file. Other software typically accepts the text rather than an outline of the text box.

Alan seems to have made it work. Maybe he will comment more.

Some ideas:

Does the Paste work better if all objects are on same layer and not grayed?

You could try to convert the selection to pdf, png or other image format, then paste the new image into FMP. Eg use Apple's Preview. Start with Edit>New from Clipboard, then Save As png or other.

Is there is a text import pref in FMP? Or a "Paste Special"?

Maybe it would work to paste the selection into some software which does show the text, eg Excel and paste from there to FMP.


Share this post

Link to post

@Benson: I tried with various options as you said but no difference at all.

It was perfectly fine when I was using 2011 version and it is happening after switching to 2012 version with same computer.

I think Alan has 2011 version per foot note that's why he has no problem.

I've already tried converting to pdf format and copy/paste to FMP, it is perfectly fine but it will need 2 steps (with one more pdf file to keep) and I can not re-convert into vw format later. I have thousands of drawings and thousands more in the future and it will be a disaster. If I stick with 2011 version, I can not upgrade to newer Mac OS/computer vise-visa.

Share this post

Link to post

Thanks for reminding me to update my signature.

The comments and example I posted the other day was made with VW 2012. It was done in design layer. I have not tried copying data in a view port, or items that are greyed out.

I am using VW2012 SP3 (Build 157127).

Share this post

Link to post

I think I found the issue. I just install vw 2012 on my coworker computer who has Mac OS 10.7 ( same as Alan) and it works fine.

I will try install OS 10.7 to my computer next week!

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114


© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.