Jump to content

VectorWorks Architect 9.5.2 crashes many times a day in Mac OS X

Recommended Posts

All this week I've been working on VW Architect 9.5.2 under Mac OS X 10.1.5 (with all the updates) and VW crashes almost 10 times a day.

This happens in different tasks, and sometimes just with the click of the mouse. The last crash happened some minutes ago, when trying to purge unused objects.

The drawing I'm working on it's 7,9 MB of size and contains some images as background for the drawings. These are 6 .jpg images none bigger than 100 kb.

This doesn't happen with all the drawings I do, but has happened to me other times (when using 9.5.0 and 9.5.1).

I'm using a 400 mhz iMac DV with 384 MB of RAM. Some times other apps are running but others not. I think it has nothing to do with that.

This has happened sometimes in Mac OS 9, but that freezes all the system, so I definitely prefer running in X; I loose much less time. But have never tested with this specific drawing under 9, just 10.1.5

I know Mac OS X saves a log file for the crashes, but it's in a language I can't guess what means.

Here it is:


Date/Time: 2002-07-22 23:35:45 -0400OS Version: 10.1.5 (Build 5S66)

Command: VectorWorksPID: 500

Exception: EXC_BAD_ACCESS (0x0001)Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x0000000c

Thread 0: #0 0x00ed2f70 in 0xed2f70 #1 0x00ed1588 in 0xed1588 #2 0x00ecf8f8 in 0xecf8f8 #3 0x00ecf550 in 0xecf550 #4 0x00ecf5b0 in 0xecf5b0 #5 0x00ecf28c in 0xecf28c #6 0x00ecc014 in 0xecc014 #7 0x00ed92a8 in 0xed92a8 #8 0x00e3a394 in 0xe3a394 #9 0x0399c56c in 0x399c56c #10 0x03999d7c in MenuMain__FllRl #11 0x03999ec4 in main #12 0x00903afc in 0x903afc #13 0x00903de8 in 0x903de8 #14 0x00903f30 in 0x903f30 #15 0x00904204 in 0x904204 #16 0x009043c0 in 0x9043c0 #17 0x0090464c in 0x90464c #18 0x00904494 in 0x904494 #19 0x005efeb4 in 0x5efeb4 #20 0x00604a90 in 0x604a90 #21 0x00604ae8 in 0x604ae8 #22 0x006190ac in 0x6190ac #23 0x00604a90 in 0x604a90 #24 0x00604ae8 in 0x604ae8 #25 0x00604a90 in 0x604a90 #26 0x00605f14 in 0x605f14 #27 0x005f016c in 0x5f016c #28 0x00605dac in 0x605dac #29 0x00605aa4 in 0x605aa4 #30 0x005f03a8 in 0x5f03a8 #31 0x0060352c in 0x60352c #32 0x006032bc in 0x6032bc #33 0x005eea84 in 0x5eea84

Thread 1: #0 0x70000978 in mach_msg_overwrite_trap #1 0x70005a04 in mach_msg #2 0x7017bf84 in __CFRunLoopRun #3 0x701b70ec in CFRunLoopRunSpecific #4 0x7017b8cc in CFRunLoopRunInMode #5 0x7061be08 in NotificationThread__21XIOAudioDeviceManagerPB0 #6 0x706141c0 in Entry__9CAPThreadPB0 #7 0x7002054c in _pthread_body

Thread 2: #0 0x70000978 in mach_msg_overwrite_trap #1 0x7024a0e8 in SwitchContexts #2 0x702c9eec in YieldToThread #3 0x70244b48 in SetThreadState #4 0x702bbbe4 in SetThreadStateEndCritical #5 0x00623548 in 0x623548 #6 0x00621df4 in 0x621df4 #7 0x00621cf0 in 0x621cf0 #8 0x0062242c in 0x62242c #9 0x006238b4 in 0x6238b4 #10 0x7027ae50 in CooperativeThread #11 0x7002054c in _pthread_body

Thread 3: #0 0x70000978 in mach_msg_overwrite_trap #1 0x70005a04 in mach_msg #2 0x70026a2c in _pthread_become_available #3 0x70026724 in pthread_exit #4 0x70020550 in _pthread_body

PPC Thread State: srr0: 0x00ed2f70 srr1: 0x0000f030 vrsave: 0x00000000 xer: 0x2000001c lr: 0x00ed1704 ctr: 0x01174da0 mq: 0x00000000 r0: 0x00000000 r1: 0xbfffe9e0 r2: 0x01ce7000 r3: 0xffffffff r4: 0x00000000 r5: 0x03ab56c4 r6: 0x03ab56c0 r7: 0x00000002 r8: 0x03aa511c r9: 0x03aa5120 r10: 0x04293010 r11: 0x80003710 r12: 0x000e8d90 r13: 0x00000000 r14: 0x00000036 r15: 0x00824370 r16: 0x00824370 r17: 0xbfffee90 r18: 0x00824378 r19: 0x00001813 r20: 0x00000000 r21: 0x0000001c r22: 0x70004234 r23: 0x700042c8 r24: 0x00000004 r25: 0x000006eb r26: 0x8081ab5c r27: 0x000639c0 r28: 0x00000000 r29: 0xbfffef00 r30: 0x00000000 r31: 0x00000001


I have more logs for previous crashes, please tell me if necessary I can post them too.

Please help me, I'm working in my final project and these crashes are not good for me.

Link to comment

Try running the Apple Disk Utility from the OS X Install disk. This is the best fix (to date) for OS X problems, and relatively un-discussed.

Upgrade VW memory to as much as your computer will allow with another app runnning. OS X takes a chunk of this memory; you may not have enough total on your machine. We use VW on machines with at least 512, and 256 min allocated to VW.

Link to comment

I have run several dik utilites, Disk First Aid; Norton Disk Doctor and Disk Warrior. I have even reformatted my HD, but the problem remains. And I do not think it's my computer the problem. VW and Adobe GoLive 6.0 are the only apps which crash. All my other software behaves very well, including Photoshop 7 and Illustrator 10 which are very memory hungry.

I understand maybe 384 MB are not a too much, but I'm doing only 2D, not 3D work. And I can believe VW just crashes without any warning. In Mac OS 9 it used to say "one or more operations were aborted because not enough memory was available" . Now it just crashes? I can't believe.

VW Architects requirements are this:

Power Macintosh or greaterMac OS 8.6 or greater96 MB RAM200 MB hard-disk space for full install, 150MB hard-disk space for typical installCD-ROM Drive

I have fourth times the required minimun of RAM. Do I really need more?

Link to comment

We run VW on machines with a minumum of 512mg; we have an office of architects and graphic designers. When we do 3D work and Photoshop, due to the number of apps open at any given time, we use machines with 1mg.....Would you really want to run a machine with any manufacturer's minimum recommendations? Their basic requirements take into account the bare minimum, with no room for computer idiosyncrasies (sp?) or multiple apps....

The disk utilities you listed mat not work on OS X yet.....you should run the Apple utility....unrecognition of the correct disk utility was a problem when 10.x.x was introduced, and still is a problem.

Link to comment

Yeesh. Buying more RAM will not solve the problem, but it will alleviate it temporarily. If a city gets too crowded, and the population is then spread out over a wider area, the people run into each other less frequently. Eventually, the population growth will result in the first problem re-appearing later.

The error appears to be along the lines of a memory protection fault, meaning that the app tried to write to a location in memory that it shouldn't have. I don't know if it was system memory, memory used by other tasks or processes, or just memory already used by VW. In OS9, you'd get a type 2 error (or -2?), I think but the issue is the same. Bad code.

Link to comment

Well, I' can't afford more memory right now, and I really think it's not the problem. Apps like Photoshop or Illustrator work fine with 50+ MB files, even Corel Bryce or others. I think this is a VW problem, not RAM problem.

Is anybody running VW with less than 384 MB of RAM? Does it crash to you?

Link to comment

UhHuh...TS, How much memory do you have?

Hugo,1) Reload VW (after copying your preferences, templates, symbols, etc) - my fault for not mentioning this solution earlier.2) Run the Apple Disk Utility from the OS X Install disk....important!

If this does work, upgrade the RAM at your first opportunity, replacing the 2nd 128chip with a new 256 ($86), or with a new 512 ($186)

If this does not work, you may have some bad (existing) memory.

There is an unanswered post from 6/24 with the same topic, and the solution above works for us. The Apple Disk Utility is key to maintaining OS X.

....and that should be the end of urban overcrowding and random daily computer crashes.

Link to comment

Thanks a lot Bruce for your ideas, I'll try them right now. As I said previously I have 384 MB of RAM, both DIMMS (256 + 128) are Kingston brand which I think is a good one. So I don't think it's a physical RAM problem, I think that either VW or Mac OS X are doing something wrong. PS 7 or Illustrator 10 use also lots of memory, but they become slower in hard work, but they don't crash!

Thanks, again, I'll check my HD and reload VW.

Link to comment

When the phones are busy the message board gets neglected a bit so I'm sorry if this is late.

In addition to testing the disk, we have seen cases where the whole computer had problems due to using RAM that did not conform to Apple's specs.

You Mac should have come with a "Hardware" test CD, boot from this and it will make sure that all of your hardware is OK (besides the disk)

Another cause of crashing just in VW is bad fonts.

Try removing all of the non Apple standard font's on your system and see if VectorWorks continues to crash. This is unfortunately far more common than I would like.

If this does fix the problem, try adding the fonts back in one at a time or in small groups.

Matthew GiampapaNNA Technical Support

Link to comment

Hardware test is a good start, however, even hardware test will not necessarily find bad RAM. We had a cube that would work fine for a while and then out of the blue it would panic. Turned out to be bad RAM, even though it passed hardware test and every other test we could find. It ran OS9 fine without failure, but OSX uses memory far more efficiently and will fill up your dimms. I think photoshop uses its own swap file for most of its memory usage. Don't know about illustrator. If you lack ram then OSX will start using swap space on your hard disk. The only thing that you should see is a performance decrease. If the speed is okay and you don't notice that your hd is churning away then 384 should be okay.

Link to comment


Although I just made a test working with the problematic file, what I did may have fixed the problem. But I will be able to say it properly after many hours on the drawing.

I run Disk Utility from Mac OS X 10.1 Install CD, and it reported no problems. I did it three times for being sure. I also booted in sinle user mode (command+S) and run fsck -y; also my disk appeared to be OK.

Then restarted using Apple hardware test CD an run the extensive test. No problem found. Everything OK.

Then I booted under Mac OS 9 and took a look in Mac OS X's fonts folder (because X woyld have told me those items were root property). The only fonts there were standard Apple fonts (arial, lucida grande, helevtica, etc.) and the fonts my Adobe apps has added (Myriad, etc.). I found very big ones with an .otf extensions which are japanese fonts. I threw them to the trash cause I don't need them and each other used up to 12 MB of size.

Then restarted in X and the first thing I tried was open VWA and opened the drawing, and went to purge unused objects (what made me crash almost three times on monday!) and it worked. No crash.

But now I'm working on another thing, so I think tomorrow I'll have many hours over that and I'll tell my experience. But I can't believe those japanese Adobe? fonts may be crashing VW. What a sensible app!

Thanks all of you for your ideas.


Link to comment

I sincerely hope that this does in fact solve the problem. Before you empty the trash, can you send me an email with the font information so I can add them to our black list?

Ideally if you just tell me where/what they came from we will go out and get our own copy. But if you could just forward the font's in a Stuffit file it would be extremely helpful. If we can reproduce your crash here, was can probably figure out exactly why VW doesn't like the fonts.

(We already know that VW loves the Japanese, We are bigger in the CAD market than AutoCAD is over there.)

Matthew GiampapaNNA Technical Support

Link to comment


I'm really sorry. I emptied my trash almost inmediatly, so I can't send you those fonts, but I can tell you all of them had japanese like names, ending in "oshi" or "aki" or similars. All of them had a .otf extension. I suppose they are japanese fonts, but they were never available to any of my Mac OS X apps (OS 9 not too). I have the doubt if they are Apple fonts for using Mac OS X in japanese, or Adobe fonts for working with japanese. I have installed Adobe Photoshop 7, Illustrator 10, GoLive 6.0 and I also installed InDesign 2, but deleted it (although it may had add some fonts...). I do not know if it may be interesting, but sometimes GoLive crashes the same way VW does. Just suddenly. Actually they are the only apps that crash in my Mac.

As I said, I only made a small test after erasing those fonts. I am waiting for a whole day of work in VW (maybe tomorrow) and then I will post again what happens.

By the way, I may reinstall any of those Adobe apps to see if those fonts appear again. Where do I email those fonts if I find them?


Also, I was surprised that they were very big files, from 3 to 12 MB in size, so I erased a total of 100 MB approximately.

Link to comment

.otf is Adobe's OpenType font technology. Usually Adobe .otf fonts have "pro" in their name. I have a few .otf files in System/Library, but they are named in Kanji-- in the info box one of them claims to be Hiragino Maru Gothic Pro W4. Anyway, The only Adobe product I have installed is Acrobat. In any event, no application should install fonts in /System/Library they should be in /Library, ~/Library, or /System Folder/Fonts-- so Hiragino Maru Gothic must be from Apple. Did you install any of the Language kits, or language kit updates?

Link to comment

I just installed spanish language files because I speak spanish; I live in Chile. But I suppose that's not the reason of those ....aki or ....ashi fonts in my computer. I'm almost sure Adobe apps added them, because I remember at the end of Illustrator or maybe Photoshop installation, those names appeared in the installer progress.

The thing is I erased them and today I spent about 2-3 hours in VW Architect and it didn't crash. Those Adobe apps works perfectly after that erasing.

Probably Matt was right and VW doesn't like that fonts (although they weren't available in the VW text menu).

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...