Jump to content
Sign in to follow this  
gvelthuis

sweep and boolean

Recommended Posts

When trying to make holes (boolean) in a sweep-object I end-up with a facetted object, no matter how I screw up the quality of the sweep.

More precise: the sweep-object is a rubber ring (a gasket) with profiling on it. And the holes are for bolts to go through. I set the sweep to "segments every 3 degrees". In Cinema 4D it looks pretty smooth without the holes, but with the holes, it looks the same as if I set the segments to "every 15 degrees" which is too rude for the purpose.

What can I do about it. Turning the sweep into something else (nurbs or wire) makes it useless for the boolean operation.

Doing a conversion after the boolean gives the same facetted geometry.

Share this post


Link to post

In my version of Vectorworks 12.5.3, Final Quality Renderworks yields a non faceted sweep with holes. Open GL gets facets, but it defaults to Low Quality and disabled Anti Aliasing. Higher settings almost eliminate the facets.

Try increasing the render quality:

View>Rendering>OpenGL Options increase the quality and enable the Anti-Aliasing.

Also, your signature indicates 12.5. If necessary, free upgrade to 12.5.3 at the Vectorworks Home page>Downloads.

Post back if this is not helping.

-B

Share this post


Link to post

I'm sorry, I forgot to update my profile; I use VW 2011.

Setting OpenGL to the highest gives a better image indeed, thanks.

But that's not the real problem.

When I send the file to C4D, but also, when I render it in Renderworks (highest settings), the swept object is perfect without holes; the moment I put holes in it, the quality decreases to an unacceptable level.

A workaround, is first converting the sweep to a wireframe object and then the boole, but then I loose editing possibilities.

Another one is transporting sweep and hole objects to C4D and doing the Boole in C4D but that's also quirky.

An image at: http://members.home.nl/gevelthuis/temp/gaskets.jpg

Edited by gerrit velthuis_dup1

Share this post


Link to post

My 2011 works with no facets:

3? sweep, OpenGL on Very High and Anti Aliasing

Final Renderworks is not faceted, either.

I found only a little effect from maxing out the 2d and 3d conversion settings in Vectorworks Prefs Edit and 3d tabs. But you should look at those, too.

Just a test - Paste the completed object into a new blank file and render. Maybe there is something else in the drawing causing the faceting.

Another idea - minimize the number of solids operations. eg Bolt holes are 4 circles extruded in one go to make all 4 holes in one solid subtract operation.

ubbthreads.php?ubb=download&Number=7576&filename=OGL.png

-B

Share this post


Link to post

OK, that's strange at first glance, but after I imported your file in my VW model, I saw that your gasket was much larger than mine.

And the ribbons I use are thinner.

If I scale down your object to the same measurements as mine, it reacts exactly the same; smooth without holes; facetted with holes.

In the second image I attached, I imported the gaskets in c4d and turned the display to "wireframe".

The difference is clearly visible; the middle ones have holes; the outer ones don't; my gaskets to the left; yours to the right.

On the other hand, if I scale my gasket up to yours, it looks great.

So, . . . .the problem seems to be in the scale. I work 1:1, which is convenient for mechanical objects like the ones I work with. The gasket is about 150 mm in width.

I think that shouldn't be the problem.

screen.jpg

screen c4d.jpg

Edited by gerrit velthuis_dup1

Share this post


Link to post

Now, I see it too.

Worse when object rescaled to 150mm

OGL better than FQRW, but still has facets.

Layer scale does not affect - tried magnifications at 10x and reductions at .25x

Tried reducing sweep to 0.5? - no improvement.

Mesh smoothing has no effect (it's not a mesh)

Same in VWX2012

Maybe others have solution?

-B

Share this post


Link to post

for a project not unlike this I resorted to Rhino to avoid faceting

Share this post


Link to post

No more reactions . . . . that's a pity.

I guess I have to do the modelling in c4d then.

But I still think it should not be necessary.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...