Jump to content

OSX 10.8 Mountain Lion Support

Recommended Posts

I'm Currently testing OSX 10.8 Mountain Lion on my MacBook Pro and recently updated to Developer Preview 4 and Vectorworks 2012 with SP3 will not open.

Is there anything I can do to get the program to open before I resort to heading back to 10.7 Lion?

The funny thing is the Program opened in DP1, DP2 & DP3.

Thanks for your help sirs/ladies.

Edited by mmurphy
Link to comment

Thanks for getting back to me!

Yes I of course meant 2012 (*edited the post now) sorry.

Just tried what you suggested but had no luck with SP4. Vectorworks loads up until it says 'Loading designer workspace' my pallets apear then crashes.

I'll try a fresh install on of VW2012 now.

Link to comment
Guest Jim Kelly

I'd definitely try a fresh install, although for your 2012 installer you'll probably have to lower your gatekeeper protection as out initial installer for 2012 wasn't signed (SP4 is signed, however).

If that doesn't seem to resolve things definitely open a bug. I know QA is testing on 10.8, but it's always good to get these sorts of reports ASAP.

Link to comment

Just tried a fresh install and the progran refuses to open with the same issues as described above.

Thanks for getting back to me!

Vectorworks loads up until it says 'Loading designer workspace' my pallets apear then crashes.

I guess I'm just unlucky! Where do I submit a bug?

Link to comment
Guest Jim Kelly

Hmm, that is strange, because I asked our QA department and they said they weren't seeing issues with DP4.

One more thing to try, have you tried moving your user preferences (workspaces, etc) out of the way? Maybe one is corrupt, given where it is crashing?

Link to comment
  • Vectorworks, Inc Employee

Similar to what Jim Kelly suggested, try removing your user preferences and let Vectorworks generate a new set on launch.

-On your keyboard, press Command+Shift+G

-Type ~/Library then press Go

-Go to Application Support > Vectorworks

-Drag your 2012 folder from here, to your Desktop as a backup

-Try launching Vectorworks 2012, you will be asked to activate your serial number again, if you're serial number begins with, "E"

Please keep us updated.

Link to comment

Still no joy.

Completely removed Vectorworks via these instructions;http://kbase.vectorworks.net/questions/935/Uninstalling+Vectorworks+2012

Reinstalled and I'm still getting the crash on the 'Loading Designer Workspace' point during launch.

I've just tried what Gunther suggested above and the program still refuses to launch.

I have another account on the mac which Ill try and install on now and see where I get.

Thanks for the help.

Link to comment

Could it be because the Library folder is hidden? I know you can unhide it through the terminal app. When you type " chflags no hidden ~/Library " the Library is visible again in Finder. Maybe this could solve it? Use this command at your own risk (I have used it on several computers and haven't had any problems, this is in OS X Lion).


Link to comment
  • 2 weeks later...

'No resolution' just means that it hasn't been tested, it doesn't mean it won't run.

I'm running VW12.5 on OS 10.6.8 and every time the OS has been upgraded I was told I was doomed unless I upgraded VW, but I'm still here and the sky hasn't fallen in.

Why be in a hurry to upgrade? You could leave it for a while, and let others do the testing - I'd at least wait until OS10.8.1 comes out.

Link to comment

I'm currently using the 10.8 general release now and Vectorworks 2012 SP4 is working fine.

The problems I was having stemmed from something awry in my user account as VW2012 opened fine in another user account I created...

Thanks for your help guys/gals.

Link to comment

I have had some problems recently and suspect it may be related to Mountain Lion. I haven't been able to pin point the cause precisely but Vectorworks is less reliable than it was before. Some files are slower, I get a new spinning blue ball (seems to be part of Mountain Lion) quite often, and yesterday Vectorworks just disappeared and crashed. Normally you have a sense its going to crash with the spinning beach ball but I've never had it just disappear before.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...