Jump to content

textures disappearing


Recommended Posts

I made an image texture with an image mask of an expanded steel floor. I applied the texture to a 1/4" extruded rectangle to make a sheet of expanded steel. This worked great when rendering using OpenGL - I can see through the expanded steel and it maps great.

When I render in renderworks - fast, fast with shadows, final quality - the object either entirely disappears (it's still there, I can select it), or just turns white.

What am I doing wrong?


Vectorworks 2010

Link to comment

Just some ideas, tests:

System Reboot?

Paste one instance of the textured object into a new file and render.

Create a new file with a new (remake) texture applied to new objects. If it works, some other thing is problem. Font corruption? Corrupt object in orig file? Referenced objects? Imported objects? Did you make this texture in an older version of Vectorworks? - if so remake in the new version.

Edit the texture and pick the mask color again. Or pick a different color, then edit again and pick the orig mask color. Sort of a texture reset.

The image might have too many pixels for Renderworks. Create a new texture with a lower res version of the image.

Toggle the World Origin option.

Toggle Planar/Perimeter mapping.

Post a file with the texture on an object so others can see the problem.


Link to comment

The one thing pops forward in the first post is "image mask of an expanded steel floor"...

This being in VW2009 it would not have the texture change as in 2012 as yet, where metal textures are horribly wrong on the reflective side.

So it should not have any problems unless the edit is wrong or it being to big.

What is the base image texture?

Maybe post both images here and we could have a look.

(to add image files, Switch to Full Reply Screen and click on File Manager.)

Link to comment
  • 3 weeks later...

Having the same problem - usually with image mask transparency. I create an image - say a logo - and create a texture with it. Very simple image -white image on a black background. I have tried grayscale pixels, selecting the color, and using alpha channels. In all 3 cases, the image appears fine in OpenGL, but disappears in Final Quality. It's there, but invisible. I've tried applying different reflectivity (matte, constant, etc.) Nothing seems to help. This is important to me because I often need to show a clients image applied as if cut vinyl on a surface.

Any Ideas?


Link to comment

Paste the object into a new file and try OGL & FQRW with no light except default ambient. Maybe the object is same color as background? Or light level is too low or too high? Some other object is in the way?

Look closely at class definition of the problem objects esp, Texture>Other near bottom of class dialog.

I found some problems with masked transparency textures created prior the new render engine. Fix was click to edit the texture. Did not have to change anything for some. Just enter and exit the edit mode. Others needed click to define transparent color again, then exit. But it sounds like you already tried that.

Sorry can't see any obvious solution.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...