Jump to content
Sign in to follow this  
Bruce Kieffer

Snap to object not working

Recommended Posts

I have one file that's giving me grief. Snap to objects is not working. It works fine in other files. Is there a way to fix this? I assume something's corrupt. How would I find the corrupt object or objects?

Share this post


Link to post

silly question, but have you tried all the usual things like projection, plane, scale etc etc

Share this post


Link to post

When this happens to me, the first thing I do is to copy the plan (being sure to group each layer not to lose my classes) then I open a new document and paste. If something was wrong in the old file it is usually corrected in the new one. Hope it works!

Share this post


Link to post

All good suggestions. The problem seems to be layer plane. When I switch to screen plane all snaps work fine. OK, so I guess this goes back to my hatred of the screen plane/layer plane mess. Why doesn't VW see my view as 2D when I'm looking straight on in front view? I thought this was fixed in 2012 with automatic working plane. So now switching views is not enough. I also have to switch planes. Not good. Is there some setting I have missed with automatic working plane?

Share this post


Link to post

Bruce,

This is exactly why I keep reverting back to working in Screen Plane only. I wish the \ toggle toggled Automatic / Layer / Screen instead of just turning Automatic on and off.

It totally is a mess. The screen mode snaps are so much more useful than the 3D snaps which are really only half functional. And of course anyone who worked in 3D before the screen/layer plane addition is totally dependent on these snaps as part of a workflow...

Kevin

Share this post


Link to post
Isn't a front view by its definition a 3D view?

It is in VW, but when the projection is orthogonal, to me that's a 2D view. Please tell me a situation that warrants front view orthogonal to be a 3D view?

Share this post


Link to post

When a building facade isn't parallel to the x-axis

Share this post


Link to post
When a building facade isn't parallel to the x-axis

bcd,

Please you be more specific. Can you post an image or movie that shows this? When I view orthogonal front view, I only see the x and y axis. Any objects I place in that view are always set in that orientation. There are no vanishing points, and everything I see is in one plane.

Edited by Bruce Kieffer

Share this post


Link to post
When a building facade isn't parallel to the x-axis

Surely in these circumstances, one uses "Look at Working Plane" (which i still have trouble getting to work since the "Planes" Enigma arrived) and this can be reached from a normal 3D view anyway as this is why the various elevation views were realised in the first place, the fact that you can work3D objects in any view is just a bonus of a 3D App. Problem is, despite claims with the new planes iteration, the connections between the two are very limited. Objects and Views continue to change . . . . . . for me anyway.

Share this post


Link to post

Symbols now drive me nuts with the 2d/3d/symbol plane.

It seems that by default the 2D info goes to 3D layer plane. urggg

Share this post


Link to post

I have not used the Hardscape Tool for several VW versions now because I do not like it at all ? rather do it by hand

So recently as it had been ?greatly improved in VW 2012 ? maybe 2011 ? supposedly? decided to give it a burl ? what a convoluted piece of c**p but as I say that - if you wish to use it for pretty things - fine but what about if you wanted to show different things within it turned on and off in different Viewports

Today I tried to put a Hardscape inside a 2d Symbol for a Legend Item within a 2D Legend which itself was a symbol and when I exited the Symbol was told through a pop up ? something like ? you have turned something 2D into 3D so now you will not see me in a 2D view

I reckon the surface of VW is sometimes made to be cool and honky dory ? BUT ? the depths of Vectorworks are un-plumbed and a deep dark science

The lesson I learned today was never use the Hardscape Tool again

Why sometimes as you delve deeper into Symbols, Groups and ?contained geometry? all of a sudden no longer can you see other things whilst in editing modes although you have it ticked in VW Preferences

Sorry to ramble on but how come since I learned recently Screen Plane is a Legacy thingy that is left there because that is how it used to be - today I was drawing away and had not changed nuffin from Layer Plane to Screen Plane and as I tried to add two surfaces together was told both were on different planes ? what whoo back there boy ? I did not do that ? or maybe I did without knowing and that could be the point

Share this post


Link to post

This will never be over until screen plane and layer plane go away. I still say all we need is everything is 3D until I tell an object to be 2D, and when I look at something in one plane (say front view orthogonal), that's a 2D view.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...