Jump to content
Sign in to follow this  
Tom Klaber

Frequent Crashing w/o Cause VW2012

Recommended Posts

We updated to 2012 last week. I have made sure everybody has installed SP1 - but we are experiencing frequent crashes. The weirdest thing is that they do not seem to be associated with any action. A few times now I have crashed when I have not been doing anything at all. Other times is happens simply when I switch windows. This is leading me to believe it might have something to do with the autosaving.

Is anybody else having issues?

Edited by Tom Klaber

Share this post


Link to post

I've been getting problems usually when editing symbols or pluggin objects. I've had a few crashes for no reason

Share this post


Link to post

MUCH more stable than 2011 but still had a few crashes.

Tom

v.2012, SP1, Mac OS 10.6.8, 6 GB memory

2.5 Ghz MacBookPro

Share this post


Link to post

I have experienced numerous "unexpected" (DUH!) crashes in 2012, all seemingly when using Open GL and sometimes Open GL Flyovers... In my case I suspect it is video card related, but so far I can't pin it down. It is true that VW's 2012 uses the video card much more than previous versions. My card has 512mb, and I wish it had about 4 times that much... Ah, maybe my next machine...

Share this post


Link to post
I have experienced numerous "unexpected" (DUH!) crashes in 2012, all seemingly when using Open GL and sometimes Open GL Flyovers... In my case I suspect it is video card related, but so far I can't pin it down. It is true that VW's 2012 uses the video card much more than previous versions. My card has 512mb, and I wish it had about 4 times that much... Ah, maybe my next machine...

You can't buy better card and replace the old one?

Share this post


Link to post

Unfortunately it's really hard to do in an iMac.... So I suppose I could get an Apple Tech to do it, but I'm not sure it's worth it in the long run. My machine is about two years old and I'm thinking that soon it will migrate to the music studio to run Logic and I will buy a brand new one for the office...

Share this post


Link to post

I have been able to better isolate the "cause" of my crashes. They seem to happen after switching windows and then zooming. Frustrating. I am crashing about 2 to 3 times more often than I did in 2011.

Share this post


Link to post

Try reducing the number of Undos

VW>Preferences>Session>Max Number of Undos

also for Undo View Changes be sure Individually isn't selected

Share this post


Link to post

Have you installed SP2?

Also, if it's zooming causing the problem, you could try turning off Vectorcaching in Vectorworks Preferences.

Share this post


Link to post

SP2 has not been released yet - as far as I know.

I got a message telling me to repair my disk permissions. I just tried that - I will see how it goes. If not - I will start playing around with settings.

Thanks!

Share this post


Link to post

Vectorworks has always been very sensitive to video drivers.

Check with the video card manufacturer to make sure you have the most current drivers installed.

Share this post


Link to post

Are you working with migrated files or migrated templates?

Or perhaps imported dwg files?

Or migrated 3rd party plug-ins?

SP2 is available.

Edited by Vincent C

Share this post


Link to post
I have now noticed that switching between programs and then coming back the VWs seems to initiate the issue.

maybe the people at nemetschek are not fond of users, who switch to other applications? ;)

rob

Share this post


Link to post

I really don't think it's the video card because I have dual card which mean three times the handling capability, but it still crashes when push come to shove! However, every bit of extra money and power you can put on the machine would help. Quite frankly, I don't think the technology is up to par for what we do. We are so abusive when it comes to power. I worked on 3ds modeling and rendering a lot, so I know. Don't believe advice from engineer and or computer tech that say: "you are buying a Ferrari, but only drive 25mph." In that analogy, I am buying the fastest car and blew up the engine on OD all the time if I am not careful.

Back to the point of avoiding crashes. BE PATIENT WITH VW... PLEASE!!! It saves you a lot of times and headache in the long run. "WHENEVER YOU SEND A COMMAND OR PERFORMING A TASK, AND VW IS CACULATING, DO NOT CLICK ANYTHING ELSE... JUST WAIT... BECAUSE WHEN YOU CLICK SOMETHING ELSE, VW CRASHES". It happens every time. I am learning it the hard way, but I am learning... The amount of crashes I have reduced from about once every hours in a course of eight hours working session to almost "once in a full moon" when I learned to control my level of anger and impatient... LOL...It does save time in the long run w/o crash. One more thing, VW seems to like the MAC platform better for some reason.

Share this post


Link to post

Update:

My mac was just carted away today after the graphics card fried itself. Maybe the crashes were a symptom of a larger problem.

Share this post


Link to post

Check to see if Apple will warranty the card as they did with my 4 year old MacBook Pro. Labor and materials, no charge.

Tom

Share this post


Link to post

The computer was still under warranty - no charge for the work - though it was returned still not working. I had to have it returned to the "genius" bar where it still resides.

Share this post


Link to post

We too are having numerous crashes in VW2012 SP2. Much more than 2008. We are working on migrated 2008 files which will be very time consuming for us to change. Any other ideas...? I have lowered my undos as well. It seems to happen more often when editing symbols/wall types etc from the resource browser. Very annoying at the moment.

Thanks

Richie

Share this post


Link to post

Just as an update to my above post. I installed Lion on my machine yesterday morning and I havent had a crash since...! I'm crossing my fingers that fixed the problem and will install on the rest of the machines next week if so.

Richie

Share this post


Link to post

Hi Tom...

So far so good with Lion. I've now got it on all the machines in the office with VW2012. In over a week of continuous drawing I've had my first crash about 5 mins ago. Thats less than our version of 2008 used to crash...!

Richie

Share this post


Link to post

Me too. About 5 crashes already today and at least 2 per day since I started working in 3D. Actually, working in 3D in VW is pretty disappointing so far. Is it really true that you have to buy Renderworks to get a usable shaded view that you can usefully work in? Also what's up with the weird 3D selection problems; it almost never selects the thing thats nearest to you, always something behind that you can't see which you weren't trying to hit. And the UI in VW is constantly flickering with little messages and things that highlight as you move the mouse around over the model, it's manageable in 2D but in 3D it picks up everything and makes me feel like having an epileptic fit. Is anyone else having problems with VW12 and 3D stuff? I'm using a site model and I wonder if it's too much for VW. Maybe I should cut and run and start using iRhino instead? What have others experienced? Sorry, that turned into a bit of a rant, it's after midnight now and I want to go to bed...

Share this post


Link to post

I have found the selection process much improved. The auto-highlighting - which is an option you can turn off - is a feature I find decreases the amount of miss-selections. You can also change the amount of time you have to hover on an object before the pre-selection indication appears. Even changing that to an 1/8th of second means objects will not pre-select as your mouse simply passes over them. Check out the options in VW preferences - interactive preferences - you should be able to modify the behavior to your liking.

There is also a new Rhino inspired feature that when your mouse is over multiple objects a * appears. If you hold down the Cntrl key or right click - a list appears allowing you to select the desired object.

Edited by Tom Klaber

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...