Jump to content

The Blessing* - problem with retaining wall site modifier


Recommended Posts

* The Blessing - Torchwood - a hole through the earth between Shanghai and Buenos Aires

I am having a problem with the retaining wall site modifier. I think I can see what is going on, but I don't know why and more importantly, how to fix it.

I have a site model built with survey data between approx 45.6M (45600mm) and 51.6M (51660mm). All design layer levels are all at Z:0. I am now in the processor of adding terraces in 3D space and associated retaining walls.

I have a pool area currently with a hardscape (currently) slab at Z:48225. On three sides are retaining walls - 1500mm high, Bot Z:46725 and delta Z:1500.

From the 3 walls, I have created a retaining wall site modifier. On the inner (terrace) side, the retaining wall is offset:0 below wall top. On the outer (grass) side, the site modifier follows the terrain.

On creation of the site modifier, I can see that the site modifier has gone wrong, or is not as I would have expected. The pad offset and side that follows wall top would appear to be correct (pad offset at 46725 [bottom of wall] and right modifier edge elevation at 48225 [top of wall]), but the side that followed the terrain has a modifier edge at 0.

Updating the side model to reflect the retaining wall modifier predictably goes horribly wrong, with the outside edge being incorrectly forced at 0 elevation rather than somewhere between 46725 and 48225 depending on the terrain.

Attached file illustrates the issue.

I cannot seem to fix this. Setting the elevation of the outside modifier edge to within the expected bounds simply shows a flat line - so it has not followed the site model but simply offset by 46725. So I cannot fix the issue.

This only appears to affect the creation of the retaining wall side modifier when the follow terrain option is used. If I set if as an offset from the wall, it works as I would expect, but not how I need.

Thinking that this might be an issue with having the level data at 50000 or so and design later Z at 0, I tried this on a simple test model. The result was correct and as I would have expected. So it is something to do with this file/model.

I have also tried it on other walls in same model. Exactly the same incorrect result.

I hope that its user error that I can fix, but I cannot find anything obviously different between this and the text model other than complexity. I cannot even find a work around and am basically stuck. If I convert the pool terrace to a pad, which I will eventually do, the modification to the site model is not as desired, so it needs the retaining wall modifier to follow the site model data to achieve the correct result.

Link to comment
  • Vectorworks, Inc Employee

Hi Ian

To get you out of a hole, you could make your own modifier...

Ungroup your retaining wall site modifier to get to its component parts. Delete the offending element.

Draw a 3D Polygon along the edge of the outside of the wall. Use Landmark > Send to Surface. This will adjust the 3D Poly to the terrain.

Put the 3D Poly into the Site-DTM-Modifier class, and it becomes a modifier.

I hope that helps you get moving again.

Link to comment

Hi Tamsin

Thanks for the suggestion but unfortunately it did not work. It was really odd but I could not send to the surface. Maybe a clue to the underlying issue, but if I have created only one site model, would you expect send to surface to give me the option of sending to 'site model' and 'site model-1'? I tried sending to both but either way, no joy.

However I did make some progress before I gave up with the retaining wall command.

I found that the result seemed to be dependant on either class or layer visibility - I think layer visibility. I had the site model on its own layer and when I was in 2D I had turned this layer off. I also had two saved views, which changed the working layers and class/layer visibilities. As a belt and braces approach, after I had set these all to all visible and show/snap/modify others I found that the edge modifier that followed the terrain came to within expected values. However, the whole site modifier got shifted about 12m off from its correct position and could only be fixed by restarting VW. Also, whilst the terrain modifier did follow some terrain, it was not the correct terrain as part of the model exceeded the height of the retaining wall. So I could not even move the site modifier back to its correct position. Something is definitely not right - this shifting should not be happening at the very least, but without being able to recreate the issue with a smaller model and a few steps, its not going to be worth submitting a bug, especially with me being on VW11.

What I did end up doing in the end was taking your suggestion of creating a 3D polyline, sending it to surface and turning it into a site modifier. Visually the results look correct although I suspect that cut and fill calculations are way off.

But it still was not plain sailing. The terrace around the pool was a hardscape slap whilst I got the site model correct around 3/4 of the pool area. However, when I turned it it to a hardscape pad, its position too was way off. This was done in isometric view. However when I redid in top/plan view, it worked fine.

I think what I'm going to do is to revert to my 2D only plan and rebuild the site model a fresh...

But this all got me thinking that I am having a senior moment - I can't work out how to view what site models are in existence and if it is possible to correct underlying data in the existing site model.

Link to comment
  • Vectorworks, Inc Employee

Hi Ian

Well, it seems something has gone seriously wrong in your file...

If you have created only one model, there should be only one model.

You can get back to the source data - right-click the site model and choose Edit Source Data. Is it worth copying the source data into a fresh file, and creating a new model from it? You could then move your modifiers across and see if it behaves better for you there?

I would also recommend trying out referencing the original survey using a Design Layer Viewport rather than working in the same file as the imported DWG.

Regarding layer visibility issues - check the settings of the site model. It is now possible to choose which modifiers will affect the model - all layers, visible layers only or only on the same layer as the site model.

SOrry to hear of your problems. Hope this helps.

Link to comment
  • 11 years later...

This is very odd: I am having the same issue in VW2020. Exactly the same behaviour of a retaining wall site modifier generated from the wall tool--i.e. the bottom of the modifier attaches to the Z0 layer, even when sent to the surface. None of the other modifiers does this.


(The effect on the front of the retaining wall, is a vertiginous chasm, bottoming out arbitrarily when it hits the linework layer on which the wall is based)


Incidentally, the separated issue of all modifiers creating themselves at some distance from where they're meant to be when generated while working anything other than top plan is still there, but can be worked around.


However, the Z0 problem really makes working on terrain impossible! I'd be *very* grateful for any help or insight. Image attached.



Screenshot 2023-09-16 at 11.49.31.png

Edited by m deasy
Link to comment

@m deasy 

Are there other site mods overlapping/touching the retaining wall mod? That causes conflict which usually shows up as warning triangles in Top/Plan. One trick is to create a sacrificial duplicate wall but assign it smaller wall thickness. Create new retainer then delet the wall. Retainer will be slightly embedded in the original wall volume, but should avoid conflict with other mods. 


Can you edit the retainer and drag the end points up to desired z?  


Just a thought - did you try delete the retaining modifier, then regenerate the retaining modifier from the (new?) wall? Might be the parameter for that low edge defaults to z=0, so needs adjustment during creation.  ???



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...