Jump to content

printing to HP455CA using pdf's and OSX

Recommended Posts

There have been many posts about printing to a plotter using pdf's in OSX. The following are results and problems that occur in our office. If anyone has reccomendations for the problems, we would greatly appreciate it.

Our network consists of 6 client macs (all running OSX and VW 9.5), a file server (running osX) a print server (running OS 9.2 and HP 455CA Rip software) and an HP 455CA plotter connected to the network via an external HP jet direct.

As many people w/ the 455CA plotter have discovered, we are not able to print to the plotter directly out of VW without getting PS errors. We CAN print to the plotter natively in OSX by generating PDF files and printing directly out of Acrobat. However, the following problems are occurring with our physical output:

1. Fills with lines in them print as a solid grey even though they appear correct in the pdf file. Hatches print correctly.

2. Images imported into VW print out as solid grey even though they appear correct in the pdf file.

We are so close to having a completely native OSX network---if only we could only resolve these glitches. Recommendations much appreciated.

Link to comment

I have a 455ca / TiBook 667 / OS 9.2 / running HP RIP thru a routed network to a jetdirect server - when I generate a pdf of a drawing using pdf writer or printtopdf - I get an error from the rip software telling me the format is not supported - so I then have to use the adobe ps print driver to make a .ps file so the rip software recognizes it -

What am I doing wrong? How can you send a pdf direct to the printer? What do you choose in the chooser in your server that's on OS9.2

Thanks in advance - John Broderick

Link to comment

I remember getting that error back in the days of using OS 9 on our clients. We always had to convert to PS first. However, none of our client Macs are printing from OS 9 anymore---they all print from native OS X programs. The only computer running OS9 is the print server---so that it can run the HP RIP software. I wish I had a better explanation for you, but consider printing from an OSX computer. It will send the print file to whatever OS 9 computer is running the HP RIP software.

Link to comment

The HP RIP only supports postscript-- that is the whole point. Think of the HP RIP as a standalone postscript printer. You can dump postscript straight to it (ever dropped a .ps file directly on a postscript desktop printer in OS9?) or you can send postscript information to it through a postscript printer driver-- like Apple's Laserwriter 8 driver.

PDF files are not postscript-- which is why your RIP software can't understand them. Its job is to take postscript input and convert (or "RIP") it into something that you plotter can understand-- in this case probably HPGL/2.

So, to print a PDF file to your HP RIP you need to print it with Acrobat and either Adobe's PS Printer Driver or Apple's Laserwriter 8. That will convert the .pdf file back into a .ps file that the RIP software can understand. You can, of course, just generate .ps files straight from vectorworks using Apple's Laserwriter 8 software and either save to file, or setting up a dedicated "translator" desktop printer.

Printing from Preview works because it is just rendering the PDF image and sending the data through the printer driver, which is converting the data back into postscript for transmission to the HP RIP. Not all PDF renderers are equal and you may find that something that works in Preview may not work in Acrobat and something that works in Acrobat may not work in Preview. I would expect this to be especially true when dealing with things like fills and embedded graphics.

Has anyone tried using Ghostscript on OSX to communicate with the HP 455CA? That might be an option besides relying on HP's RIP software.

Link to comment

In order to print from OSX, you will need to set up the HP455CA printer in Print Center by selecting it from Appletalk connection (make sure the RIP software is running on the OS9 print server so that it can be seen by other computers using Appletalk). Once you select the HP455CA, assign it the HP455CA ppd.

Link to comment

Thanks for all the tips. I did not realize that you could select the 455's ppd through the other option in the print center. I just went into my extensions in my OS 9 folder. It all seems so easy now. Additionally maybe you could try this test regarding the post script error message you get if you print directly from VWKS 9.5 I had a problem with VWKS crashing in OSX when I opened some files,but not all. As it turns out I had a font that was corrupted. When I removed the font from the system then all worked fine including printing directly from VWKS 9.5 in OS X to the 455 on the network running the RIP on an print sever running OS 9.2 ! I did a test with a file that had the bad font in VWKS 9.5 on a OS 9.5 machine and it crashed the RIP with the postsrcipt error problem. Then I took that same file and opened it in VWKS 9.5 on the machine running OSX. It subsituded geneva for the bad font and printed fine directly from VWKS9.5 on an OSX machine to the 455RIP on the OS 9.2 machine! I will do further testing but could it be a bad font crashes the RIP not any inherent problem with the 455 RIP or VWKS 9.5? And then you do not have to do the PDF file, Acrobat business.

Link to comment

This is a copy of a response in the Architect discussion area.

I think it was just a corrupted font. Not really a problem with either VWKS or the 455's RIP. There was no way to tell that the font was corrupted really. The only way I knew was a file I sent to VWKS tech was crashing VWKS in OSX. The file worked fine at tech support . They got the font substitude dialog box to replace the lithos font to geneva. So they though maybe it was the font. I got rid of the lithos font out of my system folder and the file worked fine on my machine. Then I noticed afterwards that I could print directly out of VWKS to the RIP without the postscript error. A few more tests and that seemed like the problem. I have since reinstalled the lithos font and all is well. I did get system messages on my powerbook that "some fonts are corrupted and ATM will try to fix them or reinstall the fonts from the CD". This i just ignored because it wasn't causing any apparent problem on my powerbook. But as I think about it makes sence. My Lithos font is a postscript font. I can see where it would cause postscript errors if it was corrupted. Maybe just a slight corruption enough to crash the RIP in VWKS9.5 but not enough in VWKS 8.5? Tech support said VWKS 9.5 and OS X is more sensitive than 8.5 I would suggest taking out any font that did not come with the MAC and see if you can print ok from VWKS to the RIP. Then put back in fonts one at a time to test or reinstall them one at a time. This Lithos font I had I got from a friend years ago and have been just draging it into the system folder for years on my machines. I since purchased the font and installed it correctly and all seems fine.

Link to comment

The HP software understands .pdf as well, it has a .pdf rip included. so you can even directly drag a .pdf onto the window of ps rip and it starts ripping...

But hp rip is horribly slow and produces errors in larger files. The best solution for me was to buy a PC (ugly, beige) and windows 2k server, install appletalk and let it rip. It's fast and reliable.

Link to comment

i feel the HP RIP is fine once you get it dialed in. I demo-ed a 3rd party RIP "Posterjet" which is a $3,000 dollar program that is the graphics industry standard for large format plotters for macs. It was slower than the HP RIP. Makes no sence. The time is different to if you are running it off only one machine, or a network or off the machine that has the RIP on the network. time is also reative. Depends on what you are timing. On Macs when you execute the print comand to the 455, it first goes to the lasterwriter software for processing to a postscript file, then it goes to the RIP for further processing. A lot of time is spend at the laserwriter level which has nothing to do with the RIP. A lot of time at the laserwriter means network /application problems. The RIP seems to work fast for me if you only print to the RIP machine from another machine on the network not the machine with the RIP running. Use that machine only as a server and in my case it is my old G3 powerbook with 256 mb of ram. Set the ram for the Rip to at least 40-60 mb depending on what you are plotting. 60mb seems fine for vectorworks files and photoshop files go really fast because they are already raster files.

Link to comment
  • 2 weeks later...

I have found some things that crash the 455RIP. Some crash in VWKS 9.5 and 8.5

Corrupted fonts: make sure you have good clean installed fonts. If the rip is crashing on some files, try using only the fonts that come with the computer.

Fill patterns: some work fine, some crash, go figure. you can kind of see from where the printing stopped as to what is causing the problem.

some bit map graphics (like maps from internet) do not print or print black, why? stay tuned

Link to comment
  • 2 months later...

G'day folks,

I've been writing PDFs from VW 9.5 quite happily since upgrade to OSX several months ago. I've done it successfully with the "Preview" command, which opened a PDF automatically with Acrobat reader. I've also used the "Output Options" selection "Save to File / PDF" command in the Print Dialog.

This has been the most reliable method until about 2 weeks ago when both options ceased to function. "Output Options" writes to a folder, the icon would appear, but then vanish when clicked upon to open the file. Now the icon makes no appearance at all. Likewise with "Preview", the software seems to go through the correct sequences to print a file, "printing file...", status bar, etc., (no save option appeared BTW, previously or now), but at the end, Acrobat fails to open and display the file.

The "Output Options" command was a nice simple way to create the PDFs. Seemed to work very reliably too.

Anyone have any ideas why these options would quit working?

System:G4, 1 Gig/mem, OSX.1.4, VW 9.5.1, Acrobat Reader 5.0.

Ideas & suggestions will be much appreciated.Thanks,

Charles Davidson

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...