Jump to content
Sign in to follow this  
Tobias

Textures not showing in open GL

Recommended Posts

Hello I am having a problem with a file in VW Renderworks. The file is showing no textures in open gl mode. Final quality seems fine. If I open a new, clean file open gl seems to work as expected. Is there a fix for this?

Tobias

Share this post


Link to post

Took me a minute to find the prefs for open GL, but yes it is set to use textures.

-Tobias

Share this post


Link to post

Some shots in the dark:

Sometimes it helps to enter, then exit the texture def in Resource Browser. Or edit and tweak something, then edit again to change it back.

OR maybe problem is a corrupt symbol or other object? Something converted from an old version?

Paste-in-place a couple objects into a new file, enable OGL texture pref, and render with OGL. The textures should transfer with the objects, and render successfully unless the object(s) or texture(s) are corrupt. If all OK, paste another bunch of objects to the new file and render. Repeat until render fails.

OR it could just be OGL limits.

I noticed that some image mask textures behave strangely in 2012 OGL (haven't tested in v2013). Specifically, if texture color shader is set to Object Color, then two objects with same texture, but different color, will both render same color. Renderworks can render both colors, so it's an OGL issue. There may be some other limit which you have uncovered.

-B

Share this post


Link to post

Tried the edit. Went from bad to worse: lost all rendering ability, and when editing the resource (it was a texture I created on photoshop) the base image was no where to be found. I couldn't even upload the file again. Transferred to a new file: same issure. Been doing this texture creation for years with nary a problem until now.

The "work-around" I found was to use save the original image I created on Photoshop as a .png file instead of .jpeg file. Uploaded back to the texture no problem. I hope this will last. Very weird, and very annoying. Time to buy a better graphics card...?

Share this post


Link to post

Maybe that Photoshop file was too big. There is a size limit - .5 MB is usually enough for clear renders, 3 or 4 MB will work, but 10 or 12 may be a problem. Vectorworks doesn't like huge image files for textures.

-B

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...