Jump to content

create a viewport of a selected area

Recommended Posts


when i click 'view' / 'create viewport', it creates a viewport of everything on my design layer. if i want to create a viewport of a selected area (in order to do a detail, for example), how do i do this? i don't want to copy the drawing and put it on a fresh layer and modify it, that seems really backwards.


Link to comment
  • Vectorworks, Inc Employee


Draw a shape (e.g. a rectangle using the rectangle tool) over the area you want to show. Leave the rectangle selected and then run the Create Viewport command. When prompted to use the selected item as a crop, click Yes and it will create a cropped viewport.

Once the viewport is created, you can double-click it and choose to edit the crop. Then you can adjust the cropping rectangle as necessary - move it, or resize it, change its line weight etc.

Hope that helps!

Link to comment


thank you for this - i created a rectangle over the area i wanted to show, clicked 'create viewport', but no prompt came up. i just get that pop-up where you choose the scale and render style and all that. do you know how i can get that prompt back?

thank you!

Link to comment

Did you leave the rectangle (or closed polygon/polyline/oval/circle etc.) selected?

If so, when you get done with the create viewport process the selected object will be moved to the Crop of the viewport.

If you forget to create the crop before you start or need to modify the crop, select the viewport and double click it. You should get options to modify the Annotation, Crop or Design Layer. Select Crop. Draw any 1 closed 2D object and it will be used to crop the viewport.

Link to comment


yes, the rectangle is selected when i click 'create viewport', but i still don't get an option to create a viewport using a crop. all that happens is when i click 'create viewport' i get my entire drawing on a sheet, just with the rectangle over part of it.

however your second suggestion worked. if i doubleclick on a viewport, select 'crop' and a 2D object it crops the viewport. this will work for now, although i'd like to know how to do it the other way!


Link to comment

Dave, just musing here

One of those informational dialogs pops up the first time a crop is used with Create Viewport command (paraphrasing): Use selected object as a Crop? Always complete this action without asking?

You may have checked that Always option, so now the crop dialog does not pop up during the Create Viewport command.

Seeing the crop rectangle on top of the entire drawing rather than cropping the drawing could mean several things:

1. You created a Design Layer Viewport placed in an existing design layer (or even a new design layer). Check your navigation to see if you are in a sheet layer or a design layer. If you are in a design layer and have layer visibility set to one of the Show Others modes, you could see all the drawing including the new DVLP shown in position of creation. Select the new "rectangle" and read the OIP to see if it is a Viewport or a rectangle.

2. You successfully created a new cropped VP on a sheet layer, and on the same sheet you have a previously created viewport, uncropped, showing the entire drawing. The new rectangle you see after running the Create Viewport command is actually a cropped viewport, but it's overlaying the previous one. Select it to see what kind of object it is. If it's the VP you want, select and delete the other one(s). There may be several of the full sized ones stacked on top of each other - one for each time you ran the command.

3. Or there could be a system or install screwup. Try a restart.

When things are screwy like this, test on a new blank drawing -

Create a few objects and a crop object.

Select the crop, click the Create Viewport command.

In the destination pulldown choose New Sheet Layer.

If it works here, it should also work in your project doc.

Good luck!


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...