Jump to content
dave sec

the stupid pink square is the Working Plane...it's kinda cool, actually

Recommended Posts

of my screen..

i can't click on anything anymore. any idea what button i pressed? this program is still irritating me!

Share this post


Link to post

Check class visibilities and settings

Check layer settings, perhaps you changed layers by mistake ( cmd arrow up/down) and the grey stuff you're trying to get to is on another layer.

The stupid pink box is probably the print/page boundary.

How long has it had a chance to irritate you? :grin:

Edited by Vincent C

Share this post


Link to post

The pink square indicates that a Working Plane is there and that you are in a 3D view (possibly because you are editing a symbol or the 2D of an extrusion - is there an orange border to your window?). Try returning to Top/Plan View and if you are in edit mode exit that mode.

Share this post


Link to post

Ha ha you sound like an AutoCAD user being forced to use VWs :)

Edited by Vincent C

Share this post


Link to post

I am having a similar issue. 
I've been using Vectorworks for less than a week now. Long time AutoCAD user. Sometimes my drawing entirely disappears and this pink square pops up in its place. The pink square has a dashed border and a slightly darker pink color inside. Often a red vertical line appears at the same time. Neither the square nor the red line seem to be selectable. "Undo" doesn't seem to have any effect. Panning and zooming make the pink square move about the screen, but my drawing doesn't seem to be there. Zoomed all the way out, I can create a selection marquee, but nothing gets selected. All of my layers and classes are set to visible. 
This comment thread seemed to state that this might be a 3D view, but I'm not familiar with 3D operations yet. 

When I close the program and restart it, the pink square and red line disappear and I'm back to normal, but I keep losing all of my work. 

I'm using Vectorworks 2019 SP3 on a Windows machine.

If someone could tell me what I'm doing to make this pink square appear and how to avoid making it appear in the future, I'd greatly appreciate it.  

Share this post


Link to post

I think you might be going into an edit mode on a symbol and you have "show other objects while in edit modes" turned off.

 

Do you also see a gold border when this happens?

 

The numeric keypad can also kick you into a 3D view.  Zero on the numeric keypad gets you back to Top/Plan.

Share this post


Link to post
Posted (edited)

I'm still trying to learn my way around the software, and I don't believe I have used a symbol yet. If I did, it was accidental. No borders of any type have appeared.

This thread mentioned a "working plane." I did a google image search of the term, and it surely resembles the pink square I'm seeing. I just don't understand how I'm activating it, why it seems to make the rest of the drawing disappear, or how to get rid of the pink square after I accidentally make it show up. 

Edited by Cheeselog
typo

Share this post


Link to post

Hitting Zero on the numeric keypad should bring you back.  

 

Share this post


Link to post

I believe it was a 3D view issue. Thank you.
It's excessively confusing that the number keys on the top row of the keyboard do different things than the number keys on the side of the keyboard. The difference between the function of the two number entry options is not yet muscle memory to me. 

Share this post


Link to post

Here's a bit about the Working Plane...you can invoke the WP by hitting Shift 1.  You can see it snaps to the various faces.  If you go to Top/Plan view and back again, it'll be gone until you hit Shift 1 again. It works kinda like the C-Plane in Rhino.  There's also the Ground Plane which is at Z=0 of the layer. You'll see it right at the beginning of the video over to the left.

 

Some AutoCAD folks have had troubles with multiple Design Layers (that equate to their singular Model Space).  You can also go to Vectorworks HELP to discover more...  Oh yeah, there's something called  Unified View.  If you are modeling it should always be ON.  In fact, I don't ever have the icon showing so I don't accidently turn it off - it's left over from years ago, but some folks find a use for it...

 

 

Share this post


Link to post

Ive never see that "Ground Plan" is there a way to activate and deactivate? I often find myself needed to verify if Im at z=0

Share this post


Link to post

Hi All,

 

Let’s look at a little more Working Plane magic.  First to invoke the WP, I use the shift key and the number 1.  I’m not sure where I learned that, but it works...in the video, that’s what I do to set the WP on the Ground Plane – just do Shift 1 and click in white space the WP will be set on the GP.

 The next sequence describes how you can set the Automatic Working Plane...the trick here is that you MUST select a 2D tool FIRST, then as you mouse over faces, you’ll get the AWP snapping to those faces. 

The next sequence, I take those funny looking nodes and change the axis of the WP.  To do that, just click on the edge of the pink WP and you should get those nodes.  When you go back to Top/Plan view, the WP disappears. 

A helpful modelling trick might be, if you need to return to some sort of wacky, off-axis plane, create a Saved View and that’ll let you return to that view.

 

That’s all for now, Enjoy

 

Wes

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×