Jump to content
Sign in to follow this  
GWS

OpenGL

Recommended Posts

Before SP3 I used to be able to render in OpenGL with the 'Draw Edges' option on and get a fairly good outline.

Now I get all sorts of lines crossing over the surface of objects.

Anyone else?

Share this post


Link to post

Is it possible that the object is duplicated? I often see that behavior in open gl when two surfaces are coincident.

mk

Share this post


Link to post

Hallo,

I have my office Computer not yet updated, so I could make a Test with Open GL Rendering and Draw Edges in VW 2011-SP2 and VW2011-Sp3 and can't see the triangulated Surfaces.

Horst M.

Share this post


Link to post

Horst this is where it gets really odd because I do get the lines in my renders.

Maybe its an OS problem - I'm on OSX 10.6.7 whereas you are on OSX 10.5.8

Share this post


Link to post

The OpenGL Render of Mikes "MM..." file doesn't show the triangutaltions on both of my Computers.

Could that really be a driver problem caused by the OS?

I was really thinking about upgrading, because for some Programms I need OS X 10.6. But I don't want Open GL Renderings to be destroied.

It would be nice If someone else with OSX 10.5.8 and VW 2011 could try the Files.

Share this post


Link to post

MichaelK is on OSX 10.6.6 and he doesn't get those lines either so that would seem to shoot my theory down in flames.

Edited by mike m oz

Share this post


Link to post

Hallo Peter,

could you explain a bit what that bug is about, and what we have to do to avoid it?

Edited by Horst M.

Share this post


Link to post

The bug I filed has to do with many extraneous (triangulation) lines showing up which radiate (mainly) from openings in walls. See attached. Not 100% sure that what you guys are seeing is the exact same thing, but I would guess it comes from the same cause...

Share this post


Link to post
MichaelK is on OSX 10.6.6 and he doesn't get those lines either so that would seem to shoot my theory down in flames.

No, I'm actually on 10.6.7.

I have occasionally seen the issue with walls and with extrudes made from clipped surfaces.

But I opened GWS's original file on my machine and nothing I could do would make it render with those extra lines. It opened up clean and stayed that way.

curious....

mk

Share this post


Link to post

So if it is not the OS and it is not the Vw version then what is it that makes this a problem for some and not others?

Share this post


Link to post

I've exported my file to Vw 2010, Vw 2009 and Vw 2008 and the same problem exists in all three versions.

So maybe michaelk is right and its a problem with the video cards.

Or is it a problem with the OpenGL on some computers?

Edited by mike m oz

Share this post


Link to post

My iMac has the same problem. I tried subtracting the circle from rectangle, to see if it was a geometry issue, but that didn't work.

Maybe try going into 'OpenGL Options' under pull down menu 'View - Rendering'. I am getting less 3D polygonal triangulation playing with these settings.

Share this post


Link to post

It seems the main setting that fixes this is turning on anti-aliasing in OpenGL Settings.

For your viewports you might want to turn on Mesh Smoothing in your Document Preferences. Not sure if this works with OpenGL though.

Share this post


Link to post

I just exported it back to VW 2010 and VW 2009. No problems on either one.

I'm way outside my comfort zone here, but isn't Open GL handled by the video card and other rendering modes handled by the CPU?

I wonder if the machines with the problems have a specific card or vram size?

mk

Share this post


Link to post

Diamond turning anti aliasing on just makes the lines look finer on screen and therefore less obtrusive. It doesn't get rid of them.

The lines which show are the segments that exist in the object. When OpenGL is set to Very High there are lots of them and when it is set to Low there are fewer of them (see images below).

With Hidden Line Rendering you can remove these segment lines by setting the Smoothing Angle to a value other than zero. I'm guessing that OpenGL has a similar hidden built in functionality. For some reason though this seems to works with some configurations but not with others.

Share this post


Link to post

Is there possibly a similar set of settings for adjusting the Open GL settings directly through the video card?

Ie does the video card have customizable settings of its own?

Edited by Vincent C

Share this post


Link to post

Hi Mike,

I found the 3D polygons that were showing on the model you posted showed up in different places when I changed those preferences. That said, although fewer, there was still some 3D polygonal vertices showing.

Maybe it is best just to go back to the old days in the SLVP of turn off draw edges in the Background Render OpenGL Settings, and turn on hidden line render in the foreground render settings (This is what you are suggesting above?).

Cheers.

Edited by Diamond

Share this post


Link to post

Yes, not using the 'draw edge' option and going back to the good old days is where I'm at.

Yet another workaround to add to the ever growing list......

Share this post


Link to post

Yes, as many upsides as there are to being able to do things many different ways in VW, this is one of the downsides.

The openGL is much better in 2011 than 2010 it would seem (besides this issue). We are testing it to keep abreast of the updates, but will jump into VW2012 when it arrives after September.

All the best.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×