Jump to content

glitchy VW2011 snap to behavior

Recommended Posts

I've been a user since Mini Cad... so Im not exactly a newbie. This has me stumped - but I'm sure there is a simple solution- it is just escaping me.

I can't seem to get the snap to right-

I have disabled snap to grid and enabled snap to objects- yet I still have trouble getting objects to snap properly and even dimensions seem to be drawn to some invisible grid. I think it has to do with the new 3d enhancements, but I cant seem to figure out the right configuration. It is frustrating and annoying, not to mention slow.

anyone else experience this and have suggestions??



Edited by DaveHi50
Link to comment

No fix, but some sympathy:

I find that the 2011 Move by Points tool has some uncertain snapping - esp can't always find a polycurve center when the Select tool can. I am not always confident about snaps and check vertices more than I should. Snap Loupe helps.

I get an "illegal objects" extrude error in 2011, only to find stacked vertices in the attempt source poly. But this may be something other than snapping during poly creation.

Weird possible causes: Snap to offset on one or more of the snap prefs? Selection highlight controls? A bad font messing the OS? Objects or object centers on other layers clustered near your intended snaps? Layer or class visibility not as expected? Unified View options?

You probably tried these usual steps: OS maintenance. Restart. Fresh file. Test in a different user accnt on your OS. Test on other's VW license and machine. Reconfiguring the Smart Edge snap options (made my life easier). You say Snap to Grid is off, but try increasing the snap and ref grid sizes x10, then toggle them off and on btw tests.

Hope you get it working


Link to comment

yep I find things snap to points that aren't displayed, not at all happy with version 2011, too many crashes, odd behavior, ghost images tools sometime working and then not, I wish nemetschek would concentrate on getting things working properly instead of coming up with new tools & gimmiks...................rant, rant, rant.

Link to comment

Aloha, Dave: I had similar issue once. I can't really recall what I did exactly to fix it since I was trying one thing after another. Peter Cipes was great help when he worked with me. Perhaps he will post something specific...

Try the following:

1. In VW prefs. reduce the size of your "selection box size" and "snap box size." This seems to have an effect on how precisely you can snap.

2. Go through your smart cursor settings?double click on any one of the items in your Snapping palette.

3. Few things that I changed to were:

a. In the General Category?all box checked except Snap To Individual Pages

b. Grid Category?doesn't have any effect I think since I also have the "snap to grid" disabled.

c. Object Category?Everything checked except Nearest Point on Edge

d. Angles Category?I have Angles From Axes and Plan rotation enabled.

e. Smart Point Category?(probably critical for you current issue) Everything enabled except Datum Offset. As per Peter I set the Acquire Smart Point if the mouse stops for "0.3 seconds. And Set Datum if the mouse stops for "0.6" seconds.

f. Smart Edge Category?All enabled except Snap to Offset. Acquire Edge if mouse follows edge for: "0.3 seconds

g. Distance Category?Snap by: Percent? I have "25"

Try this if doesn't work you might want to Reset the smart cursor settings see if that changes anything.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...