Jump to content

=('Space'.'Area') don?t work


Recommended Posts

Here it is...

For this file I started with your file and did the following steps:

1. Changed =('Space'.'Area') to =('Space'.'Gross Area')

2. Inserted a 2D locus on one side of the space object (as a place holder)

3. Resized the space object

4. Recalculated the worksheet

5. Resized the space object back to it's original size.

6. Deleted the 2D locus

7. Recalculated the worksheet

Space object label is 37.5

Worksheet cell is 37.50



Link to comment

Turns out you don't have to resize the space object. You just have to get it to refresh.

This also works.

1. Change=('Space'.'Area') to =('Space'.'Gross Area')

2. Select the space area object(s).

3. Shift-right arrow, Shift-left arrow (or Shift-command-arrow) [moves the objects and moves them back and forces a refresh]

4. Recalculate the worksheet.



Link to comment
  • 2 weeks later...


decimal marker issue for ('space'.'area') calculation

I had exactly the same issue. Then I realized that the regional settings on my computer are set to Germany (if you are using Windows this is in the control panel>regional and language options). The issue seems to be that in UK and USA numbers are stored as in the format 123,456,789.00, whereas Germany and some other countries are using the format 123.456.789,00. This means the decimal marker in UK/USA is .(point) whereas in other countries it is a ,(comma). The regional setting seems to have an effect on the calculations of the Vectorworks worksheets, as if Vectorworks doesn't recognize anything behind a comma. After changing my regional setting to UK every newly created space in Vectorworks came up with a .(point) and best of all the =('Space'.'Area') works and also simple =sum() calculations are working again.

I am not sure whether this will solve your problem, but given your user name it sounds as if you are based in a German speaking country and it might well be the same issue.

Link to comment

Given that the user who asked the question is based in Munich I bet my Vectorworks licence that changing the regional setting to use points as the decimal marker instead of commas will resolve the problem. I have tested it back and forward and with commas (German setting) the values behind the decimal markers are lost when using the =('Space'.'Area') command.

Link to comment
  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...