Jump to content

Slow Redraws with Biege G3 IX3D Cards


HiPhi

Recommended Posts

I'm a recently appointed network manager for a firm of architects using Apple Mac cpu's and VectorWorks. Most of the Macs are G3 or G4 units and I've recently updated them to MacOS v9.2.1. They all have around 200MB + RAM and are driving large (20") monitors at about 1150 x 870 pixels. Before upgrading from Mac OS 8.6 the redraw speed of the VectorWorks drawing was quicker then in Mac OS 9.2.1 and I can't figure out why. I've left the Apple OS installed ATI Rage driver extension on and tried leaving the ATI Radeon off but even in 256 colours the redraw is noticeably slower. The G3's show the problem not the G4's. The G3's have a ATI 3D RAGE Pro PCI chipped graphics card built-in on the Motherboard. The systems were using the following drivers before upgrading, but even if I put them back in it doesn't seem to do much for the systems performance:

Apple IX3D Graphics Accelerator v1.0.4Apple IX3D RAVE Engine v1.0.4Apple IX3D Video Memory Manager v1.0.4

In the system profiler shows the following:

Card Type - DisplayCard Name - ATI-Mach64-3DUProCard Mode - ATI, GT-CCard ROM - 113-XXXXX-1.1Rev - 92Vendor - 1002RAM - 2MB

I know the VRAM is low but why has it only slowed down since upgrading the OS? The Office is a loyal user of VectorWorks and we would appreciate some assistance.

Thanks in advance for a speedy reply. confused.gif" border="0

Link to comment

The redraw should not be slow in VW 8.5.2 especially on a G4. First off, make sure you have the most recent video driver installed to match OS 9.

Next, check the maximum number of undo's set in File>Prefs>VW Prefs. We recommend this to be at around 20 undo's. Of course if you are not comfortable with 20, set it to a number you do feel comfortable at. Please note the higher it's set, the more memory and cache it eats up, leaving slow redraws often times.

Next check memory allocations for the application. There is an ongoing debate about the minimum and preferred and whether they should be set the same number or different numbers... In my experience here, often times enough, people that have the min and preferred set to the same number and have redraw or memory related problems, their problems are alleviated when the min is set to the same as the suggested and the preferred is then set to a higher number. I have a G4 here with 256 megs built in RAM and ATI Rage video card. Depending on the file size I am working with, I leave the min to the same as the suggested and increase the preferred to about 90mb in VW 8.5.2 and 120-140 mb in VW 9.x.

Another thing you can check is the resolution setting you have for the display. If it is set to millions of colors, try setting it to 256 colors. If it's set to 256 colors, try setting it to millions of colors.

Link to comment

Hi Katie,

Thanks again for the suggestions but I've already checked them before posting my 1st message. Please note we have problems with our Biege G3's and not G4's.

I'm uncertain as to whether it's the onboard VRAM (only 2MB) with the ATI 3dPro or the actual amount of physical RAM installed. Although most of the machines have around 200MB in them but as they are older G3's I was wondering if they would resolve the problem if given more? Sometimes redraws are slow due to RAM or VRAM - which do you reckon?

Link to comment

Thank you Honourable TiTaNiuM sAMuRai:

I haven't given them as much as 500MB VM as they only have around 200MB of physical RAM installed.

I have already given them similar amounts of Min/Max memory allocation. Do you think the workstations would benefit from me setting them up with a 2nd partition on the internal HD as a dedicated scratch disk to cache to? I know another HD would be better but it's a cost "thang"?

Link to comment

If they had only 64MB, you would still give them tons of virtual mem.

I don't know if the Mac handles caching in the same manner as Windows, so I don't know if a separate drive dedicated to a cache would be, indeed, dedicated.

I'm wondering if the honourable Katie knows for a fact that the undos affect redraws. Undos should be written to a cache file. Redraw is access to video memory. I don't see the corellation. Then again, I don't know how NNA cooks its spaghetti, so never mind. wink.gif" border="0

Do you know the video ram speed of the G3s' video chips?

Link to comment

Oh, and about more RAM:as you suggested, the mainboards may not be able to handle more.

The only other thing I can guess at is what extensions OS9 added, if any. I don't know how the upgrade affects video (items other than the actual chip drivers). It may also be the Carbon Lib having now to do a bit of gymnastics for the older hardware. Have you checked with Apple?

Link to comment

We've noticed a correlation to the number of undo's and refresh rate. The more that is stored in cashe, the slower the redraw.

In the majority of the instances where a redraw was slow, we lowered the max number of undos and it alleviated the problem. The next hope was to update the video driver.

Unfortunately, there are some known problems with the G3 beige video drivers in VW 8.x which may be causing the slow redraws.

[ 02-04-2002: Message edited by: Katie ]

Link to comment

I reckon I've cracked the redraw problem at last and thanks TiTaNiuM sAMuRai for your assistance.

I'm only part time contract at problem location so sorry for slight delay in response. Before leaving on Monday (last day I logged in) I had the opportunity to test my theory as one of the older G3 workstations wasn't in use due to illness.

I fitted a Ratoc usb/firewire card and backed up the entire workstation on external firewire HD. I also fitted a VillageTronic MPDD+ PCI graphics upgrade card to compare results.

I then erased the HD and re-initialised it as two seperate partitions, although I think having two actual HD's would be better.

I then did a clean install of 9.2.1 making surte to include the IX3D card drivers as a custom install procedure. After completing the whole install process I rebooted and rebuilt the desktop. Once back up and running I went to Virtual Memory and follow TiTaNiuM sAMuRai's advice about giving the system a huge VM but set it up to run from the smaller 500MB "scratch" disk I had just created.

I then also followed Katies advice and went into VW 8.5.2's preferences and lowered the undo's from 20 to 12 and some of the other 2D and 3D resolution standards.

After another reboot and desktop rebuild for good measure the systemwas running well. I further increased the performance by lowering the colours from 1000's to 256 and then the system flew!

The real test will come later today as the absent workstation user is back in and using his computer.

Thanks to both TiTaNiuM sAMuRai and Katie for both of your suggestions. Hopefully this work round will keep our aging G3's working until later in the year before upgrading becomes inevitable. By doing this I will save my contract employer largish amounts of money now and the replacement workstations towards the end of the year will be cheaper as the new G5's will be out by then and the existing G4's will have dropped in price.

Thanks again! cool.gif" border="0

Link to comment

I didn't have to add any more RAM or VRAM! Even with the existing 2MB VRAM on the Motherboard and working on A1 & A0 sized drawings the redraw speeds were fine. Also RAM for old biege G3 desktops isn't that cheap nowadays - at least not here in the UK.

I didn't even need to keep the VillageTronics graphics card in the unit, it was so quick!

Cheers and thanks to all contributors!

grin.gif" border="0

Link to comment

I am using VW 9.5 at home on a 9500/Powermax 400 G3 with 512 megs of ram plus a ATTO Ultra SCSI board with a high speed HD. At work I have a powermac G4 733 w/768 megs of ram. Both machines are running system 9.1. My machine at home has a ATI rage 128 with 32 megs of vram. The machine at work has a standard issue NVIDIA display card. I have worked on the same files on both machines and I am sorry to report that the difference is slight. I have even made simple sample files and timed them. It may be VW or System 9.1 or both but I have yet to be blown away by the new hardware. I am also using FormZ on both machine an I can say the same for it too. Where's the beef. As a long time 3D VW user, you can speed up redraw by deleting extra points when creating polygons. Efficient building will help but until we can get multiprocessing working for us we are stuck waiting.

Bob Tiedemann

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...