Jump to content
  • 0
Sign in to follow this  
Horst M.

Text Fields iimported with dwg Files way too long

Question

Hallo,

If i import dwg Files I always have the Problem that the

Text fields are way longer than the text inside.

This leads all the time to unwanted selection and to a disaterous look in bigger Zoom States.

Is there a possibility to "shrink" all the Fileds to the size needed by the text except selecting each text Object and adjust it manually?

Share this post


Link to post

8 answers to this question

Recommended Posts

  • 0

Horst

I've seen this issue before. Turned out to be a font issue. Changing the font of the text box seemed to help. At least temporarily.

hth

mk

Share this post


Link to post
  • 0

I've tried your suggestion.

unfortunately no change if I change the Font.

I tried also to edit the Font Mapping for the import no change.

The text boxes are still 5 to 10 times longer than they must be, an therefore all over the drawing.

Share this post


Link to post
  • 0

That is annoying. But different from the problem I was having.

In my drawing the text boxes extended to the ends of the universe.

Does changing the justification move the text all the way to one side of the text box?

Share this post


Link to post
  • 0

The Textboxes behave completely normal, if I scale the Text, change the position

I was shure that other users have the Problem also, at least sometimes.

So I'm a bit surprised.

May be it has something to do with the way the texboxes are created in ACAD, bcause it happens just to some Files (approx. 30%), and it happens to Files from different Sources, so it is not caused by one Supplier.

I tried many things with the Sclaing of import, but I had no succes until now.

Share this post


Link to post
  • 0

It happens to me and it's always from the same people. I usually don't need the text so I do a custom selection and delete it all.

If you do a custom selection of text and uncheck Wrap Text it will get rid of the long text box, but may be worse that way as some text will be all in one line.

Share this post


Link to post
  • 0

Ray, that did it!

Thanks!

Will I ever lern to look, see this Checkboxes and think about their use if have such a Problem?

I also need the Text mostly for my orinentation (which isn't too good as you see), so I also deleted the texts most of the times.

But those Architects have once in a wihle the tendency to put usefull informations in this Fields....

With your checkbox method had this 2500 text boxes aligned, and just the texts inside symbols weren't effected, which is no Problem.

Thanks again.

by the way: 2011 does it right; saw that today as i was testing....

Edited by Horst M.

Share this post


Link to post
  • 0

Ooops...

Is there a default setting f?r the Way texts are improted from dwg?

Where?

? sometimes I feel so ... Blind!

Sigh!

Share this post


Link to post
  • 0

It sounds to me as if it could be that the texts are AutoCAD MTEXTs (Multiline text) and then the text boxes in VW will keep the size of MTEXT box. Depending on import scale settings this may cause the text boxes to become/remain very large in VW.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...