Jump to content
Sign in to follow this  
GRC

jagged edges on cylinder

Recommended Posts

I have drawn a piece of pipe. !0.375" OD, 10.02" ID x 42" extrude.

It looks awful. It is a octagon shaped pipe.

I tried setting the preferences/3D/conversion res to "very high".

Made no difference.

I set the document Preferences/Resolution to Full resolution and the outputs to 300DPI. I know this is for printing, but thought I would try it anyway, since I can't get anything else to work.

Ideas?

VW09

PM G5 Dual 2GHz

3GB

Share this post


Link to post

Are your rendering in OpenGL? If so check your settings for this. I think the default setting is low. Set this to High or Very High and also click on anti-aliasing.

Share this post


Link to post

i too have suffered from this problem for ages.

All the prefs set up as you suggest on high or max settings, but, to no avail.

Not sure about anti-aliasing though, i"ll have to check.

Share this post


Link to post

Pretty sure it's in one of the more obscure settings, i have seen it. If however if you want a quick fix you can always convert to nurbs ...

Share this post


Link to post

Try this. Go to the 'teakettle' (render) pull-down menu on the top bar, right. At the bottom of the menu you'll find 'Open GL Options...', and there choose the level of Detail you want. (this only works if you firs select Open GL as your rendering mode).

Share this post


Link to post

I also have this issue. I have tried all the settings and nothing works I have presumed it is a 2010 bug.

I have recently upgraded to 2010 from 2008 and am very disappointed.

Unfortunately I was sold version 10 a couple of months before 2011 came out and missed out on the free upgrade by weeks. I have lost faith in Vectorworks really.

I have installed the SP4 so it is as up to date as it can be.

I linked to an example image to explain my problem relating to this issue.

https://files.me.com/hamlindesign/232ccl

I will attach it also...hopefully

I don't have access to 2008 anymore for comparative purposes.

I have an extrude that is made up from lines and curves joined.

Problem-When i fillet the edge of the curve and render it on screen it is very faceted instead of smooth? but if you render the edge UN-filleted it is fine!!! I have made sure all settings are thus:-

I REALLY have exhausted all settings on this.!

3D conversion res Very high

2D conversion res very high

Quarts imaging & anti aliasing on ( on or off make no noticeable difference )

Mesh smoothing makes no noticeable difference

Open GL Options very high

Not relevant but Output setting are high 600dpi

I really cant understand what the problem is? Its not something I have ever had unresolvable issues with before..is it a bug or a graphics card issue?

I am very disillusioned with Vectorworks and down about this version. I regret staying loyal for so long. It cost a lot of money and I can't produce something so simple!!

Another thing is the attributes/images mapping is a nightmare!

I much prefer the old method that was in 2008! I do lots of point of sale and retail so I use graphics a lot and it is rubbish now! I see from other posts I am not alone with this and wonder if it is better in 2011?

I resent paying more money for un upgrade to 2011...2010 is not fit for purpose in my opinion with so many issues.

Share this post


Link to post

Tim,

Fillet and Chamfer Tools have long been cause for lament and discussion.

i don't know if you've already tried this(i'm still using 2009), but i assume you drew a 2D object then used Extrude Command. This being the case, select it, choose the Edit Command and when at the level of the 2D object use the Reshape Tool. Oh Yeah! Edit a Copy!!

This may have changed since 2009, but VW had a habit of increasing the number of points on custom 2D objects after extrusion(not always but usually one the causes of hickups like these) select the Delete Points Tool from the bar(if it's still there) and with patience remove as many points as you can without causing the object to stray from the desired form.

If this still doesn't remedy your problem, joins in the 2D Object may need more scrutiny Zooming in to a microscopic level in order to show more superfluous points. A little tedious but it usually gets rid of most undesirables and allows a better finish under OpenGL.

i had hoped that the Fillet Tool had lost these idiosyncracies, let's hope 2011 has improved things. i should be able to check this for myself next week . . . . .

Hope my mumblings have been of some use . . . . .

:)

Share this post


Link to post

Hi Your mumblings are much appreciated. Nice to know I am not alone.

My joins are fine so its not that. I did go back in and remove some of the corner points and yes It it is much better and less noticeable when zoomed out.. thank you .(I have done this before in the past but didn't relate it to this issue)

You would of thought this had been sorted out by now! fingers crossed for 11

I would be interested to know if the animation preview works in 11 as it does not in 10 ( I had this confirmed as a problem from my reseller!! )

I also really struggle with the crazy Mapping setup in 10 so I hope thats better also .....they say it is improved.... mmm I am sceptical.

Many Thanks again for your reply

T

Share this post


Link to post

Glad i could be of help, but like you say Tim, an improvement, but hardly acceptable.

:confused:

Let hope for 2011 and 2012

Andi

Share this post


Link to post

I think there is a bigger problem somewhere with my machine or version or something.

if i have something as simple as a circle and extrude it it renders fine. if I then subtract a solid from it it then render it again I get drastic jaggedness going on.

I found an old 2008 VW file and rendered that in best quality renderworks with the highest settings compared it to a saved render jpg from the original VW 2008

It is almost as if my preference settings are stuck or not working.

I even tried a reinstall! just as a desperate measure. I am worried its a Graphics card issue now but that should only effect Open Gl in a worse case scenario and I have never used that mode...

I think I will put post onto the 3D modelling section and see what people say What do you think?

Cheers

Tim

Share this post


Link to post

By all means post it Tim, but in the meantime i think you may get some good feedback directly from CU seeing as you reside on this side of the Pond.

Have you tried calling the 3D team?

Share this post


Link to post

I'm just doing some 3-d object editing, and finding the same problem but MUCH worse: I've added/subtracted extrusions several times, and the jaggedness is severe, pretty much making the sheet layers useless. Maybe I've missed some other setting, but I think I've set everything to high, etc. Fast machine with good graphics. The problem crops up even on-screen in sheet layers, so it's not about pdf output or anything.

It may be that it "recorded" the quality settings while the objects were being added/subtracted, so subsequent improvements to quality don't matter. I don't know: did anyone else figure anything out about this?

Keith

Share this post


Link to post

Keith,

This seems to be a constant downfall with VW.

i've recently upgraded both my machine and VW and am still testing both 2010 and 2011 and despite the fact that many seem to give positive feedback on these releases the render factor, even though stated as a known problem in OpenGL, definitely needs attention.

2010 even displays some jagged "curves" in wireframe.

Please NV, talk to us!

In the meantime Keith, post a "Bug Report"! :)

Share this post


Link to post

Hi Tim

See reply below from nemetschek. They say that at the moment custom

renderworks is the best solution at this moment.

Kind regards

++++

_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

++++ ++++++

Tech support

COMPUTERS l UNLIMITED

Hi ++++,

There are no settings that can be changed for final quality rendering. In

2011 with Custom Renderworks the edges look better (See the attached image)

and with Final Quality in 2011 in the edge looks the same as the Custom

Renderworks rendering in 2010. So the client is correct. In the long term

using Custom Renderworks is not the ideal solution but at the moment it is the best solution.

I asked if what they were saying was that there IS a recognised problem with 2010 but after this they are not replying to any emails.

I Don't see how they can expect me to use something so bad commercially!!

see attached example screen shot and a VW file if anyone fancies a gander.

This can't be as good as I can expect it to be after spending ?1827.12 as recently as the end of June 2010

No one is bothered after you have it it seems..the problem it seems is it is not up to the task but they bang them out anyway.

10 Years of loyalty to Vectorworks...I feel sick and it stinks!!

Share this post


Link to post

For the record, I asked tech support about this.

Pretty simple: I had the sheet layer page resolution set at 72 dpi.

I can go to tools/organization/sheet layers/edit, and change the dpi (300 is probably fine, though I played with 1200 and it does matter on zooms, as far as I can tell, but that's probably just a screen thing, not a print thing, assuming you've got your scales right).

Anyway, just wanted to set the record straight. This is painfully obvious once I actually look at it.

Share this post


Link to post

In section viewports, you can actually set the 3D conversion resolution for each individual viewport in the Advanced Section Properties in the OIP.

Why this is not possible for regular viewports must come down to an oversight by NNA. Keith W's solution seems only to be applicable to the bitmap output and not hidden line renderings.

Share this post


Link to post

So, did anyone get a positive result from this one???

:)

Edited by AndiACD

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×