Jump to content
Sign in to follow this  
Yoginathaswami

Jagged 3D object in viewport

Recommended Posts

Aloha, what should I do to have the rendered objects show up smoothly in a viewport. I tried changing the dpi of the sheet layer to 1200 and various rendering option but the image still shows up jagged in my viewport. Attached is a sample file. Thank you so much!

Share this post


Link to post

Have you tried it in Final Quality Renderworks? Did you update the viewport after the change? Could you post a screen shot?

Share this post


Link to post

Hi Ray,

Yes, I tried Final Q. Renderworks and did update the viewport. See the attaches jpeg file. It was a screen shot after updating the FQR..

Btw, it looks great in the Design Layer! Only in viewports.

Edited by Yoginathaswami

Share this post


Link to post

It has me stumped, it looks good on my end. Maybe there is something wrong with the object, try recreating it.

Share this post


Link to post

Aloha Yogi, No problem here with your original file. See attached (from your VP on Sheet Layer, with Fast RW's)... I cannot seem to reproduce your (funky) results...

Share this post


Link to post

Aloha, Peter:

Thanks...

I tried a complete shutdown and restart?no change.

I also did the "Permission Repair" and booted the computer on a single user mode (in UNIX) and ran the Disk Repair. No improvement either.

There are some improvement when I change the background of my VW window to white instead black background?the white hides the jaggy edges...this is not really a solution

I even reset my VW preferences but still no change.

My rendering in the Design Layer is very sharp.

I noticed the DPI of the Sheet Layer impacts the result of the viewport rendering. When I increase it to 1200 it improves?still not as good as you would have in DL. I wonder what is your SL DPI setting? Was there any significant difference in your rendering results when you compare your DL and SL results?

Any other thoughts? Anyone?

Edited by Yoginathaswami

Share this post


Link to post

The DPI setting is a document setting so we get the same as you do on the file. You shouldn't need to go to 1200 DPI, the rendering times are huge. I've never seen this problem before and again, I'm baffled. Maybe moving this to the Renderworks forum will get the right eyes looking at it. Would you like me to do this?

Share this post


Link to post

Aloha Yoginathaswami:

Change the viewport to have a solid fill. When bitmap objects and viewports have their fill set to None then white areas of the bitmap are drawn as transparent. This can be handy with white backgrounds but looks weird like this in black background. HTH!

Share this post


Link to post

Aloha, Dave:

Thank you so much! That helps...Do you know if it is possible to get crisp output in the viewports as we see in the DL? Is this just my settings or universal end result for all VW users?

Share this post


Link to post

Aloha, Ray:

So it is just on my Mac...Bummer!

I messed around with all the settings i.e. preferences that I know will have an impact on rendered output...don't know what else to do.

Perhaps, reinstall VW...but I am not prepared to do it right now.

Share this post


Link to post

Kind of looks like the white background brings it out more, but to me they are pretty much the same.

Share this post


Link to post

Try this: Under the Sheet Layer tab in the Navigation pane, right-click the Sheet Layer that your Viewport is on and select Edit. Change dpi from the default (72 dpi) to something higher (300 dpi worked for me) and update the viewport.

Hope that helps!

Share this post


Link to post
When bitmap objects and viewports have their fill set to None then white areas of the bitmap are drawn as transparent.

Sorry Yoginathaswami to jump in on a different angle: when I saw your post Dave I was hopeful for a simple way of rendering a model with a transparent background for dropping into a site photo. Exporting the vp with fill as None and as a png (which should support transparency) there is still a white background to the image. I also tried it the other way around: instead of composing in Photoshop, I imported the image into VW and placed the render on top. It worked, but there is a white anti-alias blurry edge to the model..so back to square one having to extract foreground material from a background by hand in Photoshop.

Share this post


Link to post

Hi Yoginathaswami,

MCheng's advice had no effect? Setting the sheet layer DPI (where the viewport resides) should have a direct effect on the resolution of the rendering.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...