Jump to content
  • 0
Bob-H

Apple Numbers Worksheet support needed

Question

I was recently trying to import a Numbers table into a Vw Worksheet. I thought it would be a simple task of copy and paste, as I have done before with AppleWorks spreadsheets. To my surprise, I cannot copy and paste a Numbers table into a Vw Worksheet. I ended up exporting from Numbers into an Excel file, opening NeoOffice, copying the data, and pasting it into the selected range of the Vw Worksheet.

There has got to be more up to date improvements between iWork and Vectorworks worksheets. I know the Excel support has always been there, but it's all we have now, since AppleWorks is no longer valid.

Share this post


Link to post

21 answers to this question

Recommended Posts

  • 0

Not seeing the problem here.

I just created a new Numbers table. Selected an area and copied.

Went to a new VW2010 document with a new empty worksheet. Pasted. I got all of the data values, both static and the result of formulas. The formulas themselves were lost.

The one error I did get was when the VW Worksheet was smaller than the selected area in Numbers. As soon as I made the worksheet larger the past worked fine.

What exact steps are you following that make it fail?

Share this post


Link to post
  • 0

Thanks for looking into it, Pat.

The problem is, the copied text from a Numbers table may paste into the Vw worksheet (version 2010), but it only does it in a single column. But most of the time, the data does not paste, and the error message "Paste will not fit into selected cells". This is for text in multiple columns.

Try this: in Numbers, copy three rows and three columns of text. Then select three rows and columns in a Vw worksheet and paste. The "will not fit" message pops up. Then, if you select only one cell in the Vw worksheet, and paste, all of the data is pasted in a single column.

Like I said before, the only workaround to this is to use the Excel format, and it works fine.

Share this post


Link to post
  • 0

Again, not what I am seeing.

Select an area in Numbers. Select a single cell in Worksheet. Paste.

As long as the height and width of the selection fit within the area of the worksheet it pastes fine.

Select an area in Numbers. Select a range in Worksheet the same dimensions as the selection. Paste.

Fits fine.

Do you possibly have hidden rows/columns in your Numbers that are making the actual area bigger than you think?

Share this post


Link to post
  • 0

For a test, I made a Numbers spreadsheet from a blank template. This is in Numbers "09. I entered text (numbers 1-9) and copied 9 cells (3x3) in the middle of the sheet.

And then in Vw2010, I made a worksheet in a blank file, and selected 9 cells (3x3) for the paste command.

As before, I get an alert sound and the "will not fit" message.

Then I tried selecting only one cell in the Vw worksheet, did a paste, and now I get the "will not fit" message instead of a vertical paste I got before.

I don't think there are any "hidden rows/columns" in the middle of the Numbers SS. The only paste I'm getting in Vw is a bitmap of the table. But if I go to an OpenOffice spreadsheet, the text does paste into a table.

The problem seems to be in the Vw worksheet. If there is some setting I'm missing, I'm open to suggestions.

Share this post


Link to post
  • 0

I just uploaded a short Quicktime movie (2:17) showing what happens for me when I copy and paste data from Numbers into a VW2010 Worksheet.

It is available at:

http://www.vectortasks.com/Movies/Movies.html

It is the last movie at the bottom of the page.

Other than what I am showing, I don't understand what is different between what we are doing. If we can get a repeatable case of your copy/paste failing we need to submit it as a bug so it can get fixed.

Share this post


Link to post
  • 0

I saw the video, and did the same procedure tonight, but I still get the "will not fit" alert instead of the paste.

I was wondering if the problem is with PTH Pasteboard Pro (which I am using - you don't appear to have it). I can't think of anything else.

Share this post


Link to post
  • 0

Could very well be Pasteboard Pro. Can you try turning it off and see what happens?

Does it have an option to mark either Numbers or Vectorworks as a special case and turn itself off when you use them?

Share this post


Link to post
  • 0

I filtered Numbers out of the PTH Pasteboard, but it didn't help.

Getting back to the copied data, I pasted it into a Stickies note, and it showed up as the table. And the same results happen in TextEdit. But when I copy the cells of that same table in Stickies or TextEdit, and try to paste the same range of cells in the Vw worksheet, the "will not fit" alert pops up. But Numbers, Stickies, and TextEdit all exchange pasted table cells with no problem.

I'm ready to chalk this one up as a Vw program error.

It could be that one of the VW interface settings is causing my problems. I turned off all of the snaps, and got the vertical, single column paste back (instead of the columns and rows). The core of my problem seems to be that Vw worksheets can paste a single column of data (from Numbers), but not rows.

Edited by Bob-H

Share this post


Link to post
  • 0

Here are two originally blank files, one a Numbers '09 and the other a VwA2010, in a ZIP file.

The ZIP file has a ".gif" extension, which must be changed to ".zip" in order to open. I had to do this, because the File Manager does not recognize Numbers files, or files with ".zip" extensions.

I already tried to paste the 3x3 range from Numbers, and Vw would not let me do anything, not even a vertical past this time. Strange! :(

Edited by Bob-H

Share this post


Link to post
  • 0

Could this be a fonts conflict issue after upgrade to 10.6? I am dealing with one now. Try the Font Book functions to switch off duplicates, and look at the Validate list. Safe Mode then Normal restarts also recommended to clear the font caches.

-B

Share this post


Link to post
  • 0

All of the fonts are valid, as checked by Fontbook. And I used Onyx to delete the font cache, and restarted. Same results.

I also tried some of my other Numbers spreadsheets (copy cells, etc.), and they all had the now familiar "Paste will not fit in selected cells" alert. The only variation is that selecting a single cell will paste the data into a column of cells.

I guess I will just do the workaround, and copy and paste Numbers data one column at a time.

Share this post


Link to post
  • 0

It works properly for me.

Try creating a new user account and see if it pastes properly from there. If it does, then it is something you have installed on your system.

Share this post


Link to post
  • 0
It works properly for me.

Try creating a new user account and see if it pastes properly from there. If it does, then it is something you have installed on your system.

I made a new user account, but it didn't change the pasting problem any. It's got to be some preference or configuration in Vw that's causing it. The data does paste into a spreadsheet in NeoOffice, using the test account.

If I get the time, I'll look into whether a missing font is causing the bug. I did remove Marker Felt recently, however unlikely that it may be the cause.

Share this post


Link to post
  • 0

Any chance this has been fixed in the past decade?

 

Experiencing the same copy / paste issue from Google Sheets into a VW worksheet:

 

1694614152_ScreenShot2021-04-20at8_34_04PM.thumb.png.3c2ddf2682d61814f0b7a96ca8b9e84f.png

 

1967208083_ScreenShot2021-04-20at8_36_07PM.thumb.png.cf3e662c48e0b04ea7ea61502204de75.png

Share this post


Link to post
  • 0

@Mark Aceto One thing to try, and I know it's a bit of a pain in the ass, but I think VW might require you select the range to paste into and that it has to match the copied selection.  For example, if you're copying A1:D10 in Excel, you need to make sure that you have a 4x10 grid of cells selected in VW before trying to paste the data, otherwise you'll get the warning you show above.

 

If you're already doing that, then there may very well be a bug in VW.

  • Like 1

Share this post


Link to post
  • 0

@Jesse Cogswell I already did that. The interesting / frustrating thing is that I can paste 1 row at a time without issue. And none of the rows cause an issue (process of elimination). So the issue seems to be with pasting more than 1 row at a time. I'll file a bug report when I find the time...  

Share this post


Link to post
  • 0

Dumb question, you don't have any hidden columns/rows or merged cells in your Google Sheet, do you?  I copy and paste things from Excel a lot, but don't think I've ever tried from Google Sheets.

Share this post


Link to post
  • 0

@Jesse Cogswell correct. I even created a shuttle file (pasted the cells in a new tab) before copy / pasting into VW. The key factor for me is that I can copy / paste each row, one at a time, but I get the error message if I try to paste 2 or more rows at a time.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...