Jump to content
Sign in to follow this  
P Retondo

Import NURBS objects?

Recommended Posts

I've been working between VW 10.5.1 and Rhino to create a 3d model of a curved lattice-work railing. Rhino can map a complex flat surface onto a curved surface, but I can't find a way except through .dwg import and export to get the objects back into VW, which then come in as 3d polys or meshes, not nurbs. Is there any way to do this? Does VW import IGES files, and would this help?

Share this post


Link to post

Biplap & Kaare, where do I find the command to import an IGES file? I can find "Export IGES" under File->Import/Export . . . oops, I found it in my Workspace editor and added it to the menu!

But the object I get, although it is identified as a NURBS surface, is "kinky," not smooth the way it looks in Rhino. The nurbs curves that aligned with the surface in Rhino are no longer aligned, and are composed of a series of chords. Is there some kind of limitation involved here? Degree, number of nodes, something else?

Share this post


Link to post

It may be that the criterion for detecting discontinuity on a surface is different in VW from that in Rhino. So a surface may appear continuous and smooth in Rhino and the same surface may appear segmented and divided into several sub-surfaces in VW. Is this what you are seeing. May be you can send me the IGES file so that I can take a look.

Share this post


Link to post

quote:

Originally posted by P Retondo:

Biplap & Kaare, where do I find the command to import an IGES file? I can find "Export IGES" under File->Import/Export . . . oops, I found it in my Workspace editor and added it to the menu!

But the object I get, although it is identified as a NURBS surface, is "kinky," not smooth the way it looks in Rhino. The nurbs curves that aligned with the surface in Rhino are no longer aligned, and are composed of a series of chords. Is there some kind of limitation involved here? Degree, number of nodes, something else?

What is your 3-D conversion resolution preference set to? Select the File->Preferences->VectorWorks Preferences... menu item and check what it's set to under the 3-D tab. If it's low or medium, raise it.

Share this post


Link to post

Andrew, good thought, but I already tried that to no effect. Biplab, I will send you the two files so you can see what I'm talking about. Your description sounds very close to what I'm seeing. I don't have your email, however.

[ 09-10-2004, 01:43 AM: Message edited by: P Retondo ]

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...