Jump to content

Plant symbol linework disappears when Enable 2D rendering is on

Doug L

Recommended Posts

What causes the interior linework of plant symbols to disappear when Enable 2D Rendering is checked on in the Object Info palette?

(sorry, I think this question has been asked before, but Search does not find any).

This is very strange: I have 2 different trees, Sequoia and Western Red Cedar, both on the same class and layer, and both use a copy of the same tree symbol from the resource browser, but are different size diameters. When 2D Rendering is OFF for each tree, the interior symbol linework is there. When 2D Rendering is ON for each tree (to display shadows), the interior linework is only there for the Sequoia.

Link to comment
Doug hi how are you doing

Try editing the plant geometry - right click the plant and edit

does it show up again?

Thanks Ozzie, doing great. When I do that, and go to Edit / 2D Graphics, the interior line work (and color fills) shows up there. But after closing the edit screen, it goes away.

Also, when you mouse over the 2 different trees, a square bounding box appears around the Sequoia, but not around the Western Red Cedar. Might be a clue....attached is a sample file that shows this....

Just noticed that in Edit / Definition / Render, when I uncheck Mass Overlapping Plants, the interior fill becomes visible! Is this a feature, or a bug, that overlapped massed plants don't contain any interior linework or fills? Thanks again.

Link to comment
  • Vectorworks, Inc Employee

Basically, you should not check Mass Overlapping Plants. It's a real red herring and left over from the way plant symbols used to work in the older versions. Now, you should just use the 2D Rendering and control what's visible using the Plants-Components-... classes.

If you turn on Mass Overlapping plants, it hides all geometry except the rear-most polygon on the symbol. If that happens to be white, you will also lose colour.

  • Like 1
Link to comment


In Edit with say the smaller right plant - 1-T-TP you have Classes - Plants-Component-Outline - the outline of the Plant and several objects in Class Plants-Component-Canopy

With your 1-T-TP go into Edit Plant and select one of your Plants-Component-Canopy Classes and send it to the back and fiddle with those Classes also back and front

I think what Tamsin says about Mass Overlapping Plants is correct but maybe goes beyond that

Link to comment

Thanks Ozzie and Tamsin. These are default VW symbols, didn't edit or change them, but yes, when I select a tree canopy fill class object and send it to the back, it does show up when Mass Overlapping plants is On. However, with evergreen conifer trees, the canopy is made up of 3 separate concentric polygons, like contours, and only one of them shows up at a time, whichever is sent to the back! Which results in a doughnut tree symbol (or doughnut hole)!

So when setting up plants, it seems best to leave Mass Overlapping plants OFF, and only turn it ON when specifically needed as an outline for that plant only, which may be useful on occasion. Or just control the class visibilities for the whole file.

Edited by Doug L
Link to comment
  • 8 years later...


I am having the same problem when plants are massed they loose their line weight. Problem is I need my plants massed I have turned off plant - component - outline, this allows massing but I am still unable to change the line weight.

Any suggestions? 

Link to comment
  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...